LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   No wifi as root (https://www.linuxquestions.org/questions/bodhi-92/no-wifi-as-root-4175640824/)

grenier 10-21-2018 08:43 AM

No wifi as root [solved]
 
Hi everyone,
I've got a weird problem and I hope someone will be able to help me.
I've just installed bodhi 5.0 on my x260 with no special problem, but right after rebooting I realized I couldn't access the network as root.
More specifically, after login in I can connect to the wifi network with no special issue and use with Midori, but no action with root privilege can connect. That means neither updater nor package installer nor apt. I've tried using the last both with a sudo command and after login in as root using su in a terminal. I'll note that I did make sure to allow access to the network connection to other users in the network configuration interface.

Any idea on how to correct that problem ?

business_kid 10-21-2018 03:15 PM

Have you tried it by hand as root? Kill the network, see if the wifi is spotted by the kernel
Code:

iwconfig <wifi_device>
e.g. iwconfig wlan0
You can usually connect with a line like
Code:

wpa_supplicant -i<wifi_device> -Dwext -c/path/to/wpa_supplicant.conf && dhcpcd <wifi_device>
It will probably puke, but the errors will be interesting.

ondoho 10-22-2018 03:02 AM

are you saying you're logging into the grahical desktop as root?
because i'm pretty sure you shouldn't be doing that.

apart from that, network connections always require elevated privileges.

yancek 10-22-2018 09:29 AM

Read the section at the link below labelled Why you don't have a root password. Did you enable root and create a root password (see second link below)?

https://askubuntu.com/questions/4442...lems-with-sudo

https://askubuntu.com/questions/4442...lems-with-sudo

Not sure I understand your problem but you should be able to install software in a terminal with the apt commaand using sudo and your primary user password.

grenier 10-22-2018 10:15 AM

Oh boy. And here I thought I was just asking for some technical answer. I didn't expect to be lectured on my usual use of my laptop...
So, just in case: no I didn't graphically log in as root, I simply did it in a terminal wit the 'sudo su' command (although I will enable standard root login through su once I take the time to do so. I loathe the constant use of sudo).
Appart from that, no, as I said in my first post, I couldn't use apt since no elevated privilege action (i.e. root level action) could access the network.

Anyway, it appears there must have been a problem while installing as after going for a reinstall, the bug solved itself.

Thanks for the attempt to help, especially to business_kid.


All times are GMT -5. The time now is 07:16 AM.