LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Mouse Pointer Issue (https://www.linuxquestions.org/questions/bodhi-92/mouse-pointer-issue-4175672161/)

loki_unbound 03-28-2020 09:11 PM

Mouse Pointer Issue
 
Hello everyone,

I am a first time poster and apologize if this question has been asked before. I have searched online but couldn't find anything to specifically address the problem.

I am visually impaired and so have been into the Bodhi mouse settings (currently running Bodhi 5.1.0) and changed the settings to make things bigger. On the desktop and menus this is fine. However, when I open a program/app (e.g. Firefox, LibreOffice, etc.) the pointer reverts to a tiny black pointer when I mouse over it. I believe this is perhaps the "X" theme setting, even though I have the "Moksha" theme setting selected in the options.

Does anyone know how I can change this to make it uniform, so the larger mouse pointer and Moksha theme also are applied on an open program/app?

Any help would be appreciated, so thank you in advance.

ferrari 03-29-2020 11:25 PM

Uniformity with applications built on different frameworks can be a challenge. Firefox and LO are GTK apps, so this web page may be of guidance although YMMV...

https://ubuntu-mate.community/t/make...-emerald/10555

In particular, this section may be relevant....

Quote:

Step 3 will be handled in "etc/gtk-3.0/settings.ini"

Go to “etc/gtk-3.0” and open the “settings.in” file in root (remember the “Open as administrator,” method, with “caja-extension-gksu” - if you prefer to do it that way)

Now, in root, in the “settings.ini” file, carefully modify the values of the gtk-cursor-theme-name to what you want (there, your other gtk-theme values can, likewise, be modified, if you wish). Again, in all of my examples, here, I will be using "size “16” and “redglass” - and due to user preferences, yours will look a little different; but you can figure out where to switch-out these values by the example, below:

“/etc/gtk-3.0/settings.ini”

[Settings]
gtk-theme-name = Numix
gtk-cursor-theme-name = redglass
gtk-cursor-theme-size = 16
gtk-icon-theme-name = GNOME-Noble
gtk-fallback-icon-theme = gnome
gtk-enable-primary-paste = false
Hopefully, you can tweak the cursor them size according to your requirements.

Good luck with your endeavours here.

ferrari 03-29-2020 11:30 PM

BTW, along with a system-wide config (etc/gtk-3.0/settings.ini), I have a user-configuration as well (~/.config/gtk-3.0/settings.ini), so check for the existence of this as well perhaps.


All times are GMT -5. The time now is 01:10 AM.