LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 01-17-2020, 01:56 AM   #1
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Rep: Reputation: Disabled
how to set network? where's nm-applet?


after booting into Bodhi moksa desktop,
there's only a quickstart guide telling me that
all I need to do is left-click on an nm-applet icon

but the problem is : there isn't such an icon there.
https://s2.ax1x.com/2020/01/17/lz0k1H.png


after some time, I found that if I logout ,
and then login again, using 'bodhi' and blank password,
then, this nm-applet icon appears, and it works.

https://s2.ax1x.com/2020/01/17/lz0F9e.png

or, without logout, it works if I execute command 'nm-applet' manually

why?

it's latest 5.0 and I tried in both vmware and laptop
 
Old 01-17-2020, 05:06 PM   #2
rbtylee
Bodhi Developer
 
Registered: Jun 2018
Location: Ladson, SC US
Distribution: Bodhi
Posts: 304

Rep: Reputation: 310Reputation: 310Reputation: 310Reputation: 310
Quote:
Originally Posted by bakui View Post
after booting into Bodhi moksa desktop,
there's only a quickstart guide telling me that
all I need to do is left-click on an nm-applet icon

but the problem is : there isn't such an icon there.
https://s2.ax1x.com/2020/01/17/lz0k1H.png


after some time, I found that if I logout ,
and then login again, using 'bodhi' and blank password,
then, this nm-applet icon appears, and it works.

https://s2.ax1x.com/2020/01/17/lz0F9e.png

or, without logout, it works if I execute command 'nm-applet' manually

why?

it's latest 5.0 and I tried in both vmware and laptop
Are you using the live ISO? I note you say log in with blank password.


Anyway that happens to some users. I think it is related to this known issue: Implement X-GNOME-Autostart-Delay


So if you are using the live ISO and BOdhi is not installed and you want to install it. Go ahead and install it and see if the issue persist on an actual install.

If the issue does persist, be sure your system is up to date. Then open with a text editor as root /usr/share/applications/nm-applet.desktop and add the line:

Quote:
X-GNOME-Autostart-Delay=5
Now reboot and see if the issue persist. If it does increase the delay. Hopefully this will help.
 
1 members found this post helpful.
Old 01-19-2020, 06:58 AM   #3
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
yes it's live ISO. add
X-GNOME-Autostart-Delay=60 not work
 
Old 01-19-2020, 07:17 AM   #4
rbtylee
Bodhi Developer
 
Registered: Jun 2018
Location: Ladson, SC US
Distribution: Bodhi
Posts: 304

Rep: Reputation: 310Reputation: 310Reputation: 310Reputation: 310
Quote:
Originally Posted by bakui View Post
yes it's live ISO. add
X-GNOME-Autostart-Delay=60 not work
I did some research on this issue yesterday. It is complex problem and can not be fixed on the live ISO without making another ISO.
 
Old 01-19-2020, 10:30 AM   #5
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
when doing iPXE live netboot, it’s easy to change scripts in initramfs,
by adding more overlay cpio initrd image, without making another ISO
 
Old 01-20-2020, 11:27 PM   #6
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
where'e the hidden first script to run Midori?

when first boot, there's only a quickstart guide midori, no nm-applet,
and when logout and login again, there's nm-applet, and no quickstart guide midori.

ps -aef showd there's a process: sh -c file:///...quickstartEN
I thought there must be some script to run only once at first boot.
and I want to change that script, to run nm-applet, instead of midori.

tried grep -rI quickstartEN / but didn't find this script,
only a config in /etc/skel/.config/midori
 
Old 01-21-2020, 02:01 AM   #7
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
though I didn't know the very script to run midori,
since I dont't want midori to run, and I want nm-applet to run,
so, simply, I changed command 'midori' to run nm-applet, '
and it works!

in /tmp/abc I see midori is called by /init, username is bodhi

I just add some these lines after mount_images_in_directory :

Code:
mount_images_in_directory "${livefs_root}" "${rootmnt}"
mv /root/usr/bin/midori /root/usr/bin/midori2
echo echo $0 \>   /tmp/abc   > /root/usr/bin/midori
echo whoami  \>\> /tmp/abc  >> /root/usr/bin/midori
echo sudo rm -f /usr/bin/midori  >> /root/usr/bin/midori
echo sudo mv /usr/bin/midori2 /usr/bin/midori >> /root/usr/bin/midori
echo sleep 5                >> /root/usr/bin/midori
echo xrandr -s  1440x900    >> /root/usr/bin/midori
echo nm-applet              >> /root/usr/bin/midori
chmod +x /root/usr/bin/midori

Last edited by bakui; 01-21-2020 at 04:07 AM.
 
Old 01-21-2020, 02:04 AM   #8
bakui
LQ Newbie
 
Registered: Jan 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
X-GNOME-Autostart-Delay this only work after logout.
maybe ugly, but it works. I just want it to show up in live mode, without logout.
 
Old 01-21-2020, 07:54 AM   #9
rbtylee
Bodhi Developer
 
Registered: Jun 2018
Location: Ladson, SC US
Distribution: Bodhi
Posts: 304

Rep: Reputation: 310Reputation: 310Reputation: 310Reputation: 310
Quote:
Originally Posted by bakui View Post
though I didn't know the very script to run midori,
since I dont't want midori to run, and I want nm-applet to run,
so, simply, I changed command 'midori' to run nm-applet, '
and it works!
Interesting approach. There is no script to run our quick start guide in midori. This is 'hard-coded' in Moksha to run after first boot.
 
1 members found this post helpful.
Old 02-04-2020, 12:07 AM   #10
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, Bodhi, Debian, Mageia, OpenMediaVault, Q4OS
Posts: 133

Rep: Reputation: 20
Had this issue on an old Intel Atom netbook. Nice job men
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Adding panel applet crashed cinnamon, how do I delete applet from fallback mode? matt00 Linux - Newbie 2 02-25-2014 09:38 AM
AWN Dock AWN Main Menu applet : could not create applet AMA Linux - Software 10 09-08-2011 07:20 AM
[SOLVED] nm-applet and battery missing from indicator applet in lucid someshpr Ubuntu 2 11-16-2010 06:02 PM
Network Manager Applet (nm-applet) dwhitney67 Linux - Newbie 5 02-02-2010 12:20 AM
Java applet error: "Applet Failed" nro Programming 1 08-28-2004 06:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 01:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration