LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   grub grml iso rescueboot saga continues (https://www.linuxquestions.org/questions/bodhi-92/grub-grml-iso-rescueboot-saga-continues-4175678104/)

prices1950 07-03-2020 03:10 PM

grub grml iso rescueboot saga continues
 
BLUF - Still trying to install Bodhi legacy on my old laptop. CD only and no USB boot device so trying to use grml rescueboot

I worked past the issues I had getting the ISO boot to start. The installation fails with a number of errors. Here is a record of an install attempt. I am now trying to find the referenced logs to see if they add anything interesting. The logs appear to be from the restart of Bodhi without installing...

Here is the sequence:

Window title >>> Install (as superuser)

Error popup >>> ubi-language failed with exit code 1. Further information may be found in /var/log/syslog - continue anyway?

Keyboard layout selection window - English (US) English (US) is selected by default

Error popup >>> ubi console setup failed with exit code 1. Further information may be found in /var/log/syslog - continue anyway?

Window title >>> Updates and other software
Download updates while installing Bodhi (Selected by default)
Install third party software for graphics and Wi-Fi ... (not selected)

Continue

ubi-partman failed with exit code 10. Further information may be found in /var/log/syslog Do you want to try again.. If you do not, your installation may fail entirely or may be broken.

try again - same message

Where are you - default New York ( that is correct)

Continue

ubi-timezone failed with exit code 1 ...

Continue anyway

Who are you
Stephen
Latitude-C640
prices1950
log in automatically

Continue

Getting time from network time server... (started at 15:13)
Start slide show...

Slide show completes
"The installation will finish soon. We hope you enjoy Bodhi Linux"

15:20 - "skip" waiting for time server after no response.

A terminal like text section appears in the bottom of the display areas. The last line is:
bodhi rsyslogd: file "9" write error: No space left on Device[v8.32.0 try[]

>>>> All activity stops here

Looking for suggestions as to how to proceed. This takes about half an hour to get this far in the install process

cordx 07-03-2020 05:54 PM

Quote:

Originally Posted by prices1950 (Post 6141102)
write error: No space left on Device[v8.32.0 try[]

that sounds like you ran out of space on your hard drive. i believe i recall you mentioning something similar in your previous grml thread when trying to install mint.

prices1950 07-03-2020 07:13 PM

First little step - plenty of disk space, well at least 15 gig available.
I had done a gparted split of the primary partition into 2 partitions one for a dedicated Bodhi partition a while back. I went back to a single large partition when I was getting the out of space errors.

Seems like the out of disk space reported error was a permissions trickle down of some kind...
I changed the permissions on the ISO to 777 and tried the install again. I think it is related to me being the owner because I copied it to the system and I am not a superuser in the Mint install. Fewer errors but then the install complained about not being connected to the internet. My bad, I forgot the plug the cable back in. I said continue.

Then I got a partition error telling me that there was only one partition.

I am going to repartition the disk back to a 15 gig space for the install of Bodhi and then try again.

I will continue this thread for a while or until the space issue errors are resolved.

colorpurple21859 07-03-2020 10:59 PM

how much memory is on this system?

prices1950 07-04-2020 01:06 PM

Sys Mem is 348MB - I know it is small but I thought it was enough...

colorpurple21859 07-04-2020 01:25 PM

apparently it isn't and that is your problem, I know the website says 256, but if your system is sharing with the video adaptor, you have less than 348mb. If your tring to install from a live session that also cuts down on usable memory,
before you start the installer what is the ouput of free

prices1950 07-04-2020 02:11 PM

Hmm...
Not sure what indicator you see that points to an available memory issue. Pls share if it something solid, if just experience that is fine too.


Output from /$> free

Mem: 379892, 91508, 18568, 3840, 269816, 273824
Swap:1498108, 273372, 1224736

This is running Bodhi in live mode from the iso.

I have been trying to get the network running since I always seem to fail while trying to get time from a network server. I'm not sure but I think the installer is also trying to get a package list from a ubuntu package server. So far I am not having any luck in that department either.

I have tried install from the grub grml rescue boot and from a live session. Similar results in both cases, but they are a little different.

colorpurple21859 07-04-2020 02:22 PM

base on what you posted in your first post, if you don't have enough ram, the issues that you have are a result of not enough ram, based on experience

cordx 07-04-2020 03:43 PM

Quote:

Originally Posted by prices1950 (Post 6141462)
Sys Mem is 348MB - I know it is small but I thought it was enough...

the bodhi system requirements page also goes on to say this about the installer and available ram/swap:
Quote:

*Note: the installer runs best with the availability of greater than 1 GB of RAM if your system does not meet this specification, please ensure your swap space + RAM capacity is large enough to accommodate before running the installer. You can adjust your swap to a smaller size post install if desired. Also, closer to 2 GB of RAM (or swap space + RAM) for the installer will ensure optimal performance.
i could have sworn that i read somewhere before that the ubiquity installer (which bodhi uses like ubuntu) requires 1 gb of ram. i didn't bookmark that so i can't offer a source, but this statement makes it sound like at least adding swap might make things easier on you.

enigma9o7 07-06-2020 11:36 PM

If I were in your position, after trying intalling again without booting live (just install from startup menu), would to be install slitaz (or maybe puppy, or old version of bodhi that fits on cd) to get grub installed, and to use use it to download bodhi iso and follow instructions like https://help.ubuntu.com/community/Grub2/ISOBoot to boot iso with grub, i.e

Hold shift while first booting, then press c when GRUB menu appears, then:
Code:

loopback loop (hd0,5) /home/prices/Downloads/bodhi-5.1.0-legacy.iso
linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/home/prices/Downloads/bodhi-5.1.0-legacy.iso noprompt noeject
initrd (loop)/casper/initrd
boot

and select install from the menu.


All times are GMT -5. The time now is 10:02 AM.