LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 07-15-2018, 12:20 PM   #1
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 92

Rep: Reputation: Disabled
Graphics Problems. Nvidia 6100


Clean 5.0RC 64-bit install on AMD Athlon 64 with NVidia 6100.

I get weird video glitches I don't exactly know how to describe. Flickers and lines, copies of whole windows appearing and disappearing, etc. It happens all the time, but so far I've noticed it the worst when terminal is scrolling text (like during apt update) and I have a browser open.

Based on what I think I've learned, I'm using the built-in neavuoa drivers which should work fine, but if I want better performance I could use nvidia drivers. The latest version for my chipset is 304 and last updated in 2017. Since built in is not working fine, I tried to install nvidia-304 and that won't install.

So looking for advice - is there anything I can do to fix the neavou? Is installing nvidia a good idea, if so, how?

<I'll copy/paste the exact response to apt-install in next message>.
 
Old 07-15-2018, 12:42 PM   #2
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 92

Original Poster
Rep: Reputation: Disabled
Code:
bodhi@AMD64:~$ sudo apt install nvidia-304
[sudo] password for bodhi:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package nvidia-304 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nvidia-304' has no installation candidate
bodhi@AMD64:~$ sudo add-apt-repository ppa:graphics-drivers/ppa
 Fresh drivers from upstream, currently shipping Nvidia.

## Current Status

Current short-lived branch release: `nvidia-396` (396.24)
Dropped support for Fermi series (https://nvidia.custhelp.com/app/answers/detail/a_id/4656)

Current long-lived branch release: `nvidia-390` (390.48)
Old long-lived branch release: `nvidia-384` (384.130)

For G8x, G9x and GT2xx GPUs use `nvidia-340` (340.106)
For NV4x and G7x GPUs use `nvidia-304` (304.137) End-Of-Life!

Support timeframes for Unix legacy GPU releases:
https://nvidia.custhelp.com/app/answers/detail/a_id/3142

## What we're working on right now:

- Normal driver updates
- Help Wanted: Mesa Updates for Intel/AMD users, ping us if you want to help do this work, we're shorthanded.

## WARNINGS:

This PPA is currently in testing, you should be experienced with packaging before you dive in here:

Volunteers welcome! See also: https://github.com/mamarley/nvidia-graphics-drivers/

### How you can help:

## Install PTS and benchmark your gear:

****sudo apt-get install phoronix-test-suite

Run the benchmark:

****phoronix-test-suite default-benchmark openarena xonotic tesseract gputest unigine-valley

and then say yes when it asks you to submit your results to openbechmarking.org. Then grab a cup of coffee, it takes a bit for the benchmarks to run. Depending on the version of Ubuntu you're using it might preferable for you to grabs PTS from upstream directly: http://www.phoronix-test-suite.com/?k=downloads

## Share your results with the community:

Post a link to your results (or any other feedback to): https://launchpad.net/~graphics-drivers-testers

Remember to rerun and resubmit the benchmarks after driver upgrades, this will allow us to gather a bunch of data on performance that we can share with everybody.

If you run into old documentation referring to other PPAs, you can help us by consolidating references to this PPA.

If someone wants to go ahead and start prototyping on `software-properties-gtk` on what the GUI should look like, please start hacking!

## Help us Help You!

We use the donation funds to get the developers hardware to test and upload these drivers, please consider donating to the "community" slider on the donation page if you're loving this PPA:

http://www.ubuntu.com/download/desktop/contribute
 More info: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Ign:1 http://packages.bodhilinux.com/bodhi bionic InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://packages.bodhilinux.com/bodhi bionic Release
Get:4 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Hit:5 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease
Get:6 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Ign:7 http://packages.bodhilinux.com/bodhi bionic Release.gpg
Get:8 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease [21.3 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Hit:10 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease
Get:11 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main i386 Packages [13.1 kB]
Get:12 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages [14.1 kB]
Get:13 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main Translation-en [4,644 B]
Fetched 300 kB in 6s (49.0 kB/s)
Reading package lists... Done
Code:
bodhi@AMD64:~$ sudo apt install nvidia-304
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23
              Depends: xserver-xorg-core but it is not going to be installed
              Recommends: nvidia-settings (>= 331.20) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
bodhi@AMD64:~$
And Synaptic wants to remove everything:

https://i.imgur.com/lBB7JKw.jpg

Last edited by enigma9o7; 07-15-2018 at 12:46 PM.
 
Old 07-15-2018, 04:41 PM   #3
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 92

Original Poster
Rep: Reputation: Disabled
I installed the nvidia drivers following this procedure: https://adufray.com/blog/2018/06/02/...-127-on-bionic
but still have same video glitches. In fact they seem worse. Hmmmmm....
 
Old 07-17-2018, 12:34 AM   #4
gdesilva
LQ Newbie
 
Registered: Jul 2018
Distribution: Ubuntu Studio, Linux Mint, Slitaz, Linuxlite
Posts: 3

Rep: Reputation: Disabled
I have an old nVidia Geforce Go 7950 GTX - works without any issues on Mint 18.3 but cannot install the nvidia-304 driver on Bodhi - no error messages displayed but lsmod does not show the nvidia module (nouveau is not replaced). Has anyone got any suggestions?

Thanks
 
Old 07-17-2018, 01:28 AM   #5
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 92

Original Poster
Rep: Reputation: Disabled
That procedure I linked worked perfect for me on 5.0. Did you try it? The only thing that tutorial didn't mention was that you have to exit the x-server before installing the nvidia drivers, using the command 'sudo service lightdm stop'

The way I did it, change your download directory and username as needed:

download nvidia driver from: http://www.nvidia.com/download/drive...x/123709/en-us
save patch from: https://adufray.com/nvidia-304.137-bionic-18.04.patch

sudo nano /etc/modprobe.d/disable-nouveau.conf
COPY/PASTE:
blacklist nouveau
blacklist vga16fb
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist amd76_edac
options nouveau modeset=0
SAVE/EXIT (CTRL-X)
sudo apt install gcc make build-essential gcc-multilib dkms mesa-utils
cd /home/bodhi/Downloads
./NVIDIA-Linux-x86_64-304.137.run -x
cd ./NVIDIA-Linux-x86_64-304.137
patch -p1 < ~/nvidia-304.137-bionic-18.04.patch
sudo update-initramfs -u
reboot

After reboot you'll be in some lower resolution video driver, goto terminal and run:

sudo service lightdm stop

Press CTRL+ALT+F2

login: bodhi
cd /home/bodhi/Downloads/NVIDIA-Linux-x86_64-304.137
sudo ./nvidia-installer
reboot
 
Old 07-18-2018, 04:29 AM   #6
gdesilva
LQ Newbie
 
Registered: Jul 2018
Distribution: Ubuntu Studio, Linux Mint, Slitaz, Linuxlite
Posts: 3

Rep: Reputation: Disabled
@enigma9o7, Many thanks. It did work for my 32 bit installation with the appropriate file names. Compiling failed when I tried to select the automatic compilation option when kernel changes but it is not a big deal to re-compile with each kernel change.

Thanks for your suggestion and sharing the links.
 
Old 07-20-2018, 12:15 AM   #7
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 92

Original Poster
Rep: Reputation: Disabled
The nvidia drivers didn't fix the video issue I initially installed them for, and caused new issues. VLC complained about missing codecs. MPV missing librararies. I was chasing workarounds and decided just to go back to default since nvidia didn't help anything for me anyway, and now vlc/mpv working again, etc.

So my advice, don't install nvidia using that method unless you want to keep solving new problems. It also makes it harder to remove since it wasn't installed by package manager.

Also, my video issue is magically fixed. Dunno exactly how. Cuz when I was trying to restore default I kept trying different advice I read online about how to restore nouveau and I'm guessing something I did along the way fixed it.
 
Old 07-20-2018, 01:13 AM   #8
gdesilva
LQ Newbie
 
Registered: Jul 2018
Distribution: Ubuntu Studio, Linux Mint, Slitaz, Linuxlite
Posts: 3

Rep: Reputation: Disabled
@enigma9o7, thanks for the advice. I was trialing Bodhi and LinuxLite and found that LL is easier to configure (standard Ubuntu layout) than Bodhi although Bodhi was slightly better when it came to boot time. So I have decided not to pursue with Bodhi at this time. I also found that tweaking Moksha was a challenge particularly since I am not used to it.

Thanks again for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Intel Iris Graphics 6100 driver Toonses82 Linux - Hardware 10 04-04-2016 07:55 PM
Recommended NVIDIA driver (v 180) not working with NVIDIA 6100 card MagicT Linux - Newbie 4 07-28-2009 07:39 AM
Nvidia GeForce Go 6100 / 6150 lazylogic Linux - Hardware 5 11-21-2007 05:36 AM
First no cursor, now graphics distortion. nVidia 6100 tobitron Linux - Newbie 1 09-07-2007 12:27 PM
HP Omnibook 6100 graphics problems knuhe Debian 0 05-24-2006 01:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 08:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration