LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 01-12-2016, 07:29 PM   #1
morganjeff7272
Member
 
Registered: Dec 2015
Location: Oklahoma City
Distribution: Ubuntu
Posts: 38
Blog Entries: 2

Rep: Reputation: Disabled
Fresh install a couple of issues to deal with


1. pcmanfm context menu issues
The custom sommand doesn't work for instance I left click on a text document
select custom command, type in sudo vim %f and either or check mark terminal
nothing happens

The launch terminal here wants to run x-terminal and not terminology
I switched the line in /etc/xdg/libfm/libfm.conf "terminal=terminology %s"
Had no effect.

As per pcmanfm run as root command I created /home/ep/.local/share/file-manager/actions/openFolderRoot.conf
Code:
[Desktop Entry]
Name = Open as Root
Tooltip = Open the folder as root
Icon = terminal
Profiles = on_folder;

[X-Action-Profile on_folder]
Name = Open as Root
MimeTypes = inode/directory;
SelectionCount = 1
Schemes = file;
Exec = sudo pcmanfm %f
This did nothing to the context menu no new entry

Can you help me fix the above issues
 
Old 01-14-2016, 07:19 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,359

Rep: Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980
Your post is not clear to me, but I get the impression you're trying to alter system wide settings with stuff in you ~/ directory - is that so?

It may not work. Why not go at the system settings?
 
Old 01-14-2016, 04:15 PM   #3
morganjeff7272
Member
 
Registered: Dec 2015
Location: Oklahoma City
Distribution: Ubuntu
Posts: 38
Blog Entries: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
Your post is not clear to me, but I get the impression you're trying to alter system wide settings with stuff in you ~/ directory - is that so?

It may not work. Why not go at the system settings?
Well lets narrow it down and trouble shoot one thing at a time two of the problems might get fixed by fixing terminal.
I dont really dare which terminal I use. So maybe the easiest fix would be to install x-terminal and remove terminology.

But where would I change the setting system wide for context menu launch terminal from here for PCmanFM. I changed the system setting for libFM and it did not change the PCman FM.

basically right clicking on a folder and choosing launch terminal from here. Is trying to launch x-teminal-* and since terminology came pkgd with bodhi would like for it to launch instead. Where would I find that setting.
 
Old 01-22-2016, 09:16 AM   #4
morganjeff7272
Member
 
Registered: Dec 2015
Location: Oklahoma City
Distribution: Ubuntu
Posts: 38
Blog Entries: 2

Original Poster
Rep: Reputation: Disabled
I renamed the following file /home/ep/.config/libfm/libfm.conf to libfm.conf.bak after that When I opened up pcman fm it regrabbed the main config file I had already edited from /etc/xdg/libfm/libfm.conf And now terminology opens at command right click a folder and select run terminal from here.

So now I just need to figure out how to add context menu type commands like run as root
 
Old 01-22-2016, 12:27 PM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,715
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
Quote:
Originally Posted by morganjeff7272 View Post
1. pcmanfm context menu issues
The custom sommand doesn't work for instance I left click on a text document
select custom command, type in sudo vim %f and either or check mark terminal
nothing happens
i see no "select custom command" when i left-click (or right-click) any document in pcmanfm.
please clarify.

Quote:
The launch terminal here wants to run x-terminal and not terminology
I switched the line in /etc/xdg/libfm/libfm.conf "terminal=terminology %s"
Had no effect.
scary! no need to mess with system settings. pcmanfm has a preferences dialog that will allow you to set the desired terminal.

Quote:
As per pcmanfm run as root command I created /home/ep/.local/share/file-manager/actions/openFolderRoot.conf
Code:
[Desktop Entry]
Name = Open as Root
Tooltip = Open the folder as root
Icon = terminal
Profiles = on_folder;

[X-Action-Profile on_folder]
Name = Open as Root
MimeTypes = inode/directory;
SelectionCount = 1
Schemes = file;
Exec = sudo pcmanfm %f
This did nothing to the context menu no new entry
using sudo here won't work because you'd need a shell to enter the password. try "gksudo" instead.
this, however, does not explain why you don't even get a new entry.
i have never used that feature of pcmanfm myself and would be interested to see how you solve it.
 
Old 01-23-2016, 11:56 AM   #6
morganjeff7272
Member
 
Registered: Dec 2015
Location: Oklahoma City
Distribution: Ubuntu
Posts: 38
Blog Entries: 2

Original Poster
Rep: Reputation: Disabled
Hey Ondoho Thanks for the reply.
Backwards on your post from end to beginning.

I changed the sudo line to esudo because that is packaged with bodhi linux. and by changing the file name from .conf to .desktop and reopening a file manager window that worked. So the extra or new context menu item must be ~/.local/share/file-manager/actions/FileName.desktop

In pcmanfm my version is 1.2.0 under tools menu I have a run command context item. I can run the commands there for instance if I am in a folder that has a file text.txt, I can type in the comman "esudo epad text.txt" and get it to open as root in epad the text.txt file. So that is my work around right now.

I think I might have some mixed context menu items not sure I have a context menu item "enlightenment file manager" which is the bundled file manage for bodhi I did not like it. so I got pcmanfm. that might be why I have a conext menu item when I right click on a file or folder "select custom command" Not sure.

Anyway in the select custom command window I should be able to go to the second tab and type in like above paragraph esudo epad f to open the file selected. but nothing happens.
 
1 members found this post helpful.
Old 01-23-2016, 06:39 PM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,715
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
Quote:
Originally Posted by morganjeff7272 View Post
by changing the file name from .conf to .desktop and reopening a file manager window that worked. So the extra or new context menu item must be ~/.local/share/file-manager/actions/FileName.desktop
thank you so much, i'm using this now!
 
1 members found this post helpful.
Old 01-24-2016, 08:48 AM   #8
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,359

Rep: Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980Reputation: 980
You guys are scaring me away big time from messing with gnome or kde. All that mucking just to get basics going.
 
Old 01-24-2016, 10:36 AM   #9
morganjeff7272
Member
 
Registered: Dec 2015
Location: Oklahoma City
Distribution: Ubuntu
Posts: 38
Blog Entries: 2

Original Poster
Rep: Reputation: Disabled
Hey Bussiness Kid gnome or KDE has nothing to do with My adjustments here. This is just for the file manager GUI there are many flavors just like many linux distrobution packages. and ... Right this moment I am using moshka and enlightenment not gnome and kde
 
Old 01-24-2016, 03:49 PM   #10
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,715
Blog Entries: 7

Rep: Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401Reputation: 2401
Quote:
Originally Posted by business_kid View Post
You guys are scaring me away big time from messing with gnome or kde. All that mucking just to get basics going.
u trollin?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 17 fresh install issues tw1tch Linux - Newbie 9 01-12-2013 07:16 PM
Fresh install issues jimtherabbit Fedora 12 08-07-2007 04:56 AM
Fresh install, after a couple of boots, goes through bios check then, blank screen! Dachy Slackware 1 02-10-2006 03:10 AM
Driver Issues after fresh install kysen Debian 1 04-16-2004 01:21 AM
Fresh install of Slackware 9.0...couple questions tarballed Slackware 6 05-21-2003 03:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 01:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration