LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 07-16-2020, 01:04 AM   #1
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 236
Blog Entries: 32

Rep: Reputation: 44
Disable touchpad


Somewhere I found a way to write a key binding to turn my touchpad on and off, and now I can't find it. (I have two machines, both with Bodhi, and have it fixed on one but can't repeat the fix.) Can anyone help with this? I found the key bindings but no setting for touchpad.
 
Old 07-16-2020, 01:26 AM   #2
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 696

Rep: Reputation: 158Reputation: 158
i use the synaptic drivers for my touchpad. those include a command line program that can be used to turn the touchpad on and off. i have never done so by key binding, but you could probably use a script. xinput would probably also be an option.
 
Old 07-17-2020, 02:51 AM   #3
questionsBot
Member
 
Registered: Jun 2020
Posts: 94

Rep: Reputation: Disabled
I use a app called touchpad-indicator... it places a small icon on the systemtray (though I run it hidden). You can make it do a ton of things.. like making a hotkey to turn on and off the touchpad, auto disable when typing and auto disable when you plug a mouse into it.

Code:
sudo add-apt-repository ppa:atareao/atareao
sudo apt update && sudo apt install -y touchpad-indicator
Just run these two commands to add the ppa to BodHi and then install the app. You will need to add the app to the "startup applications" section of the settings to make it load each boot. I run it without the icon in view, (right-click the system tray icon and select hide)... but you can run with it visible as well. If you edit the .desktop file you can change the icon as well.
 
1 members found this post helpful.
Old 07-17-2020, 04:28 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,904
Blog Entries: 9

Rep: Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208
Quote:
Originally Posted by cordx View Post
i use the synaptic drivers for my touchpad. those include a command line program that can be used to turn the touchpad on and off. i have never done so by key binding, but you could probably use a script.
This.
And it does it automagically.
It's called syndaemon.
 
Old 07-18-2020, 08:07 PM   #5
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 236

Original Poster
Blog Entries: 32

Rep: Reputation: 44
Quote:
Originally Posted by ondoho View Post
This.
And it does it automagically.
It's called syndaemon.
OK, how do you use it? I opened a terminal and typed "sudo syndaemon", hit Enter and entered my password... and the cursor just blinks and blinks, nothing appears to happen.
 
Old 07-18-2020, 08:10 PM   #6
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 236

Original Poster
Blog Entries: 32

Rep: Reputation: 44
Quote:
Originally Posted by questionsBot View Post
I use a app called touchpad-indicator... it places a small icon on the systemtray (though I run it hidden). You can make it do a ton of things.. like making a hotkey to turn on and off the touchpad, auto disable when typing and auto disable when you plug a mouse into it.

Code:
sudo add-apt-repository ppa:atareao/atareao
sudo apt update && sudo apt install -y touchpad-indicator
Just run these two commands to add the ppa to BodHi and then install the app. You will need to add the app to the "startup applications" section of the settings to make it load each boot. I run it without the icon in view, (right-click the system tray icon and select hide)... but you can run with it visible as well. If you edit the .desktop file you can change the icon as well.
This appears to work, thank you, even though it does not answer my original question, which was how to make a key binding to do this. I will be happy for the solution you provided.
 
Old 07-19-2020, 04:30 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,904
Blog Entries: 9

Rep: Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208Reputation: 4208
Quote:
Originally Posted by zaivala View Post
OK, how do you use it? I opened a terminal and typed "sudo syndaemon", hit Enter and entered my password... and the cursor just blinks and blinks, nothing appears to happen.
Why do you think you need sudo for this?
Anyhow, read 'man syndaemon'. No hotkeys, it does it automagically.
Only works if you use the synaptics driver anyhow.
Enter 'synclient' to find out.
BTW many touchpads have a "PalmDetect" setting that does roughly the same. More reading: https://wiki.archlinux.org/index.php...palm_detection
 
Old 07-19-2020, 07:32 AM   #8
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 696

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by zaivala View Post
OK, how do you use it? I opened a terminal and typed "sudo syndaemon", hit Enter and entered my password... and the cursor just blinks and blinks, nothing appears to happen.
checking with synclient is a good way to find out if you are using the synaptics driver first.

i use the syndaemon -i 0.5 -t -K -R -d (man syndaemon, as suggested, will describe the options) because it detects when i am typing and temporarily disables tapping and scrolling. it's not always perfect, but works well enough to soften most of the rough edges.

since you specifically want to be able to set a key binding, you might be able to (if you are using the synaptics driver) use something like synclient TouchpadOff=1 to disable and synclient TouchpadOff=0 (man synaptics or here to check out available options) to enable it.
 
Old 07-21-2020, 12:00 AM   #9
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 236

Original Poster
Blog Entries: 32

Rep: Reputation: 44
Quote:
Originally Posted by cordx View Post
checking with synclient is a good way to find out if you are using the synaptics driver first.

i use the syndaemon -i 0.5 -t -K -R -d (man syndaemon, as suggested, will describe the options) because it detects when i am typing and temporarily disables tapping and scrolling. it's not always perfect, but works well enough to soften most of the rough edges.

since you specifically want to be able to set a key binding, you might be able to (if you are using the synaptics driver) use something like synclient TouchpadOff=1 to disable and synclient TouchpadOff=0 (man synaptics or here to check out available options) to enable it.
OK, I typed syndaemon WITHOUT sudo, and the same thing happened: new line with the cursor blinking, and nothing else. And yes, I ran synclient and it is running synaptics.

Syndaemon, according to your beloved man page which you would rather send people to than talk to them, only controls touchpad use WHILE TYPING. I would like the pad disabled. Period. That does not appear to be possible with this daemon.
 
Old 07-21-2020, 12:07 AM   #10
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 236

Original Poster
Blog Entries: 32

Rep: Reputation: 44
questionsBot provided a workable answer. Thank you. It was not the answer I found before, but that is not being found.
 
Old 07-21-2020, 12:29 AM   #11
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 696

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by zaivala View Post
according to your beloved man page which you would rather send people to than talk to them
i have added two previous posts trying to help so i'm not sure why you seem to have taken exception the most recent.

mind you, i'm not the one who commented about sudo (though it is true) and didn't copy and paste from the man page because it appeared to me that syndaemon was not what you were after. you had asked how it worked in a previous post

Quote:
Originally Posted by zaivala View Post
OK, how do you use it?
so i was sharing my experience in case it might be helpful.

i added the part about synclient (related to syndaemon, but a different command entirely) because (on my system at least) it can absolutely disable the touchpad.

Quote:
Originally Posted by cordx View Post
since you specifically want to be able to set a key binding, you might be able to (if you are using the synaptics driver) use something like synclient TouchpadOff=1 to disable and synclient TouchpadOff=0 (man synaptics or here to check out available options) to enable it.
i included the part about the man page there and a link to same because touchpadoff has three options, but those two seemed like the ones you were looking for

Last edited by cordx; 07-21-2020 at 12:31 AM. Reason: clarity
 
1 members found this post helpful.
  


Reply

Tags
bodhi, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 10:51 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 03:15 PM
IBM laptop & touchpad & TrackPoint - touchpad doesn't work! espinosa_cz Linux - Laptop and Netbook 1 08-20-2004 12:45 PM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 02:19 PM
USBmouse/touchpad together, touchpad behaves erratically Pathian Mandriva 2 01-07-2004 02:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 08:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration