LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 04-05-2020, 08:18 PM   #1
wimc
Member
 
Registered: Oct 2018
Location: Washington State
Distribution: Bodhi 5.1.0-64 hwe
Posts: 40

Rep: Reputation: 11
Couple of startup questions


1. there is at startup a 5 second delay. If possible, change to 0?

2. also, a few errors show during startup, no way to capture what they are, tried to use a digital camera to capture them 12 times and they always black (blank). Cannot read the errors either, goes by too fast.

The errors DO NOT prevent booting. Just like to know what they are and if able to adjust or fix them.

Thank you...

Bodhi Linux 5.1.0 64 bit.
 
Old 04-05-2020, 09:35 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,188
Blog Entries: 27

Rep: Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828Reputation: 4828
Some error messages during boot are normal. The kernel probes for various items as it boots. Some of those items may not be present, resulting in error messages. These are generally not something to be alarmed about.

You can change the boot delay by editing the GRUB configuration: https://www.howtogeek.com/196655/how...ders-settings/

I would not recommend setting it to zero, as you will then not get the option to select maintenance mode (or whatever Bohdi calls it), in the unlikely eventuality that you will ever need it.

Last edited by frankbell; 04-05-2020 at 09:38 PM.
 
Old 04-05-2020, 09:46 PM   #3
wimc
Member
 
Registered: Oct 2018
Location: Washington State
Distribution: Bodhi 5.1.0-64 hwe
Posts: 40

Original Poster
Rep: Reputation: 11
Figured as much about the errors, operates as usual regardless of the errors.

Remember seeing that link before or at least similar, ~4 years ago.

Appreciate the reply.

Edit: correction, its 3 seconds, grub didn't have a 3 second delay, it showed 10, which I changed to 0 anyway. Bodhi is the only OS in use by the way.

Last edited by wimc; 04-05-2020 at 10:09 PM. Reason: added to post
 
Old 04-05-2020, 10:14 PM   #4
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 466

Rep: Reputation: Disabled
If you do set grub delay zero, you can still get into grub menu if you hold down 'shift' key during boot. Works for me. With SSD I can reboot in less than 30 seconds, don't need a grub delay slowing that down

If you press ctrl-alt-f1 it'll show you what's left from booting in tty1. Sometimes the real errors are left there. On one of my machines for example it always has an error there about usb ports 1-7 over current or something and something about LFENCE not serializing or something... but like frankbell said, they usually can be ignored. To get back to GUI ctrl-alt-f7.

I imagine - but dont know how to do it - all those startup messages can be logged for later review.

Last edited by enigma9o7; 04-05-2020 at 10:18 PM.
 
Old 04-08-2020, 06:35 PM   #5
wimc
Member
 
Registered: Oct 2018
Location: Washington State
Distribution: Bodhi 5.1.0-64 hwe
Posts: 40

Original Poster
Rep: Reputation: 11
Anyone have any kind of clue where this 3 second, screenshot shows 2, but starts at 3.

Best I can do taking this image.
Attached Thumbnails
Click image for larger version

Name:	3seccount.jpg
Views:	20
Size:	42.8 KB
ID:	32932  
 
Old 04-09-2020, 10:53 AM   #6
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 466

Rep: Reputation: Disabled
The delay is the "grub" bootmenu... did you follow the link in your first reply? I didn't, but I assume it's going to tell you to edit grub.cfg and then update grub.
 
Old 04-09-2020, 06:03 PM   #7
wimc
Member
 
Registered: Oct 2018
Location: Washington State
Distribution: Bodhi 5.1.0-64 hwe
Posts: 40

Original Poster
Rep: Reputation: 11
Quote:
Originally Posted by enigma9o7 View Post
The delay is the "grub" bootmenu... did you follow the link in your first reply? I didn't, but I assume it's going to tell you to edit grub.cfg and then update grub.
See post #3 above, edit part of it.
 
Old 04-09-2020, 07:55 PM   #8
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 466

Rep: Reputation: Disabled
You edited /etc/default/grub then ran sudo update-grub, right? Did it give you error about setting to nonzero value balh blah, or no error?

Attach or post /etc/default/grub.
 
Old 04-09-2020, 08:23 PM   #9
wimc
Member
 
Registered: Oct 2018
Location: Washington State
Distribution: Bodhi 5.1.0-64 hwe
Posts: 40

Original Poster
Rep: Reputation: 11
No errors...

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'
#
# bodhibuilder grub file

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -d -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX="quiet"
GRUB_GFXPAYLOAD_LINUX=auto

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_BACKGROUND="/etc/grub.d/backgrounds/grub.png"
It was simple, all it took was changing...
#GRUB_HIDDEN_TIMEOUT_QUIET=true

To
GRUB_HIDDEN_TIMEOUT_QUIET=true

Last edited by wimc; 04-10-2020 at 12:21 AM. Reason: added to post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of thing i need on startup mantonr Linux - Newbie 1 08-29-2006 09:03 AM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 09:54 AM
Couple of easy questions on Suse startup files and QT digitized_funk Linux - Newbie 1 10-15-2003 11:17 PM
A couple questions aceman817 Linux - Networking 2 04-25-2001 06:02 PM
A couple of questions LarcTongi Linux - General 1 03-14-2001 12:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 07:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration