LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Couple of startup questions (https://www.linuxquestions.org/questions/bodhi-92/couple-of-startup-questions-4175672628/)

wimc 04-05-2020 08:18 PM

Couple of startup questions
 
1. there is at startup a 5 second delay. If possible, change to 0?

2. also, a few errors show during startup, no way to capture what they are, tried to use a digital camera to capture them 12 times and they always black (blank). Cannot read the errors either, goes by too fast.

The errors DO NOT prevent booting. Just like to know what they are and if able to adjust or fix them.

Thank you...

Bodhi Linux 5.1.0 64 bit.

frankbell 04-05-2020 09:35 PM

Some error messages during boot are normal. The kernel probes for various items as it boots. Some of those items may not be present, resulting in error messages. These are generally not something to be alarmed about.

You can change the boot delay by editing the GRUB configuration: https://www.howtogeek.com/196655/how...ders-settings/

I would not recommend setting it to zero, as you will then not get the option to select maintenance mode (or whatever Bohdi calls it), in the unlikely eventuality that you will ever need it.

wimc 04-05-2020 09:46 PM

Figured as much about the errors, operates as usual regardless of the errors.

Remember seeing that link before or at least similar, ~4 years ago.

Appreciate the reply.

Edit: correction, its 3 seconds, grub didn't have a 3 second delay, it showed 10, which I changed to 0 anyway. Bodhi is the only OS in use by the way.

enigma9o7 04-05-2020 10:14 PM

If you do set grub delay zero, you can still get into grub menu if you hold down 'shift' key during boot. Works for me. With SSD I can reboot in less than 30 seconds, don't need a grub delay slowing that down ;)

If you press ctrl-alt-f1 it'll show you what's left from booting in tty1. Sometimes the real errors are left there. On one of my machines for example it always has an error there about usb ports 1-7 over current or something and something about LFENCE not serializing or something... but like frankbell said, they usually can be ignored. To get back to GUI ctrl-alt-f7.

I imagine - but dont know how to do it - all those startup messages can be logged for later review.

wimc 04-08-2020 06:35 PM

1 Attachment(s)
Anyone have any kind of clue where this 3 second, screenshot shows 2, but starts at 3.

Best I can do taking this image.

enigma9o7 04-09-2020 10:53 AM

The delay is the "grub" bootmenu... did you follow the link in your first reply? I didn't, but I assume it's going to tell you to edit grub.cfg and then update grub.

wimc 04-09-2020 06:03 PM

Quote:

Originally Posted by enigma9o7 (Post 6109594)
The delay is the "grub" bootmenu... did you follow the link in your first reply? I didn't, but I assume it's going to tell you to edit grub.cfg and then update grub.

See post #3 above, edit part of it.

enigma9o7 04-09-2020 07:55 PM

You edited /etc/default/grub then ran sudo update-grub, right? Did it give you error about setting to nonzero value balh blah, or no error?

Attach or post /etc/default/grub.

wimc 04-09-2020 08:23 PM

No errors...

Code:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#  info -f grub -n 'Simple configuration'
#
# bodhibuilder grub file

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -d -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX="quiet"
GRUB_GFXPAYLOAD_LINUX=auto

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_BACKGROUND="/etc/grub.d/backgrounds/grub.png"

It was simple, all it took was changing...
#GRUB_HIDDEN_TIMEOUT_QUIET=true

To
GRUB_HIDDEN_TIMEOUT_QUIET=true


All times are GMT -5. The time now is 03:14 PM.