LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 09-07-2018, 06:50 AM   #1
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Rep: Reputation: 16
Clipboard issue?


just noticed that when i copied a writer doc and closed it and then tried to paste info into a new writer doc it would not paste. it only works if the original document is open. how do i fix this? i read it was fixed and worked in bodhi 4.5. seems to have gone backwards.
 
Old 09-07-2018, 10:27 AM   #2
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
an update as such. the first experience was trying to paste some stuff on a thread in this forum - just would not do. using chromium. never had an issue with that.

just tried doing it with a mail app and it worked. i pasted the same info into this thread and it worked prior to deleting it because not needed to post info to this thread/forum. So I am not sure what happened earlier this AM all info was from a writer file. Very Strange. might be an issues since i had multiple glitches this morning but now seems to be OK. I never noticed an issue before. anyone else having this issue? Even randomly?
 
Old 09-07-2018, 10:51 AM   #3
Charles4809
Bodhi Developer
 
Registered: Dec 2010
Location: Zeist, The Netherlands
Distribution: Bodhi Linux, Win 10
Posts: 38

Rep: Reputation: 7
no, the clipboard module is loaded by default and I never had issues with it. maybe unloading and reloading the module could be helpful. I use OpenOffice btw, maybe with LibreOffice your results might be different.
 
Old 09-07-2018, 10:56 AM   #4
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
ok - so far i will leave it as is. How do you reload the module? Just in case it happens again. Thank you.
 
Old 09-07-2018, 01:06 PM   #5
Charles4809
Bodhi Developer
 
Registered: Dec 2010
Location: Zeist, The Netherlands
Distribution: Bodhi Linux, Win 10
Posts: 38

Rep: Reputation: 7
Main Menu >> Settings >> Modules, select Clipboard and click Unload, next click apply. The gadget now disappears from the shelf. Modules with a colored dot behind their name are loaded, a grey dot means unloaded.
 
Old 09-07-2018, 01:15 PM   #6
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
thanks and how do you reload then? sorry for being so stupid.

ah Ok just hit load. got you thanks again.

Last edited by hemlocktree; 09-07-2018 at 01:22 PM.
 
Old 09-07-2018, 01:54 PM   #7
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 102

Rep: Reputation: 48
Hello there

The clipboard module is our product (ylee and me) and we know it has some limits or unsolved bugs. The issue with lost clipboard content after closing the window was solved by using the external app called xclip which I call from the module code. Nevertheless in some situations it is not perfect. Look at the bugs reports on github (Libreoffice bug mainly):

https://github.com/thewaiter/Clipboard/issues

Stefan

Last edited by the_waiter; 09-08-2018 at 01:07 PM.
 
1 members found this post helpful.
Old 09-07-2018, 03:03 PM   #8
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
this has been the only anomaly. thanks for the hard work.
 
Old 09-10-2018, 12:15 PM   #9
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 106

Rep: Reputation: Disabled
I noticed this happen sometimes shortly after I first started using bodhi. I just stopped closing things til after I've pasted. I guessed it was cuz I don't have the clipboard thing on my shelf (although the module is loaded).
 
Old 09-13-2018, 05:42 AM   #10
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
It happened again 2x just now, I even unloaded and reloaded the module. I copied a link in chromium and tried to paste into thunderbird. nothing happened just so you know.
 
Old 09-13-2018, 09:56 AM   #11
rrashkin
LQ Newbie
 
Registered: Aug 2018
Location: San Benito, Texas, US
Distribution: Bodhi Linux
Posts: 18

Rep: Reputation: Disabled
In some cases (in both Chromium and Firefox) I get a message that I can't use the menu controls (right click - paste) because something about the clipboard, and I have to use ctrl-V (which invariably works). In other sites/applications it works with right click. I haven't done anything on purpose about the clipboard, just what comes with the installation.

When your problem manifests, can you use ctrl-V?

Last edited by rrashkin; 09-13-2018 at 09:57 AM.
 
Old 09-13-2018, 10:01 AM   #12
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
no and i even tried the right click commands too - weird eh? i know it worked in 4.5 when i used it. never an issue.
 
Old 09-13-2018, 01:59 PM   #13
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 102

Rep: Reputation: 48
@hemlocktree: I've just installed Chromium and Thunderbird to simulate your issue but I am sorry, everything goes well here.
 
Old 09-13-2018, 02:04 PM   #14
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5.0
Posts: 144

Original Poster
Rep: Reputation: 16
Ok thanks stefan. i even tried shutdown and restarting. i tried it again this afternoon 1x and still an issue. i did no real tweaking as such since i do not know a lot so i cannot blame my stupidity as to causing an issue. p.s. everything is updated too - i DO keep on top of that.
 
Old 09-13-2018, 02:10 PM   #15
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 102

Rep: Reputation: 48
Do you still have the same notification in Chromium, there is an issue with clipboard? In case it does not allow you copying the text, it should not be in clipboard menu when you click on the gadget.
PS: if it is not a secret can you post a web link where you have the trouble? Or the troubles are general?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vncconfig - issue with clipboard taylorkh Linux - Software 0 05-05-2018 08:49 PM
Clipboard kaimi.64 Linux - General 1 10-29-2017 10:01 AM
VirtualBox Clipboard issue S3P3HR Linux - Software 1 04-10-2012 03:54 PM
Fedora 8 rdesktop clipboard issue Mr. Swillis Fedora 3 08-27-2009 01:04 PM
cat into the clipboard? stabu Linux - General 2 01-09-2009 05:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration