LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Can't live load Bodhi Linux on Asus T100T (https://www.linuxquestions.org/questions/bodhi-92/cant-live-load-bodhi-linux-on-asus-t100t-4175659872/)

tdrsam 08-27-2019 04:17 AM

Can't live load Bodhi Linux on Asus T100T
 
Not sure what's happening here, but here's what I know so far;

I downloaded Bodhi v5.0.0-64 and Bodhi v5.0.0-legacy but my Asus T100T doesn't seem to wan to boot up the OS.

I'm pretty sure secure boot is disabled and I've tried both the 64bit and 32bit versions but it just boots straight to Windows.

I've got Windows 10. I bought the computer second hand and someone had already put Windows 10 on it.

Any advice would be greatly appreciated.

yancek 08-27-2019 06:17 AM

Have you tested the media (DVD/USB) you are using to try to installl Bodhi on another computer?
Had you verified the download before writing to the DVE/USB?
Have you accessed the BIOS setup to change the boot options to set your media to first boot priority?
When you attempt to boot Bodhi, what specifically happens? ANy messages on screen, just a black screen? More details.

colorpurple21859 08-27-2019 06:24 AM

disable fastboot in windows power settings, and in bios if it exist there also.

.axt 08-27-2019 03:52 PM

The Asus T100T (Intel Atom Bay Trail-T Z3775, 2 GiB RAM less shared mem) as a cheapest notebook has a 32 bit UEFI.

Not installable:
  • 32-bit Linux distributions
  • 64-bit Linux distributions

Installable:
  • 64-bit Linux distributions with integrated 32 bit UEFI boot loader

Only few distributions offer this, sometimes more, sometimes less, Bodhi Linux obviously not.

You now have the choice to use a distribution that comes with a 32 bit UEFI boot loader. Or you can integrate such a bootloader yourself. This isn't easy for the inexperienced. But isorespin.sh can do most of the work, provided you already have a Ubuntu-based (or Debian-based, maybe) system to build.

Another personal word:

I know Bodhi Linux, I recommended it 6...7 years ago, especially for non-PAE systems. But Jeff Hoogland is not reliable for a long time. His unique selling point at that time (Bodhi on ARM-based Samsung Chromebook) was cancelled overnight. The users stood in the rain. He already left his own distribution (x86), came back later, then forked e17 as Moksha, it's all hanging again. One (1!) other developer said in June that he wanted to continue maintaining Moksha/Bodhi. But you don't see anything.

There would be other possibilities for your resource-poor notebook.

tdrsam 08-27-2019 07:24 PM

Thanks for the tips.

yancek:
-Tested the USB on my main laptop. Worked fine so there's nothing wrong with the USB stick
-Works on another laptop and downloaded from the official Bodhi website so doubt it's that
-Yes, changed the boot options
-No messages, no black screen just boots straight to Windows
:(

colorpurple21859:
Hadn't thought of disabling fastboot but when I checked the settings it was already disabled. It's not available in the bios settings, only the windows settings.

Still won't work.

.axt 08-28-2019 03:33 PM

tdrsam, approving of my postings took 23 hours...I have only registered here for giving support for your issue.

Today I've try isorespin.sh in an LBionic64-VM with an LDisco64-Image (isorespin.sh 8.2.8 supports until Ubuntu-based 19.04). If you only want to add the 32 bit bootloader, run through the routine quickly, assuming sufficient resources (CPU cores, RAM, SSD).

But there are many more possibilities (adding packages, removing packages, adding static packages, adding local files, etc.).

Then, of course, it takes longer to specify the right one. You should save the logfile under a different name. It will be overwritten every time.

The whole thing is graphically or non-graphically possible.

On the first run, I wanted to purge a package that is definitely included. There was an error. Abort, no skip.

Further tests have been done. The new image is larger by ~200 MiB on my runs despite removing larger packages. So it is packed worse. Well good.

In the new image both EFI bootloaders, 32 and 64 bit, are available, CSM booting is still possible. Whether everything boots correctly, I cann't say at the moment. I don't have a UEFI32 notebook and we in the company (an IT service store) usually don't either.

colorpurple21859 08-28-2019 04:16 PM

try this http://www.jfwhome.com/2014/03/07/pe...mer-book-t100/

.axt 08-28-2019 04:40 PM

Quote:

Originally Posted by colorpurple21859 (Post 6030733)
try this

That and the newer post linked there are very outdated. In addition, a lot is manual patching or simply does not work.

isorespin.sh, on the other hand, is up to date and integrates required driver packages (e.g. WLAN).

colorpurple21859 08-28-2019 07:13 PM

unless you have your heart set on bohdi, I would suggest Mxlinux 64bit, it has 32bit efi capability.

tdrsam 09-05-2019 03:36 AM

I thought I posted a reply to this thread but I've just realised it's not here. Anyway, here's an update;
I tried Arch, Debian, Mint and Puppy (Bionic & Xenial) but none of those would load at all.
The only distros that'll load are MxLinux and AntiX but neither of those will connect to the wifi.
I'm hoping to find a lightweight distro as there's very little storage on this laptop.
Does anyone know any distros that might load on my machine?

colorpurple21859 09-05-2019 06:39 AM

Quote:

but neither of those will connect to the wifi.
Depending on your wireless hardware, this may be a problem with all distros. Open a terminal and post the output of
Code:

inxi -i

enigma9o7 09-05-2019 11:30 AM

Quote:

Originally Posted by .axt (Post 6030283)
One (1!) other developer said in June that he wanted to continue maintaining Moksha/Bodhi. But you don't see anything.

FYI, I saw something. Moksha update was pushed to main repos a few days ago. https://www.linuxquestions.org/quest...ml#post6032315 along with some other app updates https://www.linuxquestions.org/quest...2/#post6032049

.axt 09-07-2019 01:01 PM

Quote:

Originally Posted by colorpurple21859 (Post 6033404)
Depending on your wireless hardware, this may be a problem with all distros.

Right. Therefore the threadstarter should use isorespin.sh, meaningfully for Lubuntu x64. The appropriate driver package will be integrated into the image. I don't recommend this for nothing.

Btw., is inxi integrated in antiX-/MX-Linux-Images? inxi doesn't exist in every distribution, e.g. not in various arch-based ones, only via AUR. But it doesn't have to be inxi just for identification. Especially if he has to install it first w/o net. 8-)

tdrsam, for installation of needed packages w/o WLAN you could use an adapter USB 2.0 to RJ45-100-Mb/s-LAN (~10 EUR/USD). USB 2.0 because its drivers (asix) are usually included, USB3.x/1Gb/s not yet.

.axt 09-07-2019 01:07 PM

By the way, my recently with isorespin.sh created image (LDisco64) boots with BIOS/CSM, UEFI64 and also, as now tested, UEFI32 (Atom x5).

colorpurple21859 09-07-2019 01:13 PM

Quote:

Btw., is inxi integrated in antiX-/MX-Linux-Images?
Yes it does, along with other tools to help get a system working.


All times are GMT -5. The time now is 09:11 PM.