LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Cannot install 5.0 (https://www.linuxquestions.org/questions/bodhi-92/cannot-install-5-0-a-4175634055/)

enigma9o7 07-14-2018 11:16 PM

Cannot install 5.0
 
I've installed 5.0 legacy on old pentium 4 desktop with 512mb ram, and other than the green theme not working well, no real issues. I'd been using 4.5 legacy for a few weeks prior and got basically familiar with linux/bodhi but far from expert. I'd tried a couple other distros the week prior. So relative newbie. But I'm so happy with Bodhi & Linux, I installed 4.5 64-bit on a newer laptop and will wait for RC2 to try 5 since it's my main pc I've been using windows with and want stability. But, since my kids now fighting over the one desktop I setup, I have another one I decided to revive.

Amd Athlon 64 3200+. Nvidia 6100. 1.5GB RAM. 10 Gig hard drive (from a legacy xbox! I'd already removed the real hard drive years ago and had the 10gig from an xbox I'd pulled it from 20 years ago when upgrading and installing xbmc.) But I digress.

Bodhi 5.0RC 64-bit install attempt. Kernel panic suggests using noapic option. After trying that, another kernel panic and failure.

So what information should I provide?

I decided to make sure the computer was "sound" and install another distro. I'm currently using it to run lubuntu now. The first time I tried to install lubuntu, it did nothing, seem to hang forever. Then I tried the noapic option that bodhi had suggested and was able to complete lubuntu install. Note I used the 'alternate' version, this was because I thought it had less apps pre-installed, but perhaps now after trying to troubleshoot and read I'm confused, maybe it means it had a text based installer. Regardless, it's installed, so this computer does work. But I want to install Bodhi instead since I'm already familiar with it.

I didn't know what a kernel panic was but just for s&g I installed ukuu and installed the latest kernel 4.17.5 and it works fine. Then I installed 4.4, 4.2, 4.0 they all seem to work fine. 3.19 or something wouldn't install. I dunno if that means anything. I went back to the kernel lubuntu came with 4.15 anyways cuz dunno what using other kernels really does.

pan64 07-15-2018 03:42 AM

this kernel panic means (probably) Bodhi has no correct driver for your hardware. Ubuntu could handle it therefore it worked. It is not really kernel related, but a kernel driver module (which was available on ubuntu, but was missing on bodhi).
Probably Bodhi does not contain drivers for old hardwares like that. But would be nice to know what was exactly written (like the kernel panic and failure)

Randy4bodhi 07-15-2018 06:35 AM

If pan64 is correct, then try using the legacy bodhi version. It supports older machines.

Jeff91 07-15-2018 09:51 AM

With hardware of that speed you are almost certainly better off using the Legacy release of Bodhi anyways. 64bit applications use a touch more ram than 32bit and 1.5gigs of RAM doesn't leave a lot of extra to go around.

enigma9o7 07-15-2018 01:09 PM

I kinda wanted to use 64-bit because running the legacy version on my other box I did run into apps that didn't have current 32-bit versions anymore, and couldn't easily track down the 32-bit always. I also read advice elsewhere that suggested only install 32-bit if you absolutely have to. After getting used to 1/2 gig on my other box, 1.5 seems like a lot! [I can actually use the real gmail page and leave the tab open and still not swap; had to use old html version on other box if I wanted to do that.] So if I can make 64-bit work, I'd like to try.

So I tried installing Bodhi 5RC 64-bit again so I could document what went wrong. Surprisingly to me, it installed this time.

The only thing that seemed different was it did note that ubuntu was already there and gave me options to reinstall that when selecting partition, but I selected format & install bodhi. I did have to use the noapic option cuz of the first kernel panic as before. But this time I never saw a second kernel panic, although after install & reboot it hung.

I added the noapic option with grub. Now it boots fine (other than video issue I'll post in new thread). I didn't have to do this with lubuntu, only had to use it during install; even booting other kernels under lubuntu I didn't have to add any switches. Bodhi installer also had suggested using a debug switch before disabling, I never tried, but now I'm typing this message I think I should, just to see what it shows. I did note that APIC is enabled in my computers BIOS settings, which are default because if I shutdown I lose them anyway (probably dead battery) so no point in customizing anything there (unless important enough to set every time).

enigma9o7 08-19-2018 12:47 AM

I clean installed RC2 64-bit, had to use the noapic option again or it completely hung after selecting live install, or after completing install and letting it boot - no kernel or error messages/etc.

But then while installing software, setting it up, running into the same freezes and hangs and glitches like last time, decided maybe I should just try legacy. Installed that last night and no more problems. Haven't used it much yet, but got thru installing and testing everything I wanted without a hitch, which I couldn't do with 64-bit.

I am curious what the actual differences are? Since the cpu is 64-bit and I assume the OS verifies all the supported instructions before using them, why would the 64-bit version be glitchy on older hardware whereas the 32-bit isn't?

Jeff91 08-19-2018 08:40 AM

The Legacy build is utilizing a kernel from Debian that is supposed to explicitly work well on older hardware.

I'd also recommend doing a memory check - it is very possible you have bad memory in a system that old and that 64bit OS / apps are hitting the bad part quickly, while the 32bit release is not.

Randy4bodhi 08-19-2018 09:32 PM

I would also add that 64 bit uses more memory to function correctly. 32 bit doesn't need as much.


All times are GMT -5. The time now is 07:14 AM.