LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   Bodhi 5.1 Legacy - Some apps (Retroarch, Gcompris) dont work for me anymore (https://www.linuxquestions.org/questions/bodhi-92/bodhi-5-1-legacy-some-apps-retroarch-gcompris-dont-work-for-me-anymore-4175672149/)

enigma9o7 03-28-2020 04:14 PM

Bodhi 5.1 Legacy - Some apps (Retroarch, Gcompris) dont work for me anymore
 
I just wiped 5.0 installed 5.1 legacy on my pentium 4. [Had already done so on my 64-bit machines without issue, including one that used to run legacy, and don't have these issues there either.].

A couple apps for kids games that worked for me before I wiped are no longer working. I had been keeping the previous install updated, so understand that everything should still behave the same, so possible/likely that its a setting/config error on my end...

Retroarch opens a window, then closes it. No error messages or terminal output. I then added official libretro stable ppa and updated, still same thing. I do believe I was using ppa version before but not 100% sure.

Gcompris is not working at all. I'm confident the repo version used to work, it was one of the very first things I installed when I set up bodhi. Just in case tho I found a ppa with newer version, it didnt help.

edit:solved other game, removed

enigma9o7 03-28-2020 07:03 PM

Ok I found a workaround for gcompris, by using a command line switch to use software rendering instead of opengl.

Seems good enough, although I don't recall having to do that before.

Still no luck on retroarch tho. I saved .desktop files & with icons etc for all various snes/gba/psx/genesis games but need to get retroarch working to be able to use them!

There is absolutely no terminal output tho. Maybe its an opengl problem too, maybe I need to install something to support that better, although nothing came up as dependency.... The video on that machine is old integrated intel...

enigma9o7 03-28-2020 08:58 PM

1 Attachment(s)
So I guess it is video issue for retroarch. I turned on verbose logging and can see plenty of errors in the logfile (attached). I tried upgrading to 5.3 kernel (from 4.9) incase theres fixes there, nope, nothing. So I dunno. Probably not a bodhi issue, probably a retroarch issue, and I'm already scouring their forums.

enigma9o7 04-02-2020 07:20 PM

Finally found the solution for retroarch. It seems it's their problem not autodetecting my video capabilities correctly (even tho the log shows it most certainly did.... but anyway). I had to add a line to .config/retroarch/retroarch.cfg to for my opengl mode and now it's working again too.
Code:

video_driver = "gl1"


All times are GMT -5. The time now is 12:54 PM.