LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   BL5-32bit - Firefox, adding add-ons doesn't work properly (https://www.linuxquestions.org/questions/bodhi-92/bl5-32bit-firefox-adding-add-ons-doesnt-work-properly-4175646062/)

madmax25 01-12-2019 09:58 AM

BL5-32bit - Firefox, adding add-ons doesn't work properly
 
I installed Firefox64 (=FF) on BL5-32bit of my little netbook and began to add some add-ons like on my PC.

I opened FF and went to the add-ons page of FF.
Then I added one add-on and then, still on the add-ons page of FF, another one.
But to do this I had to remove the previous add-on from the search bar, but the backspace button doesn't work there, neither does the DEL button.

So, for each and every add-on I have to close FF, and start again for the next add-on.

I guess, you will all agree, this is annoying as hell.

What's going on here and how can I fix this, please?

EDIT:
Seems to be an BL5 issue, because everything is ok on BL4.5-32bit.
I also tried Xubuntu 18.04-32bit and it was ok there, too.

Reinstalling FF didn't help, btw..

madmax25 01-13-2019 06:35 AM

Anybody able to confirm this issue?

madmax25 01-31-2019 09:30 AM

I just tried BL 5.0 32bit again.
I even downloaded the ISO again.

Then I booted it "live", added my WiFi and installed Firefox from the AppCenter and added an add-on by means of the about:addons page of Firefox.
But when I tried to enter a 2nd add-on, I wasn't able to delete the previous entry from the search bar of the about:addons page (I tried the backspace key and the Del key, but no chance for both).

So this issue still happens and it happens on a totally fresh BL5 and even within the live system.

Can anybody have a look at this and tell me what to do about it, please?

cordx 01-31-2019 09:34 AM

Quote:

Originally Posted by madmax25 (Post 5948444)
Anybody able to confirm this issue?

i'm not a dev, but can try to confirm on my 32-bit machine. what add-ons are you trying to install specifically?

madmax25 01-31-2019 09:47 AM

You may try Quick Cookie Manager and then Video DownloadHelper,
but actually, it doesn't depend on what add-ons you try.

The only problem is, I just cannot remove (or edit) the content
of the search bar of the about:addons page,
when I want to enter the 2nd add-on there.

cordx 01-31-2019 10:21 AM

Quote:

Originally Posted by madmax25 (Post 5955923)
You may try Quick Cookie Manager and then Video DownloadHelper,
but actually, it doesn't depend on what add-ons you try.

just wanted to make sure i was trying something at least similar to what was giving you issues :)

my system did not have the same problem. as soon as i clicked on the drop-down link for quick cookie manager and that specific page began to load, the search bar cleared itself. after install, i was able to type video downloadhelper into the search box without any issues. after clicking the link, the search box again cleared itself. both installs appear to be successful.

i know that probably doesn't help. sorry i can't be of much help running down your particular issue.

after reading the recent thread about audacity and weird pop-up dialog boxes, my only possible thought would be that it might be a weird theme interaction issue? that is a shot way out of left field though. maybe trying a different theme will somehow interact differently with ff?

madmax25 01-31-2019 10:32 AM

I was using the default themes for both BL5 and Firefox.

What's your RAM size, please?
Mine is 1GB only.
Maybe this is causing this issue?

cordx 01-31-2019 05:17 PM

Quote:

Originally Posted by madmax25 (Post 5955954)
I was using the default themes for both BL5 and Firefox.

i have my bodhi theme set on moksha green in case you want to try it. my firefox is also default.

Quote:

Originally Posted by madmax25 (Post 5955954)
What's your RAM size, please? Mine is 1GB only. Maybe this is causing this issue?

that machine has 3.5gb of ram. however, before i launch ff it is only using about 250mb and even after it is running with three tabs the highest it got (just after launching) was 750mb. i'm not saying it can't be a ram issue, just that mine doesn't go above your 1gb limit.

madmax25 01-31-2019 05:24 PM

Here, I'm running the blue Moksha. (EDIT: I mean the default theme, which I think is the blue Moksha)

I don't have another theme installed so far.

I will check the green one as soon as possible,
but as I didn't use themes for BL for a long time,
I'm not sure where to find the green one, because there's no menu entry for it.
Is it in the AppCenter or in the settings console?

cordx 01-31-2019 05:31 PM

i didn't see moksha green listed in the app center so i am fairly certain it comes pre-installed. i don't tend to mess with themes too much. i can see it listed in the settings console under look and then theme.

madmax25 01-31-2019 05:46 PM

Not sure, but the green one may be missing in the legacy version which I'm running.

cordx 01-31-2019 06:04 PM

1 Attachment(s)
this is where i found it in settings. in case the screenshot helps :)

Attachment 29669

rbtylee 01-31-2019 06:27 PM

For the record MokshaGreen theme above is not installed by default.

Code:

sudo apt update
sudo apt install bodhi-theme-moksha-green


madmax25 02-01-2019 05:35 AM

Sorry, I'm a bit confused about the default theme, now.

Is the default theme and the Blue Moksha the same or not?
I think, it is the same, right?


Anyway,... I'm giving up on BL5 as for now.
I think, I will better give it another try, as soon as BL5.1 will be available
(or whatever number the next version will have).
And if that one doesn't work properly, either, I will probably have to accept
that my 10-year-old little 32bit netbook has finally reached the end of its life.

cordx 02-01-2019 10:03 AM

Quote:

Originally Posted by madmax25 (Post 5956307)
Sorry, I'm a bit confused about the default theme, now.

Is the default theme and the Blue Moksha the same or not?
I think, it is the same, right?

it has been long enough since install (sometime in september i believe) that i don't recall what the default looked like. on mine it is simply labeled "default".

Quote:

Originally Posted by madmax25 (Post 5956307)
Anyway,... I'm giving up on BL5 as for now.
I think, I will better give it another try, as soon as BL5.1 will be available
(or whatever number the next version will have).
And if that one doesn't work properly, either, I will probably have to accept
that my 10-year-old little 32bit netbook has finally reached the end of its life.

hopefully you will find something to keep your netbook going. i know i enjoy having my older equipment up and running even if i don't use them as often as they might like :)


All times are GMT -5. The time now is 02:15 AM.