LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 07-10-2019, 05:43 PM   #16
madmax25
Member
 
Registered: Aug 2018
Posts: 232

Original Poster
Rep: Reputation: Disabled

@ the_waiter

I guess, instead of
Code:
.e/e/config/your_profile_name
you mean
Code:
.e/e/config/bodhi
,
right?

Anyway, now, after this fix, there are two files in that folder,
Code:
e.cfg
and
Code:
e2.cfg
Is this, what it should be like?
Or is
Code:
e2.cfg
meant to replace
Code:
e.cfg
?

Last edited by madmax25; 07-10-2019 at 05:48 PM.
 
Old 07-10-2019, 06:01 PM   #17
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 279

Rep: Reputation: Disabled
This time the popup came and said the newest version is 0.22.4, whereas before it said 0.17.4

I hadn't done anything. I didn't do the procedure suggested because my values appear to already be zero.
Attached Thumbnails
Click image for larger version

Name:	shot-2019-07-10_15-59-58.jpg
Views:	10
Size:	31.3 KB
ID:	30886   Click image for larger version

Name:	shot-2019-07-10_16-07-30.jpg
Views:	10
Size:	50.1 KB
ID:	30887  

Last edited by enigma9o7; 07-10-2019 at 06:08 PM.
 
Old 07-10-2019, 07:50 PM   #18
madmax25
Member
 
Registered: Aug 2018
Posts: 232

Original Poster
Rep: Reputation: Disabled
After doing the fix there's no message anymore, so far, here.
 
Old 07-10-2019, 08:20 PM   #19
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 184
Blog Entries: 14

Rep: Reputation: 33
I just got the same thing while watching the news in Kodi. I was informed that the latest version of Enlightenment is 0.22.1.
 
Old 07-11-2019, 05:01 AM   #20
rbtylee
Bodhi Developer
 
Registered: Jun 2018
Location: Ladson, SC US
Distribution: Bodhi
Posts: 171

Rep: Reputation: 191Reputation: 191
Rather odd this is back to working. I had forget about it, had been assuming the functionality was turned off in the code. Looking at the code tho it is not turned off just was broken on the e server side of things evidently.

Quote:
Originally Posted by the_waiter View Post
Interesting

The same here with BL 3.2.1 with Moksha 0.2.0. We need to check the code. Unfortunately I am on holidays with family. Probably Robert will look at that sooner than me. Anyway we can use "never tell me" option.
I will be unable to do anything about this until this weekend. Looking at the code trivial to fix tho.

Quote:
Originally Posted by the_waiter View Post
Moksha is connecting the e server
url_up = ecore_con_url_new("http://www.enlightenment.org/update.php");
to check the version

Not sure why we can see this for the first time.

Stefan
if anyone cares ...

Why we are seeing this now? enlightenment.org has been having problems with their servers for about a week now, there has been a thread on their mailing list. Last msg they are still not fully functional. Problems with their servers has been an ongoing thing for them for years. Evidently, the link www.enlightenment.org/update.php has not worked correctly for years, either that or it was ignoring whatever values moksha was feeding it. I don't know for sure as I don't have access to that server nor do I have the source code for the file update.php.

But around the time our users started reporting this update dialog, Raster had partially restored functionality to the e servers. Whatever he did made this update functionality start working again. Since Moksha uses different versioning numbers than enlightenment and in the relevant code is reporting itself as e17, the code thinks Moksha needs updated.


For the record the "never tell me" option should work. Just looked on my machine and it did change the relevant values in the config file. For users saying it is not working, unsure why that would be but perhaps after clicking the never tell option restart moksha. If that fails to work follow Stefans eet solution posted above.
 
3 members found this post helpful.
Old 07-11-2019, 06:38 AM   #21
rrashkin
Member
 
Registered: Aug 2018
Location: San Benito, Texas, US
Distribution: Bodhi Linux
Posts: 40

Rep: Reputation: Disabled
In my case, sudo apt full-upgrade seems to have done the trick (v5 64bit).

edit: ... or so I thought! It just returned.

Last edited by rrashkin; 07-11-2019 at 06:43 AM.
 
1 members found this post helpful.
Old 07-11-2019, 07:32 AM   #22
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5 & debian 9 LXDE
Posts: 678

Rep: Reputation: 304Reputation: 304Reputation: 304Reputation: 304
Robert - the one daily laptop i use i did ht the never bother me again and i will see. the other office laptop was in suspend but when i turned t off yesterday i did not get the message - but i did not use it long enough to see if that popup would show. we had storms due here but never appeared so that is in limbo - my wife hardly uses hers lately and that has been off but i will see into that one maybe later. I hope it all works out. i am too stupid with linux to attempt stefan's solution. My luck i would break more.

ha ha
 
1 members found this post helpful.
Old 07-11-2019, 11:06 AM   #23
enigma9o7
Member
 
Registered: Jul 2018
Location: Silicon Valley
Distribution: Bodhi 5 (Ubuntu 18.04)
Posts: 279

Rep: Reputation: Disabled
After telling it to never tell me on both of the versions it popped up, it hasn't returned a third time. But that could be server down again I guess. I don't recall restarting....

Either way, sounds like a permanent fix is coming, thanks Robert.
 
1 members found this post helpful.
Old 07-11-2019, 01:33 PM   #24
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 467

Rep: Reputation: 391Reputation: 391Reputation: 391Reputation: 391
Yes, it is very easy to do the fix. As I said doing some developing on holiday is not the right activity I wanna do. Also I have only wife's poor laptop with me here. Robert will do this or me later, but it will be done for sure...at least for Moksha 3.1 in BL 5.x

Stefan

Last edited by the_waiter; 07-11-2019 at 01:38 PM.
 
2 members found this post helpful.
Old 07-11-2019, 02:23 PM   #25
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5 & debian 9 LXDE
Posts: 678

Rep: Reputation: 304Reputation: 304Reputation: 304Reputation: 304
tell your wife not to send the divorce lawyer fees to my address.... thanks for everything stefan you too Robert.
 
1 members found this post helpful.
Old 07-12-2019, 04:45 AM   #26
madmax25
Member
 
Registered: Aug 2018
Posts: 232

Original Poster
Rep: Reputation: Disabled
I tried the fix on both BL4.5-32bit and BL5-64bit, both seem to be ok now.

EDIT:
Hit "Never bother me again" AND reboot your system are apparently very important steps to get this fixed permamently.

But I'm not exactly sure if I did the fix properly.
After the fix, I have two files, e.cfg and e2.cfg, now.

Do I need both of them or shall I better replace e.cfg with e2.cfg?

Last edited by madmax25; 07-12-2019 at 04:54 AM.
 
1 members found this post helpful.
Old 07-12-2019, 11:39 AM   #27
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 467

Rep: Reputation: 391Reputation: 391Reputation: 391Reputation: 391
If the fix works for you, let it be as it is We are gonna release new Moksha version in testing repo soon.
 
1 members found this post helpful.
Old 07-12-2019, 12:06 PM   #28
hemlocktree
Member
 
Registered: Aug 2018
Location: Northern Exposure
Distribution: Bodhi 5 & debian 9 LXDE
Posts: 678

Rep: Reputation: 304Reputation: 304Reputation: 304Reputation: 304
Thank you! oh so far on my daily use thinkpad no more popups- knoooooock on woooooood.
 
1 members found this post helpful.
Old 07-13-2019, 12:18 PM   #29
madmax25
Member
 
Registered: Aug 2018
Posts: 232

Original Poster
Rep: Reputation: Disabled
The new Moksha, will it be for BL5 only, or for BL4.5 as well?

And how will I get it?
With Synaptic or by performing a global update in terminology?

Last edited by madmax25; 07-13-2019 at 12:20 PM.
 
1 members found this post helpful.
Old 07-13-2019, 12:51 PM   #30
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 467

Rep: Reputation: 391Reputation: 391Reputation: 391Reputation: 391
For BL 5 for sure. For BL 4x only if time permits. We are too tiny dev crew, sorry

We will announce the release in testing repository. Everything will be explained then...

Stefan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
BL4.5.0 32bit - How to use only 5GHz for WiFi? madmax25 Bodhi 3 02-18-2019 10:50 AM
BL4.5.0-32bit - How to remove unused packages without damaging system? madmax25 Bodhi 13 02-07-2019 10:49 AM
USB device connection overrides Moksha DE's lock screen (Bodhi 4.5.0, Moksha 0.2.1) Kazuhira_x3 Bodhi 1 11-08-2018 02:54 AM
BL4.5.0-64bit - Need command to start Moksha from command line? madmax25 Bodhi 4 10-04-2018 10:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 02:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration