LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Bodhi (https://www.linuxquestions.org/questions/bodhi-92/)
-   -   BL4.5-32bit an BL5-64bit - Is kernel 5.0.0.20 supported? (https://www.linuxquestions.org/questions/bodhi-92/bl4-5-32bit-an-bl5-64bit-is-kernel-5-0-0-20-supported-4175657579/)

madmax25 07-17-2019 05:29 PM

BL4.5-32bit an BL5-64bit - Is kernel 5.0.0.20 supported?
 
I would like to install kernel 5.0.0.20 on my little netbook with BL 4.5-32bit and on my laptop with BL5-64bit.
Is it possible?
Is there any reason why I should not do it?
Can I use the ukuu tool or what is the best way to do this, please?

ehartman 07-17-2019 08:20 PM

Quote:

Originally Posted by madmax25 (Post 6016008)
I would like to install kernel 5.0.0.20 on my little netbook
Is there any reason why I should not do it?

1) there is no 5.0.0.20, the 5.x series of kernels have three numbers only (like 5.0.20)
2) 5.0.x is long EOL and isn't supported anymore, current stable is the 5.2.x series.
See www.kernel.org for currently supported kernels (stable and longterm).
Whe you do get a kernel there, you will have to compile it from source.

madmax25 07-17-2019 08:42 PM

Sorry, I mean 5.0.0-20-generic.
Well, at least, this is the latest one I'm offered on a Linux Mint 19.1-64bit MATE.
It seems to run quite well there, so I thought I should try that one on Bodhi, too.

hemlocktree 07-17-2019 08:47 PM

.......

madmax25 07-17-2019 09:29 PM

Quote:

and this is the Bodhi forum.
I know, it's a Bodhi forum, and I'm indeed also running two Bodhis (the ones I mentioned above).
In fact, I'm running several distros on three multi-boot machines.
It's just that I began with a Mint to fix an unstable wifi by updating the "rtl8812au" to "8812au v5.2.20.2_28373.20180619".
Before that, I installed kernel 5.0.0-20-generic, which, according to Mint's kernel manager, is the latest available kernel and it's supported until February 2020.
Since it seems to be working that way, I now want to have the same update for my two Bodhis.

I'm just unsure what kernel to use there and how to install.

ehartman 07-18-2019 02:01 AM

Quote:

Originally Posted by madmax25 (Post 6016050)
Sorry, I mean 5.0.0-20-generic.
Well, at least, this is the latest one I'm offered on a Linux Mint 19.1-64bit MATE.

That's a MINT-specific rebuilt version of the 5.0.0 kernel.
As I do not know what the 20 rebuilds (the -20 means number of rebuilds) have done I cannot say if that kernel is any use in "other then Linux Mint 19.1" systems.
But anyway there have been a number of backported (security?) patches and/or Mint-specific changes IN that kernel.
Normally you should go for either the latest kernel your own distribution offers OR get the sources from the latest stable kernel (from kernel.org) and compile that yourself.
Packages from other Debian-like distributions are a gamble, especially custom ones (that is: not directly derived from the upstream sources).

madmax25 07-18-2019 11:25 AM

Ok, so, what if I want to use this wifi driver, what kernel would you recommend for BL4.5-32bit and BL5-64bit?

enigma9o7 07-18-2019 12:00 PM

The driver page you linked says it should work in kernel 5.2-rc1 which I assume is prior to 5.2, so 5.2.1 would in that case be newer.

Currently the latest kernel in ukuu is 5.2.1. It saves your old kernel which you can boot into from grub menu, so if it doesn't work, you can always go back.

If it were me I'd try it. I still have default kernel on my 64-bit machine but upgraded both my bodhi legacy machines with ukuu no problems, it's easy to use.

edit: that kernel.org someone referenced also says 5.2.1 is the latest stable too.

madmax25 07-18-2019 02:00 PM

I'm not sure I understand that page.
If it says on that page, "it should work in kernel 5.2-rc1", does it mean,
I can only use this kernel and newer ones or will older ones do, as well?

Actually this question should be unnecessary, but it also looks like Mint is counting its kernels differently.

Therefore, regarding Bodhi, I'm confused as for the proper kernel to use, now.

enigma9o7 07-18-2019 02:15 PM

The driver page isn't 100% clear, but I took it to mean the 5.2.20.2 version of the driver won't compile with kernels earlier than 5.2-rc1.

5.2-rc1 means the first release candidate for 5.2, before 5.2 (5.2.0.0) stable was released. Then the next stable after that is 5.2.1 (5.2.1.0).

It seems like ubuntu/ukuu use the same numbers as kernel.org. The simple answer is install ukuu and then install the latest kernel, which is 5.2.1, then try that driver.

https://kernel.ubuntu.com/~kernel-ppa/mainline/ is where ukuu gets its kernels from, you can see the list there too if you haven't installed ukuu yet.

enigma9o7 07-18-2019 03:11 PM

I changed my mind. I think you don't need to update kernel for that driver, more likely it quit building in 5.2-rc1 so he had to fix it.

Have you tried to install the driver with the kernel you have?

madmax25 07-18-2019 06:42 PM

Not yet, but I'll try it asap.

EDIT:
I just tried ukuu, but it didn't offer me kernel 5.2.1.
So I simply tried to install the "gordboy" driver anyway.

Interestingly, at least as for now, it seems to be working with kernel 4.15-20.

enigma9o7 07-29-2019 11:12 AM

1 Attachment(s)
Glad you got it working.

Yeah I dunno, I just looked in ukuu today and 5.2.1 isn't there, although I really did think I saw it the other day... there's newer ones now tho. But anyways not your issue, and probably better not to use that much newer kernel unless you really need to anyway, could break something else... when I went upgraded it was only to like 4.20 or something, not the 5.x series.


All times are GMT -5. The time now is 02:49 AM.