Visit Jeremy's Blog.
Go Back > Blogs > Ztcoracat
User Name


Rate this Entry

How To Fix The UID Issue

Posted 05-12-2017 at 12:22 AM by Ztcoracat

There's nothing more irritating than not being able to mount your other drives while your booted into your favorite distro.

This has happened twice on my Linux systems and thanks to our Guru suicidaleggroll there is a way to fix it.

I'll use my 3 systems as an example.

I've got Slackware, Voyager Linux and Gecko Linux (Open Suse) installed on 2 different drives on my desktop.

Long story short the id for Slackware and Voyager is 1000.

However after a fresh install of Gecko Linux the new id was 2001.
If I tried to copy or paste anything from Slackware while booted into Gecko Linux I was locked out and vice versa if I was booted into Slackware.

So I checked on the id's of all 3 systems and sure enough Slackware and Voyager had an id of 1000 but Gecko Linux had an id of 2001.

I solved it in tty with:

usermod -u 1000 zebracat
groupmod -g 1000 group

find / -zebracat 2001 -exec chown 1000 {} ;
find / -group 2001 -exec chgrp 1000 {} ;
After running those cmd's one at a time as root I typed reboot.
Upon reboot I could copy and paste and mnt any drive I wanted to.

If you need help you can pm me.

Posted in Uncategorized
Views 715 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 09:49 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration