LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Blogs > Ztcoracat
User Name
Password

Notices


Rate this Entry

A Start Job Is Running ERROR

Posted 02-22-2019 at 12:10 AM by Ztcoracat

If you get this error message upon booting up chances are it's a simple fix.

My Debian system would boot but would be delayed with a 1 min and 30s error message.

Code:
A start job is running for dev-disk uuid (exact #'s of the device/HDD) 1 min 30s
To correct the error run blkid and compare it's output to that which is in your /etc/fstab file.
If the 2 files do not match than change the UUID in fstab to that which is shown by blkid.

Here's an example and the output of blkid:
Code:
/dev/sda1: UUID="ff6a9927-e1b5-4177-8957-2cc2598ec91e" TYPE="ext4" PARTUUID="000688b0-01"
/dev/sda2: UUID="d8f6b93e-dbaf-4ac3-b02a-f1fc70d558bf" TYPE="swap" PARTUUID="000688b0-02"
/dev/sdb1: LABEL="rootMX18" UUID="8d9aa50a-f6d2-47d3-9f60-13ec85b3672b" TYPE="ext4" PARTUUID="c2d23fcd-01"
/dev/sdb2: UUID="22b34198-7f33-4b7e-9ffd-77d6f96744ca" TYPE="swap" PARTUUID="c2d23fcd-02"
/dev/sdc1: UUID="0ac4246d-399a-447d-b33b-ca5b09f6f079" TYPE="ext4" PARTUUID="000ce4f3-01"
/dev/sdc2: UUID="df960
Here is the output of /etc/fstab:
Code:
# / was on /dev/sda1 during installation
UUID=ff6a9927-e1b5-4177-8957-2cc2598ec91e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=d8f6b93e-dbaf-4ac3-b02a-f1fc70d558bf none            swap    sw              0       0
# swap was on /dev/sdb2 during installation
UUID=7ce0685e-e8a0-40c4-9197-317ad97f0905 none            swap    sw              0       0
# swap was on /dev/sdc2 during installation
UUID=dd5c1461-6503-48e9-af54-e4e7aa5734a1 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto
As you can see the first 2 UUID's(ffba9927 and d8f6b93e)in the output of blkid and the fstab file matched.
The other 2 entries (sdb2 & sdc2) in the fstab file didn't match what was reflected in the output of blkid.

Opening the /etc/fstab with elevated privileges in nano worked.
I simply changed the UUID of 7ce0685e and the UUID of dd5c1461 to UUID=22b34179 and UUID=df96003d.

Upon reboot the error message was gone.

This worked for me on a custom built 64-bit AMD desktop pc running Debian 9 stable.
Posted in Uncategorized
Views 437 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration