Review your favorite Linux distribution.
Go Back > Blogs > xjlittle
User Name


Rate this Entry

Linux and the nx6325 aka is there a distro that will work on this notebook???

Posted 03-11-2007 at 09:49 AM by xjlittle

Wow what a ride this has been with the nx6325 notebook. And not a fun one either. I started off using a 64 bit version. First I tried FC6. Things didn't feel quite right with that. I jumped over to Ubuntu. Same there. I use both of these distros regularly so I was quite surprised at these events. I finally installed Kubuntu and it work perfectly. I'm not sure what the difference is between it an Ubuntu as far as core system files. All I can think of is it was either the KDE libraries or just the way the developers set it up.

After using this for a couple of months I finally got fed up with the lack of reasonably good java and flash support for 64 bit. (I don't want to hear the comments about non free stuff. I want it to work pure and simple..and I've probably been using linux longer than you've known what it is so don't start that crap with me). This is when the fun started.

Since I had been using Kubuntu I decided to stick with that. It was ok for a week or so. Then all of a sudden when I put the laptop on my docking station at work, connected to my KVM switch, the keyboard would work for awhile and then just quit. After a few days of this annoyance and attempting various fixes that didn't work I decided to try FC6. This was even worse. The mouse would all of a sudden jump to the left hand side of the screen and stay there. This would happen even when I wasn't plugged into docking station. Another few days of trying to fix this. Nothing worked. I tried the synaptics drivers from source, tried ps2 mouse drivers, anything and everything that I could find to try. This just wasn't going to work. On Friday I had actually asked to get a new notebook at work and they agreed.

Saturday morning rolls around (I've been at this for about two weeks off and on now)and I'm searching the web and the history in my brain for a distro to try. Mepis is out-it won't even start the livecd let alone install. I finally thought about Slackware. Not in the least because of the many good things I've heard about it here at LQ.

I started the downloads of the first three cd's and then went to install my new garage door opener. That evening I burned the cd's and browsed through the install manual (it was a light browse as we'll soon see :-) The install went beautifully. X started with startx. Oops-the mouse is in the middle of the screen and won't move. Ok well let's see what's going on with this. A few minutes of reading and I found out that Slack, when using the 2.6 kernel does not install the modules directory for the kernel. A few more minutes of reading and I found out how to do that and had it done. Now I have a mouse.

I quick glance around the system and I discover that the light on my mute button on the notebook is lit and won't turn off. I start up the command line alsa stuff and unmute everything there but this is still a no go. This one took about an hour to figure out what was going on. Thanks to CWache and his write up on the gentoo wiki at I soon had this working.

Ok got everything working so let's what Slack has to offer. I restored the backup of my home directory so I could get some of the things that I needed. I immediately installed ndiswrapper and the broadcom driver. Perfect-the blue light came up and everything looks good. Another few minutes of reading and I had it getting an ip address and the other network info from my dhcp server. Cool stuff.

I opened up my mp3 server at, chose a couple of songs to play and almost unbelievably streaming mp3 to amarok worked out of the box. Ok let's hit youtube and see what happens. Oops-either flash, java or both aren't working. A quick check of about:plugins in firefox shows java but not flash. A download later and flash is working. Now this is cool stuff.

Now there are obviously many things to use and check out before I know if I can use everything I want on here. Since this is also my network engineer's workstation at work I need at least clusterssh, OpenOffice, davfs2, openvpn, wink and so on. But so far the things that have been problematic in the past are working. Given the ease of installing a few packages from source as well as using the installpkg application I don't foresee any problems.

Nice work Slackware dev people!
Posted in Uncategorized
Views 2236 Comments 0
« Prev     Main     Next »


All times are GMT -5. The time now is 12:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration