Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Blogs > Whaling the FOSS
User Name


The experiences of an Australian student who uses Linux.

Cover all topics from shell scripts to monopolies and reviews to political comments.
Rate this Entry

When Windows Update kills nostalgia

Posted 07-23-2011 at 05:25 AM by William (Dthdealer)

Today I decided to take a look at my old Pentium 4 box back from the days before I knew of Linux. It has been sitting unused for years, and lately I have come across the desire to setup a torrent box. Before wiping Windows XP off it, I decided to have a look at what it still had.

After starting it up I realised that I had forgotten my login credentials many years ago. To change them I would have to reboot and start the computer off one of my old CDs containing ntpasswd. Unfortunately Windows XP had a different idea:

These updates must have downloaded when I last used the device, for I had not yet bothered to plug an ethernet cable into it.

After about half an hour of enduring the Windows Downgrade (TM) process, I rebooted to a blank screen. I tried again in safe mode with the same outcome. Input and the speakers still worked so I assumed something relating to the video drivers had gone wrong.

I was finally able to boot the computer in 'VGA' mode, where the graphics driver is substituted with vga.sys, a 640x480x8 built-in universal driver. The computer now allowed me to see what I was doing, but trying to change the screen resolution would result in the same blank screen.

My first port of call was system restore. For some odd reason it did not exist in the Start Menu, and I was unable to execute it by its name on the command-line. This computer runs XP Professional and I have used System Restore on it before, but it seems to have just vanished. In the Control Panel options still existed to change how much space system restore could take up, but that was about all that remained.

The situation now smelt even more like malware when I found out the computer refused to connect to the internet. I was able to download an updated Intel GMA driver installer off the web and transfer it to this computer via a USB stick, but it did not fix my problem.

All signs so far seem to point at a software problem, especially since the computer's graphics driver was working correctly at the login screen before ( and while ) the updates were applied.

In response to this I tried to boot the computer off a USB stick containing Debian and clamav. Unfortunately as soon as the correct console resolution was enforced, the screen went and stayed blank.

I will have a try at swapping in and out RAM modules to see if that fixes the problem. As far as I know Intel GMA has no dedicated memory and instead shares the system's memory, and several months ago I stole a stick out of this box to put in another computer.

Has anyone else had the same problem with Windows Update? I was not able to find anything on the web. Feel free to comment.

Regards, William
Posted in Uncategorized
Views 1079 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 03:51 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration