Review your favorite Linux distribution.
Go Back > Blogs > vharishankar
User Name


Rate this Entry

We forget that Linux can be frustrating sometimes

Posted 12-09-2005 at 09:32 AM by vharishankar

I have always criticized people who complain about Linux on forums and while I do think that some of them do troll for the sake of trolling, I think I can relate to some of the sufferings of other Linux users which I think we tend to forget once we smooth over all the configuration of the system and get it to work the way we want it.

I recently changed my ISP from a cable provider to a DSL one. Getting it to work has taken me a long time, not because Linux could not get it to work, but because I had a difficult time figuring out how to configure the connection to work properly with the router.

To cut a long story short, it was to do with how to get the IP assigned to the router. Doing it manually did not work at all and while I was able to establish the connection, I could not do anything at all. It was frustrating. Because to get help, I needed to connect to the internet, but then I could not connect at all in the first place. It is a catch-22 situation. Finally I had to manually run pppoe and then establish the connection. It sounds trivial and it probably is, but then the sequence wasn't too obvious in the first place.

I think that I have some idea now why there are so many frustrated newbies. Certainly not trying to justify trolling, but I think I can understand why there are so many of those "why can't Linux be easier?" messages.
Posted in Uncategorized
Views 2420 Comments 4
« Prev     Main     Next »
Total Comments 4


  1. Old Comment
    You shouldnt need to configure you computer to use the internet through a router.

    but i'm not sure what distro this is but Mandriva and SUSE take to manual part out of configuration
    So linux is easier.

    My motherboard (ATI Xpress literaly would not boot Mandriva Install disc at all without noapic enabled)

    so i figure i guess i will need noapic to boot Mandriva off my hdd.
    I did that and everything was fine but couldnt access router or internet

    I sat for countless hours trying to get eth0 to connect.
    it had a static IP the router indicated a connection but the NIC just wouldnt do anything.

    DHCP spat up error invalid connection settings please verify in Mandriva control Centre

    I tried a PCI NIC same problem,

    i did it repeatedly, reset modem, reinstalled router bios, tried hotplugging, different cable, manual config.

    Problem ended up being


    so i removed it and what do you know Mandriva booted and Network connected to router as it should.

    was almost like the PCI bus wasnt turning on.
    Posted 12-31-1969 at 07:00 PM by vharishankar vharishankar is offline
  2. Old Comment
    Yes, sometimes the underlying issue can be so obscure as well. I must admit that these issues are more likely to be OS independent because of the innate complexity of computer hardware.
    Posted 12-31-1969 at 07:00 PM by vharishankar vharishankar is offline
  3. Old Comment
    pls i need help in the area of pppoe. i just install cento 5 on my computer and am connected directly to the i want to configure my pppoe to enable me browse the internet. can somebody help me out?
    Posted 12-31-1969 at 07:00 PM by vharishankar vharishankar is offline
  4. Old Comment
    pls i want view .chm file on my cento 5 using gnome desktop but i could not open it can somebody heal me out?
    Posted 12-31-1969 at 07:00 PM by vharishankar vharishankar is offline


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration