Visit Jeremy's Blog.
Go Back > Blogs > Vermind
User Name


Rate this Entry

Ubuntu 9.04 upgrade woes

Posted 04-26-2009 at 02:27 PM by Vermind

I upgraded my Ubuntu 8.10 laptop to 9.04 a few days ago when it came out. While the release seems good, there were some undesireable side-effects caused by the upgrade, my configuration, or the new release itself.
  1. In the upgrade process itself is a serious flaw. If a package cannot be downloaded, for example because of an inadequate or too crowded network connection, or the server on the other end, the upgrade process quits, giving me no option to try again. This results in a huge amount of wasted time manually starting the upgrade over and over again. To resolve this, I finally added the jaunty sources into my sources.list and said
    sudo apt-get update && sudo apt-get -d dist-upgrade
    in order to download the packages. I had to do that multiple times as well, since the connection failed to download packages every now and then. The upgrade succeeded after that.
  2. When I started my session in 9.04 the first time, I noticed that there was a strange 1-pixel wide line in my gnome panel. It was the indicator applet, but it did not work. I added the indicator applet to the panel manually, and later by tedious pixel hunting managed to remove the defunct indicator applet. Suggestion: Always show a handle for moving or removing the indicator applet. This goes for all other applets as well.
  3. I proceeded to enable desktop effects. The 9.04 had uninstalled my previous, manually installed nvidia driver, or was unable to detect it. It told me there are no drivers available. This was probably because I had disabled the "hardware drivers" session item in the previous version, invoking it when I needed it. I ran the "hardware drivers" entry from the system - administration menu, enabled the nvidia drivers, and got 3d acceleration upon reboot. Desktop effects were not enabled however. I went to appearance properties and enabled them. Compiz started fine, but on another reboot, the desktop effects radio button was unselected again, and compiz was not running. To fix this, I just added
    compiz --replace
    to my "startup applications" ("former sessions") That did the trick. I do not know why compiz is not enabled by default in further sessions after selecting "normal" desktop effects.
  4. I noticed that my desktop icons do not appear on login. It seems that nautilus is not started in my session. There seems to be something seriously wrong with my session configuration, I wonder how to reset it to defaults? Well, I don't mind nautilus not starting, since it makes startup faster. I can start nautilus manually when I start browsing my files.
  5. Firefox flash fullscreen crash: In Firefox-3.1 (3.5) and newer, if you fullscreen a flash video (youtube for example), firefox crashes. This happens with nvidia drivers only. To fix this, you can preload libGL before starting firefox, like so:
    LD_PRELOAD=/usr/lib/ firefox-3.6
    . I fixed the firefox starting script by adding
    export LD_PRELOAD=/usr/lib/
    to the beginning. After that, I can fullscreen flash without crashing firefox.
  6. Dead icedtea plugin: When I try to use the icedtea Java plugin that comes with Jaunty, it freezes firefox, or just doesn't work, giving weird errors, depending on the site. It may be that the majority of sites use sun-specific extensions, or the icedtea plugin just doesn't work. I remember it working on Intrepid for this laptop before. I removed icedtea-plugin, all openjdk packages, and installed sun-java6-plugin. It seems that if you install sun-java5-plugin, it does not automatically activate in firefox, but sun-java6-plugin does.
  7. I solved the gnome-screensaver & compiz ut2004 fullscreen-to-window switch bug: There was a longstanding bug in Ubuntu, going back as far as gutsy at least, where when using compiz, gnome-screensaver activates when playing a fullscreen game such as ut2004 or scorched3d. The screensaver cannot grab input from the game, and as a result the game is thrown off fullscreen while the screensaver does not activate, making this issue really tricky to track down to the screensaver. To fix this, I disabled gnome-screensaver. Other solutions include disabling compiz, or changing the screensaver to xscreensaver instead.
  8. IM status & shutdown & user switch applet (fast user switch) does not work if ubuntu-tweak has "disable fast user switch" enabled: I had previously disabled "fast user switch" in ubuntu-tweak, to make my system more locked-down when I am logged in. Perhaps I misunderstood what disabling it means, but it seems that the applet called fast-user-switch fails to load if this option is checked in ubuntu-tweak. This makes the applet useless for any other purposes than user switching, such as quick reboot, hibernate, suspend and shutdown options and tracking IM status. I unticked the option in ubuntu-tweak to re-enable it.

Posted in Uncategorized
Views 6834 Comments 0
« Prev     Main     Next »


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration