Latest LQ Deal: Linux Power User Bundle
Go Back > Blogs > uinseann
User Name


Rate this Entry

My experience converting a video

Posted 09-03-2009 at 04:29 PM by uinseann

I use Kaffeine to record TV programs. The trouble is it saves as an "m2t" file, which I'm told is compressed to save space.

there's no problem playing it in Kaffeine and the quality is great, but Totem freezes. So I thought I would try and convert it to .mpeg! Openmovieeditor, wouldn't open the .m2t extension, neither would Pitivi! I didn't have Kdenlive installed and didn't want to install all those Kde dependencies (this is my old desktop computer you see), so I tried "Avidemux". It looked promissing, it actually loaded it, with the words "This looks like an mpeg, should I index it? or words to that effect!

So I let it. I set the boxes at the side to "copy" for video and audio. I didn't want to edit the program I had loaded for now so I just let it save as an "avi" It took about 15 mins, for my 45 minute program. When it finished it told me it had saved it (famous last words).

I opened the saved "avi", and the picture looked quite good ... and it was until the characters spoke! Their mouths moved and the voices came afterward, yes it was out of sync! I opened Avidemux again and loaded the m2t file, checked the settings? all seemed OK. Scratched my head, then decided to search with Google, for "Avidemux, sync problems". I found very little info. On Avidemux's website I found "If you are editing a file with variable bitrate audio, run Audio->Build VBR Time Map before you do any editing. Otherwise your audio will be out of sync". Well I had checked all the settings I could think of, so I tried it. No joy just the same.

I visited the site of one of my previous posts "Dvd ripping and transcoding with Linux". I found the section on "Fixing desynched audio". It said this does not work with Avis that use VBR/ABR,Mp3s. This step uses "avisync", which is part of the transcode package.

It's starting to get to me by now! I'll try Winff! This program is just ffmpeg with a gui! It started well, but when it finished, I noticed it said 22mins instead of 45? So i knew it was a dud. I run the mpeg it had created, and funny enough the sound was in sync, but there was half a program?

I surfed again, and found a page that showed how to use ffmpeg with the command line!

So I tried ffmpeg in a terminal! Lets say my program was "Voyager" So it's Voyager.m2t. I wanted an mpeg, so I typed "ffmpeg -voyager.m2t -sameq voyager.mpeg"
You know what? after about 30 mins it was done! and the program works great! So that's it, no more messing around with Avidemux. I may though, try Openmovieeditor to cut the commercials out ... another day!
Posted in Uncategorized
Views 1361 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 01:41 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration