Share your knowledge at the LQ Wiki.
Go Back > Blogs > TwinReverb
User Name


Rate this Entry

Slacker installs OpenSUSE 11.4

Posted 06-05-2011 at 04:46 AM by TwinReverb

So I figured I'd try OpenSUSE 11.4 on my netbook (Asus 900A) today, and write down my experience with it as I go.

First, when booting the installer, I noticed that during the configuration phase, when partitioning my hard drive, it picked some odd options (to me), like putting root and /home on extended partitions, etc. I thought to myself, no big deal, I'll custom partition with the root size it had decided (5GB). Well /dev/sda2 was already a LUKS but I told it I wanted to start over, so I added a 5GB root and then went to try to make /dev/sda2 an encrypted swap. It asked for a password so I backed up and tried to make the entire thing an encrypted LVM. It brought me back to partitioning saying it did not have the password for sda2 (which I had elected previously not to specify when I started this thing up). Oh well, so I went to a console, generated a LVM-inside-LUKS of my own, and rebooted the installation DVD.

On boot-up, this time I supplied the LUKS password, and it found my LVM. However, I had to tell it to create a partitioning scheme, and I had to go to "Custom: for experts". I found gladly that it had indeed found my LVs inside my LUKS, so I proceeded (using 512MB for swap and the rest as /home). I chose Xfce and proceeded. I then went to "software" and made sure only what I wanted was installed, choosing my familiar xchat, firefox, Terminal, mousepad, gimp, bibletime, thunar, audacious, skype, pidgin (those that were available at time of install). I did not (due to prior experience) bother trying to tell it no boot loader or LILO, and with the install options, it was replacing Slackware on that netbook (16GB internal SSD and 16GB LUKS SD card, not inserted at the time).

Then it told me that installation of libreoffice-ure failed and I tried to retry but I got a failure, so I ignored that package and kept on going. Then xorg-x11-libx11 failed and I knew something was wrong with the install media I had (got it from a Linux magazine) so I started downloading the real deal.

- To Be Continued -
Posted in Uncategorized
Views 675 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 05:13 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration