Help answer threads with 0 replies.
Go Back > Blogs > trevorparsons
User Name


Rate this Entry

Sorting out Isa's laptop

Posted 05-28-2010 at 06:45 AM by trevorparsons
Updated 05-28-2010 at 01:21 PM by trevorparsons

My friend Isa has an Asus A6000 laptop she bought new about seven years ago. It is the mainstay or her communications and entertainment at home. It had Windows XP on it, which eventually got very slow due to cruft and malware.

I installed Ubuntu 9.04 on it a year ago or so, leaving an NTFS partition in place, full of photos. (I tried upgrading to 9.10 when that came out, but couldn't make the wireless chip work with it, so downgraded again).

Isa has got on OK with Ubuntu, and I sweetened the pill by installing Spotify which she hadn't come across before. But the machine had a recurrent problem of freezing up every now and then. I superstitiously thought that might be to do with the NTFS logical partition being on the same extended partition as / and /home -- no, I can't remember how I ended up with that partitioning scheme! -- so I've been keen to delete that for a while. The other day Isa scraped together 40 quid and bought a 250GB external disk from Argos, so we were able to back up the data from that NTFS partition, spin up a live CD and delete the old partition.

That's when the trouble started. Not having pulled this trick for a while, I forgot that GRUB would need to be informed of the change, and the installed system was as a result unable to boot -- grub error 22. I spent quite a lot of time trying to fix things with supergrubdisk, and eventually was able to boot the old system. At that point, if I had known my onions, I would have deleted the old menu.lst and run sudo update-grub which would at least have fixed grub. Ah well, you live and learn.

The only way I could think of to sort out grub was to make a fresh installation of Ubuntu into a new partition in the space freed by removal of the NTFS partition. In any case I wasn't happy with the position of the root and swap partitions, because they were in the middle of the disk, preventing me from growing /home. So, using an Ubuntu 9.04 live CD, I made a new 1GB primary swap partition and a new 9GB primary ext3 partition at the end of the disk, into which I installed 9.04 (sticking with what I know works), pointing it at the existing /home.

I ran the newly installed 9.04 and installed amsn, spotify, gitso (for remote assistance) and the restricted extras, to make the new system functionally identical to the old one for Isa.

I was then confident that I could delete the old root partition. However, I didn't want to do this from a live cd in case I borked grub again! So in order to do the changes within the running system, I enabled the root account, allowed root logins, logged in as root via gdm, killed a few evolution processes that were hanging on to /home (discovered by running lsof | grep /home), and unmounted /home.

Using gparted, I then deleted the old root partition and grew /home into the space (an overnight job as for some reason parted needed to move everything left a bit). That worked fine, and the /home partition is now 44GB instead of 32GB, so there's plenty of space for more photos . This leaves /home as a single logical partition in an extended partition, which is an oddity, but I hope that makes no practical difference. (At least I finally understand extended and logical partitions now!)

I ran blkid and checked that the uuids of the partitions were the same as those already listed in /etc/fstab. They were, so fstab didn't need changing.

grub needed to be informed of the changes, though. I did a bit of reading and discovered that if I mv'd menu.lst to menu.lst.bak and ran sudo update-grub, a fresh menu.lst would be generated. (This is the old grub, not grub2 of course, being 9.04). Tried a reboot. WORKS!

My quaint theory of the dodgy partition causing the system to seize up was soon disproved as I encountered a lockup after having deleted the NTFS partition. It took burning my fingers on the power input plug, which goes into the power socket right next to the heatsink, to realise that the problem was probably overheating. After all, it has been quite warm here in London over the past couple of weeks, and Isa says the computer's been locking up more often.

So I decided to remove the battery for a start, because it is knackered and draws power unnecessarily. The battery doesn't provide more than a few minutes' of power, so Isa only runs this machine plugged in anyway. I then removed a cover to expose the CPU, graphics chip and associated heat sink, and used a handy can of compressed air to blow away dust. I replaced the cover and stress-tested the system by installing build-essential and using a cpubuild script from the Gentoo hardware stability guide to compile kernels continuously, which keeps the CPU usage at 90% or so. The fans kicked in and expelled a lot of hot air at the back, and the system ran for half an hour or more without a problem. So my hope is that the cleaning and removal of the battery has solved the problem.

I shall now give the laptop back to Isa and I hope she likes it!
Posted in Uncategorized
Views 768 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 03:24 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration