LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Blogs > linux-related notes
User Name
Password

Notices


Just annotations of little "how to's", so I know I can find how to do something I've already done when I need to do it again, in case I don't remember anymore, which is not unlikely. Hopefully they can be useful to others, but I can't guarantee that it will work, or that it won't even make things worse.
Rate this Entry

Annotations while trying to eventually get suspension and/or hibernation to work

Posted 08-16-2017 at 04:33 PM by the dsc
Updated 08-16-2017 at 05:18 PM by the dsc

I've never used this kind of thing, decided to give a try, as it seemed safe for all I was reading.

"pm-suspend-hybrid" did work, but after resuming, the CPU fan was reset to full speed all the time, as if the BIOS was set to have "smart fan control" disabled.

It may be also partly because some of the power management options (whatever is its name) are set to "S3" which I recall reading isn't really appropriate for suspension (which keeps the stuff live on RAM, but the RAM itself isn't turned on). So maybe I should tried just "pm-hibernate" instead. Suspension seems to require S1, which in turns will use more energy all the time when the computer is shut down. 30-50 watts versus less than 5 if I recall.

But I guess that this mistake wouldn't have caused any difference on the behavior of the CPU fan speed. It should have probably just gone like "hey, we can't suspend with this BIOS options. Let's just hibernate then".

Some people seem to have run into similar problems, and their solution was to have the BIOS fan control turned off, having the linux' "fancontrol" process/service handle it as the system initializes or resumes (some extra scripting needed for the latter).

But I can't get fancontrol to work, or manually control the fan, even when the BIOS control is set to "disabled". To make things more complicated, there are two sets of possible pwm-control files; one at /sys/class/hwmon/hwmon1, which seems to be the more standard one, and other at /sys/devices/platform/it87.656/hwmon/hwmon1/. But echoing any number to the pwm files (after enabling with "1" to pwm#_enable or something) don't do anything, either with the BIOS control set as "disabled" or as "Intel (R) QST" (Quiet System Technology). The one other alternative besides "auto" is "legacy", but I don't know what it does yet.


At the moment, "pm-hibernate" seems to do nothing, even though I had the impression there was a surge in hard disk noises, presumably writing all the stuff. I was afraid o just leaving this mysterious, non-functioning hibernation by itself and decided to shut down instead.
Posted in Uncategorized
Views 279 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 09:47 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration