Welcome to the most active Linux Forum on the web.
Go Back > Blogs > ted_chou12
User Name


Rate this Entry

very important information:

Posted 09-15-2012 at 10:07 PM by ted_chou12
Updated 09-16-2012 at 11:51 AM by ted_chou12

Ubuntu Forums > The Ubuntu Forum Community > Main Support Categories > Multimedia & Video > [ubuntu] BTTV Capture card

PDAView Full Version : [ubuntu] BTTV Capture card


tsumaruOctober 5th, 2008, 04:26 AM
Hi there,

I have a BTTV based 4 port capture card. Unfotunately in lspci it doesnt give me a model.. just
03:00.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
03:00.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

After spending a few hours on BTTV Gallery i have found my card is apparently a TE104B.

The problem is i am unsure as to which card= setting to use in modprobe options. when i currently try to record something using mencoder (or even to view it with tvtime) all i get is a blue screen.

This is something thats been bugging me for a few weeks now.. can anyone help me or at least point me in the right direction?


[ 3317.266405] bttv0: Bt878 (rev 17) at 0000:03:00.0, irq: 20, latency: 64, mmio: 0xd2000000
[ 3317.267353] bttv0: using: *** UNKNOWN/GENERIC *** [card=0,autodetected]
[ 3317.267409] bttv0: gpio: en=00000000, out=00000000 in=00f360ff [init]
[ 3330.047488] tveeprom 0-0050: Huh, no eeprom present (err=-121)?
[ 3330.047500] bttv0: tuner type unset
[ 3330.047506] bttv0: i2c: checking for MSP34xx @ 0x80... not found
[ 3336.437368] bttv0: i2c: checking for TDA9875 @ 0xb0... not found
[ 3342.827241] bttv0: i2c: checking for TDA7432 @ 0x8a... not found
[ 3349.217208] bttv0: registered device video0
[ 3349.217471] bttv0: registered device vbi0


RingiOctober 5th, 2008, 05:17 AM
Try lspci -vn in terminal.
Check this:
Read this:


tsumaruOctober 5th, 2008, 12:41 PM
03:00.0 0400: 109e:036e (rev 11)
Flags: bus master, medium devsel, latency 64, IRQ 20
Memory at d2000000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2

03:00.1 0480: 109e:0878 (rev 11)
Flags: medium devsel, IRQ 20
Memory at d2001000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2
^^ lspci -vn

even though my card is not the same as the one in the link i tried card=13 to no avail i still get a blue screen


RingiOctober 5th, 2008, 12:52 PM
What do you get when you run dmesg in terminal?


tsumaruOctober 5th, 2008, 03:47 PM
dmesg output is in the first post


RingiOctober 5th, 2008, 04:35 PM
even though my card is not the same as the one in the link i tried card=13 to no avail i still get a blue screen

dmesg should show:
bttv0: detected: AVerMedia TVCapture 98 [card=13], PCI subsystem ID is 1461:0004

Check sudo gedit /etc/modules
is there something like this:
> lp
> psmouse
> bttv
> bt878

if you dont have bttv and bt878, add it.
Restart the computer and do dmesg again and try tvtime.


tsumaruOctober 6th, 2008, 04:25 PM
dmesg does indeed show that, along with insmod,options in it too.

both modules bttv and bt878 are loaded in modules and when the computer boots up. i have even tried adding bttv card=13 into /etc/modprobe.d/options.

When i load tvtime (or mencoder) all i get is a blue screen.

Tvtime, with card=13 only shows TV, Composite1 and Svideo whereas if i leave it to autodetect it gives me TV, Composite1, Svideo and Composite3

I have tried something on each port under each of the settings in tvtime. blue screen.

As you can see, this has been bugging me a while


RingiOctober 7th, 2008, 12:54 PM
You can try:
unload bttv and tuner using "rmmod bttv" and "rmmod tuner".
modprobe bttv card=13 tuner=2


tsumaruOctober 25th, 2008, 09:25 AM
sorry it has taken me so long to reply, i have been having problems with my internet.

Right, using card13 and tuner2 i can now get a picture.

Input 0 and 1 are both colour however input 2 is black and white
also the last input for the card isnt being mapped anywhere

Do you know of a way i can get the last 2 to display colour also?

And on an unrelated note to this, is there any way i can capture all four cameras at the same time?


RingiOctober 25th, 2008, 10:39 AM
Try more PAL tuners

tuner=0 - Temic PAL (4002 FH5)
tuner=1 - Philips PAL_I (FI1246 and compatibles)
tuner=2 - Philips NTSC (FI1236,FM1236 and compatibles)
tuner=3 - Philips (SECAM+PAL_BG) (FI1216MF, FM1216MF, FR1216MF)
tuner=4 - NoTuner
tuner=5 - Philips PAL_BG (FI1216 and compatibles)
tuner=6 - Temic NTSC (4032 FY5)
tuner=7 - Temic PAL_I (4062 FY5)
tuner=8 - Temic NTSC (4036 FY5)
tuner=9 - Alps HSBH1
tuner=10 - Alps TSBE1
tuner=11 - Alps TSBB5
tuner=12 - Alps TSBE5
tuner=13 - Alps TSBC5
tuner=14 - Temic PAL_BG (4006FH5)
tuner=15 - Alps TSCH6
tuner=16 - Temic PAL_DK (4016 FY5)
tuner=17 - Philips NTSC_M (MK2)
tuner=18 - Temic PAL_I (4066 FY5)
tuner=19 - Temic PAL* auto (4006 FN5)
tuner=20 - Temic PAL_BG (4009 FR5) or PAL_I (4069 FR5)
tuner=21 - Temic NTSC (4039 FR5)
tuner=22 - Temic PAL/SECAM multi (4046 FM5)
tuner=23 - Philips PAL_DK (FI1256 and compatibles)
tuner=24 - Philips PAL/SECAM multi (FQ1216ME)
tuner=25 - LG PAL_I+FM (TAPC-I001D)
tuner=26 - LG PAL_I (TAPC-I701D)
tuner=27 - LG NTSC+FM (TPI8NSR01F)
tuner=28 - LG PAL_BG+FM (TPI8PSB01D)
tuner=29 - LG PAL_BG (TPI8PSB11D)
tuner=30 - Temic PAL* auto + FM (4009 FN5)
tuner=31 - SHARP NTSC_JP (2U5JF5540)
tuner=32 - Samsung PAL TCPM9091PD27
tuner=33 - MT20xx universal
tuner=34 - Temic PAL_BG (4106 FH5)
tuner=35 - Temic PAL_DK/SECAM_L (4012 FY5)
tuner=36 - Temic NTSC (4136 FY5)
tuner=37 - LG PAL (newer TAPC series)


secsNovember 25th, 2008, 03:35 AM
Hi all.

Googling for a solution to basicaly the same symptoms, I came across this site and these posts. I have basically no hair left from playing.

I have a 4 port capture card based on a bt878 chip. It has no audio input jack and no tuner. Doing a Dmesg I get

Bt878 (rev 17) ***UNKNOWN/GENERIC *** [card=0, autodetected]

Tuner type unset

with bits and pieces of other info

then a line that says bt878_probe: card id=[0xffffffff], Unknown card

So is it possible I can use the info above


You can try:
unload bttv and tuner using "rmmod bttv" and "rmmod tuner".
modprobe bttv card=13 tuner=2

and simply keep going changing numbers till it works?

So far the best I have done is get a blue screen with no camera's connected and then if I plug a camera in, I get grey sort of picture that looks like a black and white tv not tunes into a channel correctly. Yeah I am old enough to know what a black and white tv is :-)

As mentioned above, this seems to be the best info I have found to date.



vBulletin® v3.8.7, Copyright ©2000-2012, vBulletin Solutions, Inc.
I think this is some very important information, so I am keeping a backup here, in case the original post is deleted.


Note: The correct title of this article is snd-bt87x. It appears incorrectly here due to technical restrictions.

1 What Is It?
2 Installing the Module
3 Loading the Module
4 Making Sure the Module Recognized Your bt87x Card
5 Making Your System Load the Module When it Boots
6 Testing the Driver
7 Using the Driver

What Is It?

snd-bt87x is a Linux kernel driver for the Advanced Linux Sound Architecture (ALSA). It allows you to capture digitized sound directly from a bt87x capture card, without hooking it to your sound card.

For more information of bt87x capture cards, see bttv.

For a more generic overview of TV audio-over-PCI, including other (non-bttv) analog cards, see PCI TV audio.

Installing the Module

To use the snd-bt87x driver, the driver module needs to be installed. To see if it is already installed on your system, type
# find /lib/modules/`uname -r` -name 'snd[-_]bt87x*'

If it returns a filename, the module is installed. If it doesn't, you will have to install it yourself. To do that, you will probably have to do one of the following:
install it from a package included with your Linux distribution
build it from the kernel source code included with your Linux distribution
build it from the ALSA source code (available at

Loading the Module

Once the module is installed, it needs to be loaded. To see if your Linux distribution has already loaded it, try
# lsmod | grep 'snd[-_]bt87x'
If it returns one or more lines, the module is already loaded. If not, you will need to load it yourself. To do that, try
# modprobe snd-bt87x
If it doesn't give you any errors, use the lsmod command above to confirm that it's loaded.

Making Sure the Module Recognized Your bt87x Card

Sometimes the driver doesn't recognize a bt87x card. To make sure that your card was recognized, try
# cat /proc/asound/cards
The output should have one or more lines that look something like
1 [Bt878 ]: Bt87x - Brooktree Bt878
If it doesn't, you can reload the module using the load_all option, so it will recognize more cards. To do this, do
modprobe -r snd-bt87x; modprobe snd-bt87x load_all=1
Now, the 'cat' command above should show your card.

Making Your System Load the Module When it Boots

Different Linux distributions use different configuration files to load and configure modules. Here's what you need to do for some distributions.
Mandriva 2007 echo "snd-bt87x" >>/etc/modules # load the module on boot
echo "options snd-bt87x load_all=1" >>/etc/modprobe.conf # OPTIONAL - if required for your bt87x card

Testing the Driver

Once the module is loaded, it creates one or more ALSA sound card instances, one for each bt87x card it found. To see these, type
# cat /proc/asound/cards
The number preceding the card you are interested in is the ALSA sound card number.

If your system uses udev or devfs, a corresponding device file might be created automatically. It will probably be named /dev/dsp for ALSA sound card zero, or /dev/dsp<ALSA_sound_card_number_here>.

If the device file has not been created, please refer to the documentation for your Linux distribution to determine how to create it.

Once you know the name of the device file, you can try it with:
# dd if=/dev/dsp1 of=/dev/dsp bs=1K count=33
Assuming that /dev/dsp is your default sound card, and /dev/dsp1 is your bt87x capture card, you should hear about 5 seconds of sound from your bt87x capture card. If you only hear static, don't worry, your capture card might not have the correct input selected or be tuned to a valid channel. If the sound you hear is noisy, it might be because the dd command is not meant for playing sound. It's just a very crude way to test that the driver is working. If you hear sound, it's probably working fine.

Using the Driver

To use the new ALSA sound card, just configure your application to use the device file as it's input.

For example, in MythTV, when configuring the capture card, just enter the device file where it says Audio device:.
Using in Fedora Core 6
If using a Hauppauge WinTV DBX 401 w/radio try using /dev/adsp1 as your audio device for capture during setup.
If you are fresh installing be aware that the sound may be very grainy and distorted. Go to the Recording
Profiles and change the Audio Codec to Uncompressed.
Posted in Uncategorized
Views 992 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 05:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration