Download your favorite Linux distribution at LQ ISO.
Go Back > Blogs > stuartd
User Name


Rate this Entry

Installing Slackware 12.2 On An Old Dell Laptop

Posted 08-17-2009 at 02:31 PM by stuartd

I have an old laptop computer that I have had an old distribution of Fedora running on for ages. I wanted to use the laptop with QCad to create drawings of a brake van that I am helping to renovate at my local steam railway.

I could have installed QCad on the Fedora setup but it was very slow and clunky and I thought that with a more stripped down installation it might be quicker. So I decided to install Slackware 12 that I got on the DVD that came with a copy of Linux Format Magazine (LXF).

This is the story of that installation. It's worth saying here and now that I am still using my desktop computer to do the drawings - and to write up this blog. The new installation of Slackware didn't go as smoothly as I might have liked.

The computer is a Dell Latitude CPi A Series

But first a confession. I am not a complete newbie to installing and configuring *nixes. I have used linuxes of various flavours over the past 10 or so years and have installed FreeBSD on one or two machines to play with. At work for a while I had a LAN running using a CentOS box as its Samba server, and it would have become the mail server if time and my manager had permitted.

So, I'm not a complete newbie, but nevertheless I think of myself as a beginner, and I am certainly a beginner with Slackware, which I chose because friends who are geeks and lovers of old British bikes (there's a clue in there!) advised me that it is the best.

What I am looking for in this process is more competent and confident control of the OS, its installation and maintenance and the installation of software. I did toy with Linux From Scratch, and may go there one day, but for now Slackware's cut-down package manager is near enough for me to compiling from source. I say "Slackware's cut-down package manager" which is what I understand it to be, in comparison to other distributions' package management applications, I could be wrong.

I got the first two ISO images of the Slackware 12.2 set from the Linux Format magazine DVD and burnt them onto a couple of CDs. LXF had done me a favour by only having two of the Slackware discs on their DVD because it meant I had to install a stripped down version of Slackware just to get it going.

After a couple of attempts to get the disc partitions right I got it installed: or so I thought.

I'd rather have /home on its own partition but in the end I put the whole intallation on one partition because I seemed to keep running out of space. The drive is only about 5Gb, barely enough.

So I partitioned hda into hda1 the / partition and hda2 a 500Mb swap partition which I put at the start of the hdd.

All went well until it offered me Lilo and then failed to install it. The rest of the install was complete but I couldn't get the machine to boot, it would get as far as diplaying "Grub" on the screen and then sit.

I tried various boot options from disc 1 of the set but could not get the machine to do what I wanted, perhaps because I didn't know what I wanted.

I booted TinyCore linux from a CD I burned from another LXF magazine DVD and found I could mount hda1 and look and even write to it, but I couldn't issue commands from there.

Puzzled I browsed the net looking for information on getting lilo to work and I kept nadgering away at the Slackware installation information.

In the end I tried booting from disc 1 of the Slackware set with the option root=/dev/hda1 in the boot command line and hey presto I had an OS up and running and was resident on the hdd. I know, "why didn't I try that boot option before?" Well, I thought I had but obviously I'd done something different.

I carried on looking at lilo information and discovered various lilo commands and configuration files. In the end I noticed while browsing through /etc/lilo.conf that line 64 looked like this:

root =

so I changed it to:

root = /dev/hda1

and saved the file. I typed `lilo` at the command prompt and got promising messages to the screen. I rebooted and there I was with Slackware booting from the hdd. Success!

It's worth saying that hda1 is my bootable partition. As far as I can make out the initial attempts to install and configure lilo, both from the command line and during the initial installation had tried to make /dev/hda the object of the boot process.

Now I have a working Slackware installation on my laptop but there's a long way to go. First of all I don't have it connected to the network. I know that the pcmcia network card works because when I booted using the TinyCore disc it found and configured the card and connected to the net. I haven't changed anything in the hardware since then, so the machine's present failure to connect to the net is somewhere in the configuration.

It's at this point that I decided to keep this blog. I have been chasing on the internet and in the Slackware documentation to find out how to configure the machine to install and use the network card. This blog is for me to keep a record of changes I've made and things I've tried as I get the machine to work. Maybe too, others who are installing Slackware will find my story useful as they confront similar problems.
Posted in Uncategorized
Views 2724 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 05:49 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration