Visit Jeremy's Blog.
Go Back > Blogs > SrDorothy
User Name


Rate this Entry


Posted 01-10-2009 at 10:23 PM by SrDorothy

Yesterday, a friend came over to help me try to put Rapla, a resource booking software based on Java onto our server which runs SuSe 10.2. I had updated it in preparation. But in the end, neither of us had enough experience or knowledge of the command line interface to accomplish it, or not completely. Our server runs without a GUI, and I know just enough to administer day to day stuff. Sometimes.

We tried putting it in /etc...why? Well, as one person might have described it, I was following my imagination vs. figuring it out! Obviously, that didn't work.

So we went to a machine on our network running Mepis 6.5 and placed it, after a few minutes thought, into /bin--what an idea!--since Rapla is a binary file... Well, we're still learning!

So we clicked on the file, and nothing seemed to happen. Then we clicked on the file........and wow! The Rapla splash started! The application opened up and we played with it for a bit. Then we tried to access it on another (Windows) machine via Firefox, which is the way it is supposed to be accessed--but it didn't work, even after we opened the correct port in the firewall. Hmmm, something still not right.

We felt pretty good about the progress we made, though, and then my friend went home. While I was making a record of what we had done, it occurred to me that we had NOT tried putting it into /bin on the SuSe server--so I did that. Um. Now what? No easy click of the mouse without a GUI.

Did some research online and found instructions for executing a .sh file by first changing it to be executable, then executing, so:

chmod +x [to make it executable]
./ [to execute it]

So I did that, and it told me that it couldn't find Java--that I needed to set JAVA_HOME to point at my Java Development Kit installation. But at least I am pretty sure it would have run if I coulda done that!

Have you ever noticed that as soon as you figure out one thing you'll likely run into something else you have no idea how to do? Time to call on my more experienced Linux friends...and do more research! Stay tuned...
Posted in Uncategorized
Views 1208 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 11:50 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration