LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Blogs > An open source user evolution
User Name
Password

Notices


This blog is to document my progress with Linux and programming in general. I started off trying to fix my computer which led me down a road of great intrigue into Linux and programming. From this, I also developed a passion to document what I do for two reason; first is to have a history of what I have done and second is leave the possibility open for feedback and suggestions or even simple discussion. Feel free to email me schulidr@protonmail.com or send me a message on here. I can also be found on twitter, mastadon, manjaro forums, arch forums, and IRC all of which I have the same handle.
Rate this Entry

Arch FINALLY BOOTS

Posted 03-02-2019 at 07:41 AM by schulidr

I set about on a quest recently to scratch the itch of completing an install of Arch on my older laptop. I had tried it in the past with no luck and I was reluctant to do it again but through someone who has become somewhat of a mentor and friend to, I was persuaded to try it one more time. My void install that mimicked the look of an old Solaris machine would soon become a dual-boot project bigger than I thought was possible.

Starting out I needed a plan of what I wanted to do and how I wanted to get there. I decided on a simple partitioning scheme that would shrink my current void partition by about 30GB to allow for a small spot for me to install Arch and maybe play around with customizing it a little bit. I didn't have much of anything to lose on the void install other than a few hours of making it look like an old ass computer, so I just made a snapshot of it and proceeded to make my Arch USB for install.

Same old song and dance making the USB with dd and proceeding to boot off of that. I have tried this in the past with no luck because of the internet requirements for the install. I don't have easy access to hook a cable up to my router so I need to figure out a way to enable my wireless card and actually get it to work. This is what has stopped me in the past because it has simply gotten to be too confusing for me.

I spent hours reading into it and trying different things in the live Arch environment and nothing was working. Finally, thanks to my good friend, I wrestled with wpasupplicant (which I had been avoiding hoping that I wouldn't need it) and figured it out. Using the Arch Wiki I configured the wpasupplicant to connect to my wifi but it still couldn't connect to the internet without an IP address. So I used dhcpcd for my access point and it configured it all for me no problem. I sent out a ping to verify connectivity and I was up and running in about 10 minutes. So now I can finally move on to installing packages!!

I partitioned the disk, shrinking the void partition slightly and mounting the all the rest of what I needed to, which was my efi partition. Installed grub and went on my way to a restart which brought me to grub recovery shell. Well crap, what did I do wrong. I used my arch install USB to boot back up and chroot into my installed Arch environment and investigate. Everything looked good with all the troubleshooting I did until I tried to mount the partition I had shrunk earlier. I figured I could chroot into void and revert back with my snapshot. Well that wasn't the case as it turns out my partition was corrupted from resizing it earlier. Now I am back to square one.

This now became a full rebuild that I was determined to complete. I left it for the night and returned the next morning. I have become fairly good with the first few steps of the Arch installation process by now so getting to the point of rebooting took little under an hour. And I tried it... and it failed again lol. So what the hell did I do wrong this time?!?!? Well, for starters I mounted partitions completely wrong. I installed grub to the wrong file and I generated my fstab with the wrong partitions mounted in the wrong spots. It was a mess all around and fixing it was becoming a major task. I resorted to trying one more install from scratch.

Using all the lessons I had learned from my 10+ other attempts at installing Arch I gave it another shot and quickly found myself at the reboot point once again. I double checked stuff as I was going through the process to make sure I wasn't making the same mistakes I had in the past and I verified my mount points several times. Once I was comfortable that everything that could be checked was in actually checked, I shut it down to see if I could boot it right back up.

This time it worked and I was THRILLED to see the grub screen pop up with the option to load arch. But was I really there? It still needed to load the OS so I wasn't out of the woods yet. I pressed enter to proceed and within seconds I was greeted with my first login screen on my first successful install of Arch Linux. It was a goal I set for myself several months ago and it's finally here.

This has been an incredible learning experience for me. Now that the first install is done, I can focus on getting void back on there. I'm not the biggest fan of dual-booting anymore but I still think the capability is awesome. And what the hell, having these two distros on one computer would be a bit of an accomplishment for me. We will see if it works out. Either way I'm sure to learn a lot while trying!
Posted in New to Linux
Views 39 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 11:42 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration