Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Blogs > robertvi
User Name


Rate this Entry

Ubuntu 10.10 on Lenovo B560 laptop

Posted 08-01-2011 at 10:34 AM by robertvi
Updated 11-22-2011 at 03:16 PM by robertvi

I recently bought a new laptop from preinstalled with windows 7, and have now set it up as a dual boot ubuntu/windows 7 machine. So far I only use win7 for playing eve-online. Here are some notes about the laptop and install process in case they are of any use to anyone considering buying a new laptop for linux.

laptop spec:

Lenovo B560 4330 (part number M489GUK)
CPU: Intel Core i3 380M 2.53 GHz Dual-Core, Hyperthreaded, with integrated Intel graphics
15.6" screen
Windows 7 Home Premium
64 bit laptop
unusually for a laptop the keyboard includes a dedicated numerical pad

My impressions so far: a well made laptop, good value for money. My previous laptop, an HP Pavilion dv2202 about 4 years old, ran with a hard drive temp up to as high as 57C, and had started to get bad sectors. The B560's drive seems to run at more like 45C, which hopefully will give the disk a longer life.

This is the Arrandale generation of i3 processor not the more recent Sandy Bridge generation. I chose to avoid Sandy Bridge because I read a number of reports of problems getting the integrated graphics working correctly with linux. I don't know how current this problem is, and the newer integrated graphics would presumably be significantly better, but I chose to play it safe (I can still play eve online at 20 fps currently under win7 with this laptop).

When it first arrived I booted into win7 for the first time (why does windows always need to reboot multiple times if it's already installed?! For the record: 17 minutes until the first application crash), and tried to test all the hardware such as camera, fingerprint reader etc. under windows. This means any problems under linux can probably be put down to software rather than hardware issues. I was not able to test the eSATA port as I don't have any eSATA enabled devices. The specs don't seem to mention eSata, so I'm not even sure if it's actived (it also doubles as a USB port, which does work ok).

Having checked the hardware I burnt two recovery disks in case I ever need to return the disk to the factory state. Now time to shrink the windows partition to make room to ubuntu.

Using the [my computer -> right click -> manage] disk management utility, windows claimed it could only resize it's NTFS partition down to about 200GB due to the presence of 'unmoveable files', and this was far more of the disk than I needed to devote to windows (I'd rather have no win7 than waste 200GB of my new disk! I've got data to store!). Using an ubuntu 10.10 live DVD I shrink the partition down to about 46GB, deleted two additional windows partitions (I think these were for encrypted file storage and lenovo recovery) and installed ubuntu into the remaining space. I left the 210MB windows boot partition alone.

The disk is now: [210MB win7 boot|46GB win7 NTFS|451GB ubuntu ext4|3GB swap]

The next time I booted windows it did a file system check, but seemed otherwise to be happy.

Ubuntu seems to be working fine, although I've been too busy to check everything so far. I'll report back as I check things out. I installed the 32 bit version of ubuntu, because this is the disk I had available.

During installation I selected for ubuntu to encrypt the home folder. This means that if someone steals the machine and does not know your password, they will find it very hard to read any files in your home folder. Everything is done automatically by Ubuntu, including automatically creating the encryption password for your data. Should the system fail, you will want to have this password written down somewhere safe, or stored in a password manager NOT in your home folder. So once ubuntu was installed I ran the command 'ecryptfs-unwrap-passphrase' to show me the encryption password.

The only drawback I found so far with the encrypted home folder system is that very long file names cannot be stored in it. Some of my mp3 files (from I believe) have very long names which I had to manually shorten in order to store in my home folder.

Now tested the webcam, working fine with cheese.

SD card reader and wireless also working fine. (Ubuntu seemed to automatically install a proprietary driver for the wireless, without my intervention).

Update: wireless problem 2011-11-22
Wireless worked flawlessly until one time recently I changed the wireless password on the network to allow a guest to use her wireless device. For some reason when I changed the password back to the old one my laptop would no longer connect. The icon would stay with one green light on and never get the second one. 'sudo iwlist eth1 scan' returned an error, and 'sudo ifdown eth1' said the interface wasn't even configured. I found a post by someone saying they had this problem after they turned the hardware wireless isolation switch to off while wireless was in use - maybe that's what I did. I can't imagine changing the network password would do it, but who knows. They solved the problem by doing something in the bios. So I did the IT Crowd thing: I turned it off then back on again, and it worked! I went into the bios (restart the machine, but press F2 as soon as the first start-up screen appears) and disabled wireless, loaded ubuntu, then restarted again and reenabled wireless in the bios. Then wireless was immediately back working again.
Posted in Uncategorized
Views 3495 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 01:20 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration