Review your favorite Linux distribution.
Go Back > Blogs > nomen
User Name


Rate this Entry

SOLVED wireless card problem: ubuntu i386: ERROR SAID: SIOCSIFFLAGS: Device or resource busy

Posted 03-18-2012 at 02:31 PM by nomen

STEP 1: Is there a wireless network card present? YES: see list hardware:

#lshw -C network
*-network DISABLED
description: Wireless interface
product: RT2561/RT61 802.11g PCI
vendor: RaLink
physical id: 1
bus info: pci@0000:11:01.0
logical name: wlan0
version: 00
serial: 00:08:a1:be:9a:67
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rt61pci latency=32 multicast=yes wireless=IEEE 802.11bg
resources: irq:0 memory:fc500000-fc507fff

STEP 2: Is there a driver module loaded for the RaLink RT2561? YES: list modules:

#lsmod | grep -i RT
rt61pci 18920 0
crc_itu_t 1371 1 rt61pci
rt2x00pci 6027 1 rt61pci
rt2x00lib 27541 2 rt61pci,rt2x00pci

STEP 3: Can I bring it up? NO: this is the error message:

#ifconfig wlan0 up
SIOCSIFFLAGS: Device or resource busy

==> Here is the solution, that finally worked for me.
This was posted by another kind linux user:

open the computer
take out the wireless PCI card
put the wireless card back in

Posted in Uncategorized
Views 1700 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 06:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration