Share your knowledge at the LQ Wiki.
Go Back > Blogs > Neo@Matrix
User Name


Rate this Entry

Error opening /dev/sdb:Permission denied

Posted 11-02-2009 at 04:36 PM by Neo@Matrix

What distribution are you using?

On Ubuntu, root isn't given a password by default, but the first user to have an account will be able to use the `sudo' command to run individual commands. So, instead of typing `program-name --argument' to run your program as a normal user, you'd type `sudo program-name --argument' to run your program as the root user, and then everything should be dandy.

As I wrote ,I use Ubuntu 9.04 ,
I tried the command :
sudo format/dev/sdb what is most likely not correct
But as I said , I have no experience with Linux at all
I know it is pretty much to ask , but if U could write the whole command line instead of `sudo program-name --argument'
it would make much easier for both of us. lol
I have no idea , what to write for program name or argument.
I know what should I do under windows , but I want to learn to use Linux.This is like homework for me .
Basically no one near me uses Linux at all .

When I read property tab on device , the filesystem type is MSDOS
The permission tab has info like: The permission of "NEW VOLUME"could not be determined.
ALSO only 967.5MB is the visible size of the 2Gb size of the card?!

TY very much on effort and Your time
Posted in Uncategorized
Views 2438 Comments 3
« Prev     Main     Next »
Total Comments 3


  1. Old Comment
    Well at first maybe, you can check your user and group permissions...
    Posted 11-04-2009 at 03:36 AM by 234107 234107 is offline
  2. Old Comment
    And also check what you are able to do with sudo, forgot to mention. Your main clue is that, you dont have permissions. As root, you can do anything. So there is something wrong or you are doing something wrong, or your tools are not properly configured.

    Check for problems, in /etc/passwd, /etc/group/, /etc/sudoers (visudo command), ugo permissions on /dev/<device>

    Ubuntu by default i think is not giving you freedom as other distros. You can ofc easily configure it and remove annoying(for me) restrictions which main point is to protect you from damaging your system. Everything is up to you and your skills. But be careful. Freedom means responsibility
    Posted 11-04-2009 at 04:00 AM by 234107 234107 is offline
  3. Old Comment
    I sorted out that the SD was faulty
    the locking tab doesn't worked.
    So it is now sorted
    Posted 11-06-2009 at 10:31 AM by Neo@Matrix Neo@Matrix is offline


All times are GMT -5. The time now is 05:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration