LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Blogs > mrknify
User Name
Password

Notices


Rate this Entry

install slack to lg x110 day 1

Posted 04-26-2015 at 11:15 PM by mrknify

Today I installed Slackware via an sd card. It did not go smoothly.

I used rufus usb key installer to put the 14.1 iso onto my sd card. Booted my LG x110 with the card, now my little netbook is my toy, I use it to install all manner of things before migrating them out. Previously I had installed two versions of Oz Unity on my netbook, they installed to duel boot with the netbooks Windows XP using grub. more recently I had been using Arch Linux via usb install to a SD card but that card corrupted, so I used the card for Slack.

running the SD card to boot my LG x110 worked without errors, took a bit long but it worked. I was deposited into the nice little shell where I immediately went into fdisk to prepare the HD for installation.

fdisk /dev/sda

this access the whole hard drive and all its partitions. after that I removed my old linux extension and partitions. I saved the changes leaving the empty space, quit fdisk and ran fdisk again.

I do this this way to ensure the transition of partitions goes smoothly as with a SD card this has caused problems before with me.

I then proceed to create a new extension (sda4) as then I partition the extension; sda5 -ext4, sda6 -ext4, sda7. The last partition I set for 2148 M (with my setup I have never needed more then that). flag the swap as a linux swap partition and off I go.

next I go into the setup, following all the nice instructions its fairly easy. Even setting up LILO(advanced) went smoothly no errors there. quit reboot.

<grub rescue>

uh oh, bad grub persistence LILO did not take over the MBR (master boot record) from grub.
If you follow the link you can see how I fixed that issue. I was stuck read and re-read many posts about grub, LILO and using a windows boot key to fix it. (not possible as its a netbook and the repair part no longer has the grub.cfg pointing to it)

so I found my solution during a re-install of Slackware 14.1 (gotta try everything right!) I used the terse option instead of verbose and noticed grub being put into the filesystem. BAM! solution re-install grub. Its been the only one I've really used, even though I want to use LILO just to compare what one I like better.

reboot, login: ## incorrect login
oops have to go back and make a user. done, reboot, xfce4 is not loading now. try to find it, apparently it is not installed... weird I check the installed packages with pkgconfig, a nice gui pops up (not unlike the install gui) lets me confirm the packages, yes it is there! ok hit the forums again. took a while found several workarounds that did not work for me (some not as clean as others) found one that does work.

Now to fix the window manager; I like XFCE its low on resources and fairly easy to manage.(i really like AwesoneWM, I3, and XMonadWM but they are for a later date.)
startxfce4 works great... In root. out of root it fails as It can not create directories needed.

Todays problems sorted out. Tomorrow clean install (format partitions included) and try again.

Cheers
Posted in Uncategorized
Views 829 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 11:08 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration