Visit Jeremy's Blog.
Go Back > Blogs > MrCode
User Name


This is the first "blog" of any kind I've ever had, so it's probably not the greatest...

Just a little snippet about me:

I'd like to consider myself relatively tech-savvy; obviously I use Linux (Arch to be precise; K.I.S.S. FTW), and I enjoy learning new things about computers in general (both software and hardware-related).

This blog is mostly just for whenever I feel like telling the world about my experiences with computers/Linux (or just life in general), or just posting for the hell of it.
Rate this Entry

Re-installing...because of a MOUSE problem!

Posted 01-24-2011 at 06:55 PM by MrCode
Updated 01-24-2011 at 07:06 PM by MrCode
Tags linux

I decided to completely re-install Arch from scratch on my lappy (save for keeping the /home partition of course).

Why? Mouse issues. Specifically, the newest Synaptic touchpad driver that came with the update to Xorg 1.9. I've been having a hell of a time getting the sensitivity correct (first it was too slow, then too fast), and the pointer would also stutter on occasion (I even posted in the Linux - Desktop forum about this little issue; still hasn't received any replies). At one point I actually had the sensitivity set just about the way it used to be before the Xorg update, but after a restart, everything was way too fast! I tried re-installing the Synaptics driver...nothing. I tried removing the config file in /etc/X11/xorg.conf.d (keeping a backup of course), and that rendered the touchpad useless. Pacman wouldn't seem to let me completely re-install Xorg, so I finally said "screw this, I'm starting from scratch!".

Sure, call me lazy...I get easily frustrated with things, and I tend to give up on them somewhat easily, too. Maybe I shouldn't be using Arch, then, but it's the only distro I seem to really like (it gives me a nice blank slate to start from and build upon...with dependency resolution! ). Seriously, I would try Slackware, but a) it just comes with too much by default (yes I know you can uncheck most of it, but I'd really rather not have to go to that much trouble just to get a minimal system), and b) I don't like the idea of having to manually grab dependencies, especially if there are a lot of them. This also complicates removing packages as well (you have to know exactly what the package depends on and what depends on it).

So here I am waiting for a fresh net-install of Arch to complete, and I'm seeing quite a few "error: failed retrieving file '<package>.pkg.tar.xz'" messages...I'm wondering if that means I'll have a broken system once it finishes.

EDIT: Yup, broken install (couldn't even finish the installer; all the config files were blank at the end)...well, looks like I'm doing a regular local install and updating later.
Views 14485 Comments 5
« Prev     Main     Next »
Total Comments 5


  1. Old Comment
    Just an update:

    Well, I got things set up (roughly) the way I had them before, and everything seems to be a bit faster* (), but the mouse stuttering issue still hasn't gone away...didn't think it would.

    There are still a few other minor warts that need to be taken care of, but so far so good. Keeping my /home partition let me keep a lot of my settings, so that helps quite a bit.

    (* - I think it's because I actually know a little more about what the hell I'm doing...and because I installed Xfce 4.8 from scratch; the update from 4.6 had done some annoying little things, e.g. automounting not working at first, logging out taking a couple seconds, etc.)
    Posted 01-25-2011 at 07:34 AM by MrCode MrCode is offline
  2. Old Comment
    A mouse is an odd thing to go bad if you don't muck with settings. I would try wiggling the cable at different spots to see if something didn't happen. I've seen them go bad right where the cable enters the mouse. If you are good at soldering, you could try an fix it your self.
    Posted 01-25-2011 at 11:02 AM by lumak lumak is offline
  3. Old Comment
    I would try wiggling the cable at different spots to see if something didn't happen. I've seen them go bad right where the cable enters the mouse. If you are good at soldering, you could try an fix it your self.
    This is a laptop touchpad, not a wired mouse.
    Posted 01-25-2011 at 12:51 PM by MrCode MrCode is offline
  4. Old Comment
    err yeah... I read that in the main post a few days ago... sorry :P
    Posted 01-25-2011 at 02:54 PM by lumak lumak is offline
  5. Old Comment
    Another update:

    I keep tweaking the sensitivity with synclient, but it just never feels quite the same no matter how much I screw with the MinSpeed, MaxSpeed, and AccelFactor paramaters. Really makes me wish there was some way I could go back to the old Synaptics driver just so I could have my old sensitivity/acceleration settings back (if only that).
    Posted 01-25-2011 at 04:42 PM by MrCode MrCode is offline


All times are GMT -5. The time now is 02:39 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration