Share your knowledge at the LQ Wiki.
Go Back > Blogs > Kenny the one-teen comittee to stamp out Proprietary $uckware
User Name


I decided to post a little introduction to myself here: Ask me who I was last March, and I would have had WinBloze 7 Beta on my main computer and would have been part of Micro$uck's test project for WinBloze 7 and would have been excited about it. However, that changed as soon as my network adapter changed and the new one worked with Linux. As soon as I tested the new adapter with Mint (I'd say about a year ago, in July 2009) I began to really value Linux for what it is.

However, I knew about Linux long before that. I started with gOS 2, which was my first distro. I had tried it back in about February 2008. I first learned about Linux back in mid-2007, from an article in PCMag that spanned several pages. I had quite a hard time back then, and Ubuntu Hardy was no different than gOS.

So then what took me so long from knowing about Linux to finally becoming an active user? My house was nothing but Wi-Fi. My mother set a secure wireless network up back then, and I couldn't connect to it because my adapter (Linksys WUSB54GSC) wasn't recognized by Linux. I had the patience to continue.

Then, in June 2008, my family got hit by the economic collapse here in the USA: The mortgage on my old house doubled and my family had to leave because of the rate increase. So, we were stuck in a hotel room until my family and I could end up in a new house. That Christmas, I wanted a netbook, and got my wish (the one I'm typing on, an Acer Aspire One AOA110-1545). It came with Linux preinstalled, and I liked it all around.

From then to June 2009, I still had WinBloze on my desktop, as Linux still didn't work with my wireless network adapter. Then, in June 2009 as I said, I got a new wireless network adapter, and in July decided to test it with Linux Mint 7. It worked, even from the Live CD! Now,

Rate this Entry

The Toolkit Wars 2.0: GTK+ 3.0 vs. Qt 4 vs. Clutter

Posted 08-18-2010 at 12:30 AM by Kenny_Strawn

Now that GTK+ 2.90 (a.k.a. 3.0 Beta) is out, we now have three head-to-head toolkits, all with advanced graphics, to deal with. How do these toolkits stack up? That's up to your comments.

To start it with my opinion: I would put Clutter at the top, followed by Qt and lastly GTK+. The reason for this is that Cairo (being the drawing API in GTK+) is 2D instead of 3D, and we all know that's really old fashioned. Qt in contrast actually allows for 3D acceleration while Clutter is built all around OpenGL and so as a result Clutter is 3D all the way, not just partially.

Again, though, which API wins is up to you. Please feel free to comment here which toolkit you like better (since there is no option to post a poll in my blog).
Posted in Uncategorized
Views 11817 Comments 16
« Prev     Main     Next »
Total Comments 16


  1. Old Comment
    I wouldn't call being fully 3D an "advantage". Not all Linux machines even have working 3D, of even have suitable hardware!

    Seems like much better criteria would be programming style, ease of use, licensing, etc..
    Posted 08-18-2010 at 07:29 AM by MTK358 MTK358 is offline
    Updated 08-18-2010 at 07:35 AM by MTK358
  2. Old Comment
    Who needs 3D? It's mere eye-candy.
    Posted 08-18-2010 at 07:49 AM by brianL brianL is offline
  3. Old Comment
    Actually, it's not the 3D in Clutter that is most astounding. It's native RGBA support (and customizable support, with a function instead of a boolean). I know this because I have used the function in GNOME Shell's theme (and GNOME Shell uses Clutter instead of GTK+).
    Posted 08-18-2010 at 01:07 PM by Kenny_Strawn Kenny_Strawn is offline
  4. Old Comment
    But even though I use the open-source xf86-video-ati driver, GNOME Shell was unusable for me. It's like the WHOLE DESKTOP refreshed every 10 seconds, and I'm not exaggerating!!!
    Posted 08-18-2010 at 08:01 PM by MTK358 MTK358 is offline
  5. Old Comment
    With me and FGLRX, I would get a flickering screen (on my older 2400 graphics card) when I ran GNOME Shell, but it was no slower than my netbook (with an Intel 945GME).

    Edit: If the 2400 can run GNOME Shell just fine with FGLRX, so can the 4350.
    Posted 08-19-2010 at 02:01 PM by Kenny_Strawn Kenny_Strawn is offline
    Updated 08-19-2010 at 02:07 PM by Kenny_Strawn
  6. Old Comment
    But I'm not willing to use FGLRX or the proprietary Nvidia driver. Until xf86-video-ati and Clutter play nice together, I won't use it.
    Posted 08-19-2010 at 08:08 PM by MTK358 MTK358 is offline
  7. Old Comment
    What about noveau? Or maybe xserver-xorg-video-ati?
    Posted 08-19-2010 at 09:24 PM by Kenny_Strawn Kenny_Strawn is offline
  8. Old Comment
    I didn't know about xserver-xorg-video-ati. What's the difference between it and xf86-video-ati, and does it support 3D too?
    Posted 08-20-2010 at 06:08 AM by MTK358 MTK358 is offline
  9. Old Comment
    Sorry, I found out that's merely an Ubuntu package for xf86-video-ati, so it won't work. What you need is two drivers - xf86-video-ati and xf86-video-radeonhd. The RadeonHD driver is what you need to work well with newer cards.

    See and

    Note: 3D support in RadeonHD is IN DEVELOPMENT! Please use with care, but you may need to look here for more info:
    Posted 08-21-2010 at 11:31 AM by Kenny_Strawn Kenny_Strawn is offline
    Updated 08-21-2010 at 11:58 AM by Kenny_Strawn
  10. Old Comment
    I tried xf86-video-radeonhd before and it didn't even have 3D!
    Posted 08-21-2010 at 11:41 AM by MTK358 MTK358 is offline
  11. Old Comment
    If you look at another part of the comment, 3D support is UNDER DEVELOPMENT for radeonhd and needs to be built from source.

    Either that, or use radeonhd 1.3.0 and Linux Kernel 2.6.32 or higher.

    Please check the version of Arch's radeonhd (probably with Pacman).
    Posted 08-21-2010 at 02:24 PM by Kenny_Strawn Kenny_Strawn is offline
    Updated 08-21-2010 at 02:34 PM by Kenny_Strawn
  12. Old Comment
    $ pacman -Ss xf86-video-radeonhd
    extra/xf86-video-radeonhd 1.3.0-2 (xorg-video-drivers) [installed]
        Experimental Radeon HD video driver for r500 and r600 ATI cards
    Posted 08-21-2010 at 03:50 PM by MTK358 MTK358 is offline
  13. Old Comment
    As I can see it's Now post the output of the following commands:

    pacman -Ss linux
    pacman -Ss mesa
    Posted 08-21-2010 at 04:32 PM by Kenny_Strawn Kenny_Strawn is offline
  14. Old Comment
    In Arch Linux, the kernel package is called "kernel26", not "linux".

    $ pacman -Ss kernel26
    core/kernel26 (base) [installed]
        The Linux Kernel and modules
        Kernel hackers manual - HTML documentation that comes with the Linux kernel.
    core/kernel26-headers [installed]
        Header files and scripts for building modules for kernel26
        The Linux Kernel and modules - stable longtime supported kernel package suitable for servers
        Header files and scripts for building modules for kernel26-lts
        Kernel hackers manual - Section 9 manpages that comes with the Linux kernel.
    core/linux-firmware 20100807-1 [installed]
        Firmware files for Linux
    core/zd1211-firmware 1.4-3
        Firmware for the in-kernel26 zd1211rw wireless driver
    extra/nvidia 256.44-2
        NVIDIA drivers for kernel26.
    extra/nvidia-173xx 173.14.27-2
        NVIDIA drivers for kernel26, 173xx branch.
    michael@michael-desktop ~ $ pacman -Ss mesa
    extra/3ddesktop 0.2.9-3
        a 3d virtual desktop switcher (opengl/mesa)
    extra/ati-dri 7.8.2-1 [installed]
        Mesa DRI drivers for AMD/ATI Radeon
    extra/intel-dri 7.8.2-1
        Mesa DRI drivers for Intel
    extra/libgl 7.8.2-1 [installed]
        Mesa 3-D graphics library and DRI software rasterizer
    extra/mach64-dri 7.8.2-1
        Mesa DRI drivers for ATI Mach64
    extra/mesa 7.8.2-1 [installed]
        Mesa 3-D graphics libraries and include files
    extra/mga-dri 7.8.2-1
        Mesa DRI drivers for Matrox
    extra/nouveau-dri 7.8.2-1
        Mesa Gallium3D DRI drivers for Nouveau - highly experimental/unsupported
    extra/r128-dri 7.8.2-1
        Mesa DRI drivers for ATI Rage128
    extra/savage-dri 7.8.2-1
        Mesa DRI drivers for S3 Sraphics/VIA Savage
    extra/sis-dri 7.8.2-1
        Mesa DRI drivers for SiS
    extra/tdfx-dri 7.8.2-1
        Mesa DRI drivers for 3dfx
    extra/unichrome-dri 7.8.2-1
        Mesa DRI drivers for S3 Graphics/VIA Unichrome
    community/lib32-libgl 7.8.2-1 (lib32) [installed]
        Mesa DRI OpenGL library and drivers
    community/lib32-mesa 7.8.2-1 (lib32) [installed]
        Mesa OpenGL library
    Posted 08-21-2010 at 07:09 PM by MTK358 MTK358 is offline
  15. Old Comment
    How long ago did you try RadeonHD? Apparently, if you didn't try 1.3.0 there's your problem.
    Posted 08-21-2010 at 10:19 PM by Kenny_Strawn Kenny_Strawn is offline
    Updated 08-22-2010 at 01:53 AM by Kenny_Strawn
  16. Old Comment
    I tried RadeonHD, it screwed up everything, I was only able to get it working again by pressing the reset button and switching back to xf86-video-ati.

    Anyway, looks like Qt is catching up with Clutter with their 4.7 release, introducing Qt Quick and QML:
    Posted 10-08-2010 at 11:32 AM by MTK358 MTK358 is offline


All times are GMT -5. The time now is 05:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration