Welcome to the most active Linux Forum on the web.
Go Back > Blogs > FredGSanford
User Name


Rate this Entry

Debian Testing

Posted 08-15-2009 at 06:33 PM by FredGSanford

About three weeks or so ago I installed Debian on a Dell Inspiron 2650 laptop and everything was going pretty smooth.

I did a netinst with LXDE desktop and plugging in my USB Dell 2 button wheel mouse worked. It has the 2.6.26 kernel.

Around Aug, 09, I did a safe-upgrade and now the mouse is not working at all. The touchpad continues to work.

When I run dmesg | tail, I see 'New USB device found' after unplugging & re plugging the mouse in the port.

I just plugged in a usb thumbdrive and it is detected and automounted.

I posted this issue in the Debian forum hoping to find an answer but so far nothing solid. I even install the 2.6.30 kernel from Sid but that has brought on a completely different issue, It won't boot.

Now I'm beginning sometimes to wonder what is going on in the Debian development camp.

Just a small rant.
Posted in Uncategorized
Views 20457 Comments 4
« Prev     Main     Next »
Total Comments 4


  1. Old Comment
    Unless I am testing or trying something new I tend to stay away from upgrades (safe or not) if everything is working. When I do run into problems like this I try and ask myself:

    Was this the right upgrade?

    Is something different or unusual with my equipment?

    Is it my time? (what ever can go wrong does)

    Then last, why did the developers not find this problem by now, how could they miss this?

    Now I report the problem then go back and try and undo everything, my knowledge is limited and I must rely on others to develop my systems. During the processes above I have been known to bang my head on the wall and scream at objects.
    Posted 08-16-2009 at 06:34 AM by Larry Webb Larry Webb is offline
  2. Old Comment
    Hi Larry. So you don't update/upgrade your system much? Since I'm using Debian, I assume the upgrades are more for bug fixes than anything else. Doing a dist-upgrade would take me to the next level of upgrading the OS itself, I believe.

    I would assume it was a pretty safe upgrade, since everything is working as usual, except for a USB mouse stop working.

    Nothing different or unusual other than an older laptop about 5 years old.

    Maybe it was my time for something like this to happen. I've used Debian before running Sid (untesting) and did have major problems upgrading. Now I'm not in no hurry to run sid as much.

    I don't think its a matter of the developers not finding it, but why it happen. I'm sure they can overlook or underlook code. All it takes is one letter/number to be misplaced and it will cause havoc on the program.

    I think I will go check bug reports and go bang my head on the wall some more. As I mention, everything is working fine using the touchpad, but being a laptop and at home, I just like to use a mouse instead of the touchpad.

    Posted 08-16-2009 at 12:23 PM by FredGSanford FredGSanford is offline
  3. Old Comment
    I do upgrade the distros to the next released level but very seldom do any upgrades after installation and setup of the distro. I have five linux distros on my computer with two being up to date. I keep two up to date and this keeps me from banging the wall if something happens. The other three are a couple of years old and I use for experimenting. I have an old football helmet you can borrow till you get yours fixed.
    Posted 08-16-2009 at 03:48 PM by Larry Webb Larry Webb is offline
  4. Old Comment
    Debian was one of my first distros, and I liked it a lot. However, the upgrading part seemed to break things occasionally, like the USB mouse issue you described here. So I got into the habbit of backing up the entire system drive before doing upgrades. The updates part seldom ever breaks stuff, but I remember one time when my Radeon graphics stopped working just after a basic update. The computer that I had at the time was pretty old though, so it could of just been the crusty hardware finally quiting on me, but I still found the problem very frustrating as I did not have a replacement graphics card. Perhaps anoher USB mouse will work? Some makes and models of computer mice don't use conventional signaling rules on the cable, and so require special drivers to work. I know it sounds silly, but sometimes even the most basic of pointing devices can be like this. You have to keep in mind that just because the mouse says Dell, the chips inside may not have been created by Dell
    Posted 08-30-2010 at 09:59 AM by PhoenixAndThor PhoenixAndThor is offline


All times are GMT -5. The time now is 03:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration