LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Upgrade of 7-year-old machine from Ubuntu 16.04.5 LTS to 18.04.1 LTS

Posted 09-04-2018 at 07:05 PM by flshope
Updated 09-06-2018 at 09:07 PM by flshope (clarification)

I recently upgraded my primary computer from Ubuntu 16.04.5 LTS to 18.04.1 LTS (hardware summary below). I have the machine set up for dual-booting with Ubuntu and Debian 9.5 from separate hard drives, each with its own Grub installation. My preferred window manager is Gnome Flashback although I had been using Unity for a while toward the end of 16.04.

As I have done in the past, I installed the 18.04 upgrade using the Update Manager (UM). The upgrade process went smoothly in terms of demands on the user, but I did notice that the UM repeatedly tried to install the Nvidia-304 graphics driver (nvidia-304/now 304.135-0ubuntu0.16.04.2 amd64), which was used under 16.04; but the UM ran into dependency problems and eventually gave up. I ended up with the Nouveau driver (xserver-xorg-video-nouveau/bionic,now 1:1.0.15-2 amd64).

I make handwritten running notes on whatever happens during the upgrade. The installer also generates some log files (e.g., /var/log/installer/syslog).

Before I started the UM, I shut down all applications except the System Monitor. The System Monitor is comforting in the sense that it gives independent verification that the system has not crashed even though nothing seems to be happening in the installer window for many minutes -- a situation that happens all too frequently. On my 1 MB/s internet connection, it took 42 minutes to download the 1.9 GB of upgrade files.

At some point in the installing/unpacking process, the System Monitor window went gray and stopped changing. So I did a force quit to get rid of it. During the setting-up/unpacking process, I noted many messages indicating various files or directories that could not be opened, followed by the specific message that "This likely means your installation is broken ...". At about 2 hours into the upgrade, the Installer window stopped showing any activity and went all gray. After a while it started slowly varying from gray to normal white. After too many minutes, the text started scrolling again (whew!). At about 2 h 20 m the installer box went back to no activity with the slow variation of shading again. There was a progress bar on the screen, but it showed no progress or change. However, my mouse was still active and I could move the Installer window around the screen, from which I concluded the machine had not crashed. At about the 3 h 10 m point, the process indicated that the upgrade was complete and the system was ready for restart.

I did the restart using my BIOS hot key (F12 on my machine) to select Ubuntu's disk and Grub menu. The boot went all the way to the log-on GUI (perhaps usually called the "greeter"). At this point, I first saw the font was enormous. After selecting my user name, I clicked on the cog icon to see what desktops and windown managers were installed. I got the following list:
  • Gnome on Xorg
  • Gnome on Flashback (compiz)
  • Gnome on Flashback (Metacity)
  • IceWM session
  • Unity
  • Ubuntu
  • Xfce session

Some of these are present because of my 16.04 installation. The default was Unity but I selected Gnome on Flashback* (Metacity) and proceeded to log on. The log on succeeded, but the desktop icons were enormous and tended to be piled on top of each other. I doodled with applications and found most windows went off screen making many control icons inaccessible. The only exceptions were terminal and gedit, which fitted to the screen with very large fonts but were usable.

Using the command 'xrandr' I discovered that Nouveau was locked in on a screen resolution of only 640 x 480, and I could not find any way to change the resolution. Under the Debian 9.5 boot alternative, the driver is Nouveau and the resolution is 1920 x 1080. So I assume the limited resolution under Ubuntu 18.04 is due to the Nouveau driver. Perhaps the Nouveau installation is incomplete. [I later discovered that there is a Nouveau firmware package recommended but not installed by the Installer.] At the time, I judged the installation as not usable and looked for fixes.

I tried manually installing the Nvidia-304 driver ('sudo apt install nvidia-304/now'), but apt refused to install it due to unsatisfiable dependencies.

Next, I looked at the Nvidia web site

https://www.nvidia.com/Download/driv...x/137276/en-us

which recommended the proprietary 390 driver for my graphics card (GF108 [GeForce GT 430]). I downloaded a file with the name 'NVIDIA-Linux-x86_64-390.87.run', but I did not know what to do with a '.run' file. However, I did note that 'apt list --all-versions|grep nvidia' returned two records of interest:

Code:
...
nvidia-driver-390/bionic 390.48-0ubuntu3 amd64
...
xserver-xorg-video-nvidia-390/bionic 390.48-0ubuntu3 amd64
...
Of course, none of this is any guarantee that the 390 driver would work or even install (I have been burned before). However, a general Google search suggested the link

https://linuxconfig.org/how-to-insta...c-beaver-linux

which recommended the terminal command

Code:
ubuntu-drivers devices
This command yielded the following:

Code:
== /sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000DE1sv00003842sd00001430bc03sc00i00
vendor   : NVIDIA Corporation
model    : GF108 [GeForce GT 430] (GeForce GT 430)
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin
So I installed the 390 driver:

Code:
sudo apt --install-recommends install nvidia-driver-390
The result upon reboot was a display much as it had been under 16.04 and fully satisfactory (a "EUREEKA!" moment, as it were).

*If you are not familiar with Flashback, it has the appearance of an old Windows-like desktop, with applications icons stored in a desktop folder that is automatically displayed on the screen after log in. Work spaces are chosen on a bar at the bottom of the screen. There is a top bar where you can place application icons that you always want visible and accessible.

#######################################################################
Pogo2011 hardware summary
Vendor: Pogo Linux
Motherboard: Gigabyte Technology Co. GA-970A-U
CPU: AMD Athlon(tm) II X3 450 Processor, 3200MHz, 64 bits
RAM: 8 GB
Display: NVIDIA Corporation GF108 [GeForce GT 430]
Network: Realtek Semiconductor RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
Hard disks: 3 SATA drives (two 500 GB, one 1 TB)
Operating Systems (dual-boot): Ubuntu 18.04.1, Debian 9.5
Posted in Uncategorized
Views 547 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration