LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Upgrade of 2003 machine to Debian 8 -- a bumpy ride

Posted 10-19-2015 at 11:53 AM by flshope

I have a 2003-vintage machine that remains useful despite its age, and I am determined to keep it running as long as I can as a backup to my main machine. The 2003 machine was born with Red Hat 9, migrated to Ubuntu, and finally to Debian 7 last December when Ubuntu dropped support for the display card.

Yesterday, after much study of the release notes,

https://www.debian.org/releases/stab...e-notes.en.txt

I decided to proceed with the upgrade to Jessie. I was really worried about failure of the upgrade because the release notes said something about Gnome 3 not including Flashback Services (which I had been using under Ubuntu and Debian 7) and that Gnome 3 now assumed an SSE2 instruction capability (which the machine doesn't have). Well, "Damn the torpedoes, full speed ahead".

Since this was my first Debian upgrade, I read the release notes in considerable detail. Many experienced Debian users say the upgrade is easy -- just three simple steps. However, the upgrade notes are 30 pages in pdf form and say to do a lot more stuff to improve chances of success. So I made detailed notes on a text file of the recommended apt-get, aptitude, etc., commands.

The notes say to do the upgrade from a virtual console (VC, e.g., ctl-alt-F1) and not from a terminal from within the GUI, which might become unstable during the upgrade. And most certainly, do not use the Update Manager. OK, noted. With the VC, there is no mouse capability. The notes say to use the screen program, which allows copying text from the screen and pasting onto the command line using only the keyboard. So I had to learn to work that.

https://www.gnu.org/software/screen/manual/screen.html

One glitch I hit was that none of the commands copied/pasted from my text file to the command line would execute in the VC. Turns out that I had copied them from a pdf I made with Chromium. Apparently, that copy process put some undisplayable characters on the text file that interfered with their execution. I then found that Opera would convert the original HTML to a simple text file with no invisible formatting characters. Problem solved.

I ran the specific backups as recommended in the release notes as well as for my own application files. I ran the package update under Wheezy and cleared any pending actions. I edited sources.list to show only "jessie", saving a backup of the original. I also created a link on my home directory to the directory where I was keeping my upgrade-related files -- I didn't want to have to cd through a bunch of directories to get there when I started the upgrade.

So my plan was to:
- shell out to a VC (leaving the GUI running)
- log in as my administrative user name
- start screen
- start script
- open a second window to display my text file with less
- copy/paste commands from the second window to the first

Before I started the actual upgrade process, I did a lot of testing in the VC to gain confidence since I haven't used VCs much. I used ping to verify that I had internet access. I doodled with aptitude and ran the recommended apt-get commands that don't do anything except display information.

Well, the plan worked OK, ... up to a point. I won't list the commands here -- they are all in the release notes -- and the selection would vary with hardware and software configurations. Of course, I did the standard sudo apt-get update, sudo apt-get upgrade, and sudo apt-get dist-upgrade, and some other stuff from the release notes I thought relevant.

The process took about 4 hours, with me mostly just watching as downloads and setups occurred, occasionally answering a question in a dialog box. Eventually, the final command prompt appeared, which seemed too inconspicuous for such a long process. I did observe happily that Flashback and my expected new linux kernel were downloaded and installed. When the final prompt appeared, per instructions, I verified that the new kernel was installed (though not yet running, of course) and purged the old package files. Then I rebooted from the VC using sudo shutdown -r now.

The machine booted to a blank screen (yep, a torpedo got me). I let it "cook" for about 5 minutes and decided it had gone as far as it was going to go. So I shelled out to a virtual console, which was fully visible (whew!). I didn't take that for granted because when Ubuntu screwed me, booting to a blank screen, I could not even do that! Even the VCs were blank.

My first thought was that the machine was booting into Gnome 3 and that it would not run. So I used aptitude to remove Gnome and install xfce. As far as I could tell, that all worked. Except that the machine still booted to a blank screen. After browsing with aptitude for a while to identify options, I noted that Bumblebee-nvidia was available for installation. I had been using this successfully under Ubuntu until some routine software update rendered it unusable. So I installed it. The install put up a note that said xorg.conf would have to be manually modified to make Bumblebee work. I could not find a file named xorg.conf and had no idea how to configure it anyway. I did look at the Bumblebee home page on launchpad.net, where someone commented that they didn't think xorg.conf was even accessed by Bumblebee. Whatever! So I let the install proceed.

When I rebooted, I got a log-on GUI with both xfce and Flashback listed among the desktop choices. Seeing Flashback surprised me because of the comment in the release notes. Were the release notes out of date, or did the upgrade process note that Flashback was installed under wheezy and either leave it alone or update it? I have no idea -- there are so many black boxes in this business. However, both of those desktops worked; and I consider the upgrade to Jessie successful. Including a little time off for lunch and supper, the entire upgrade, from start to the successful log-on GUI, took about 7 hours. It probably took at least 14 off my lifespan.

---------------------------------

Just for reference, this machine is described as follows:

PogoLinux Altura Workstation (32 bit)
Athlon-XP 2400+ (2.0 Ghz) 266 Mhz FSB Processor
Asus A7V8X KT-400 Chipset Motherboard
1024 MB PC2700 DDR333 Memory (2 X 512 MB)
(2) Maxtor 120 GB UDMA-133 7200 hard drives
NEC 40X / 10X / 40X IDE CD-RW drive
Gainward (nVidia) GeForce4 Ti-4200 64 MB AGP video adapter
Creative SoundBlaster Live Value
Intel EtherExpress Pro 100+ adapter
82540EM Gigabit Ethernet Controller
Posted in Uncategorized
Views 1853 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration