Visit Jeremy's Blog.
Go Back > Blogs > flshope
User Name


Rate this Entry

Upgrade from Ubuntu 11.04 to 11.10

Posted 09-03-2012 at 11:25 AM by flshope
Updated 09-05-2012 at 08:37 AM by flshope (Correcting textual errors)

Since this is my first entry, I need to define a few of my boundary conditions. I have two primary computers, both from Pogo Linux. The machines are configured as follows:

- Pogo model Altura M3, purchased Sep 2011
- 3-processor AMD Athlon(tm) II X3 450 Processor, 3200 MHz
- 8 GB RAM
- 2 500 GB Seagate HDs
- GF108 [GeForce GT 430] nVidia Corporation
- Ubuntu 12.04 LTS (64-bit) as of 04 Aug 2012

- Altura Workstation, purchased May 2003
- Single Athlon-XP 2400+ (2.0 Ghz) 266 Mhz FSB Processor
- 1 GB RAM
- 2 Maxtor 120 GB UDMA-133 7200 hard drives
- Gainward GeForce4 Ti-4200 64 MB AGP video adapter
- Ubuntu 11.10 (32-bit) as of 02 Sep 2012

- Brother HL-2140 monochrome laser printer
- Epson Perfection V33 flat-bed scanner
- AT&T DSL internet access
- Dell 14-in. flat panel monitor
- Logitech keyboard and mouse
- IOGEAR KVM switch
- USB printer switch
- Cyberguys RJ-45 ethernet switch to Linksys wireless access point
- 2WIRE wireless router

Primary software:
- NEdit
- Libre Office
- Opera, Firefox, Chrome
- gfortran
- Evince document viewer
- ghostview

The following discussion is how I got to the event listed in the title of this blog entry.

The Pogo2003 machine was originally configured by Pogo with Red Hat 9. Not long after I received the machine, Red Hat dropped support for their free OS. Accordingly, no further updates were available. Somehow, I lived with this situation for about 8 years, updating applications software as long as the updates were compatible with Red Hat 9. Eventually, of course, this situation became an impossible situation. Since the machine was old but nevertheless my only access to the outside world (i.e., the internet), I opted to purchase a new machine Pogo2011 configured with Ubuntu 11.04, which was the current release at the time.

Shortly after receipt of Pogo2011, I upgraded Ubuntu to 11.10 with a lot of difficulty and good help from and some nice people here at LQ. My problems apparently came from having an obsolete sources.list file. There were some issues with getting Unity to work, but these were solved by reinstalling a proprietary display driver from nVidia, which was apparently removed by the 11.10 upgrade. In early August, I again updated Pogo2011's Ubuntu to 12.04 LTS. That took nearly 7 hours but was largely uneventful and ultimately successful.

Back in March 2012, when I was confident that Pogo2011 was stable under Ubuntu 11.10, I installed 11.04 from CD on Pogo2003, overwriting Red Hat 9. That was largely uneventful and successful, too.

Upgrade from Ubuntu 11.04 to 11.10

After a month of stable operation on Pogo2011 with Ubuntu 12.04 LTS, I upgraded Pogo2003 from 11.04 to 11.10. This is the OS configuration I am currently using.

The Pogo2003 upgrade to 11.10 was completed yesterday. The upgrade took about 4 hours at DSL speeds (about 80 KB/s) for a 683 MB download + installation + cleanup. I had no difficulties during the upgrade process.

However, there are several problems with the Pogo2003 installation, none debilitating. Under 11.04, the machine supported a HP Laserjet 5L printer; but with the 11.10 upgrade, the printer no longer prints. The same thing happened when I upgraded Pogo2011 to 11.10. I worked a long time trying to get the HP to work on Pogo2011, but eventually I gave up and bought the Brother HL-2140 (there is story there, too, which maybe I'll blog eventually). Today, both machines are working well with the Brother shared through a USB switch.

Another problem with the Pogo2003 with Ubuntu 11.10 is that Unity appears not to be supported by the hardware, although that explanation is speculative at present. I am unable to configure workspaces in the N X M matrix that worked so nicely under 11.04 (I had an 8 X 8 arrangement). The workspace configuration is apparently limited to 1 row with N workspaces. Ubuntu identified an nVidia proprietary display driver for this machine, which I installed. It had no effect. The commands
gconftool-2 --type=int --set /apps/compiz-1/general/screen0/options/vsize 2
gconftool-2 --type=int --set /apps/compiz-1/general/screen0/options/hsize 2
given in the help facility don't do anything. However, the command
gconftool-2 --type=int --set /apps/metacity/general/num_workspaces 9
does change the number of workspaces in the linear configuration (1 X 9 in this case). I had this same problem on Pogo2011 after the 11.10 upgrade, but that was solved by reinstalling it's proprietary nVidia display driver after the upgrade.

Another problem on Pogo2003 under the new 11.10 is that videos from some sources will not play. However, this problem was present under 11.04, too. Specifically, the magazine site Zinio doesn't display at all. The problem began with an upgrade of Opera and/or Firefox and possibly involves redundant installations of Adobe Flash. For a short time I had a similar problem on Pogo2011, but that was solved deleting all Flash installations and reinstalling. That didn't work on Pogo2003 under 11.04, but I am still working on this.
Posted in Uncategorized
Views 1242 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 02:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration