LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Ubuntu disaster (blank screen after software update), Debian recovery

Posted 12-26-2014 at 07:57 PM by flshope
Updated 01-06-2015 at 08:45 AM by flshope (Correcting directory of grub file)

A few weeks ago, I did a routine Ubuntu software update. When I rebooted after the update, all I got was a blank screen.

Actually, it was just my backup computer, a 2003 Pogo Linux desktop (http://www.pogolinux.com/) whose dated hardware is still working fine. The machine -- Pogo2003 -- was recently updated to Ubuntu 14.04, which caused me some initial display anomalies because Ubuntu dropped the Nvidia display driver I was using (Nvidia-96). The display was pretty messed up but not inoperative. In between struggling with the distorted desktop GUI and shelling out with ctl-alt-F1 to run apt commands, I was able to eliminate my problems by installing Bumblebee-Nvidia. Oh, yeah, I had to abandon Unity and go back to Gnome Flashback Services; but that was OK with me. I find Gnome classic easier to use for what I do, and it doesn't require a petaflop computer for adequate graphics response.

So, there I was, machine working OK, when the Ubuntu Update Manager informs me of a routine software update. I note that one of the updates is for the Nvidia-304 driver, which I am not using. So I click the install button and go back to working on my main machine, a 2011 Pogo Linux desktop. A half hour later, I switch back to Pogo2003 and allow the required reboot to finish the update. Result: I get only a blank screen. So I sit there, waiting, panic-stricken, wondering what to do. After a few long minutes, I get a boom (from the speakers) indicating the GUI is ready for someone to log on. But the screen is still blank. I shell out with ctl-alt-F1, but the screen remains blank.

Over the next several weeks, I try lots of things to get control of the machine. I discover that after a ctl-alt-F1, even with the blank screen, I can still execute commands in the blind. For example, logging in as administrator, I can blindly but successfully execute 'sudo shutdown -h now' to halt or 'sudo shutdown -r now' to restart, blindly entering the password for the administrator when expected. So I can execute commands but can't see the system response. May be useful. I also note that I am not getting the Grub menu during boot, which would allow me to boot to text-only recovery mode, perhaps before the bad video driver can grab screen control.

I do have some bootable disks prepared in advance. The aged machine does not have a DVD drive, only a CD-RW, but I do have several bootable CDs containing various Ubuntu versions. The machine does boot OK off these disks; but, sadly, they do not offer a recovery mode. Worse, even if I try to install, they hang saying something about "bad mirror". Manual entry of various mirror site URLs doesn't make any difference. Perhaps they are not making an internet connection.

I try several hot keys (shift is one that is said to work) during boot that may intervene in Grub's work and put up the Grub menu, but nothing I try works. I always end up the blank screen and an eventual boom from the log-on GUI. I even try blindly logging in through the (imagined?) GUI, but what would I do with the desktop when I can't see anything?

Three times during the several weeks' struggle, the machine did unexpectedly boot all the way to the log-on GUI for reasons unknown and conditions I could not repeat. Since this was unexpected, I didn't have a good plan of action. I looked at the installed video drivers with the Software Center and tried to remove the Nvidia-304 driver, but the system said Bumblebee-Nvidia was dependent on some 304 components. This almost confirmed that the 304 update was what disabled my machine. What I did not know how to do at the time was how to enable the Grub boot menu, which might have allowed me to at least boot into a readable text-only shell. On the final successful GUI log-in, I decided, for reasons no longer apparent to me, to remove the Nvidia-bumblebee driver. I may have thought this action might force the OS to try to find another driver that might work -- certainly a last ditch effort. Of course, it didn't work.

At this point I started considering other OS options. Debian (www.debian.org) offered a live CD download as did Ubuntu for 12.04 and 14.04, but the Ubuntu images would not fit on my CDs. The Debian did fit, and I burned a bootable live CD for Debian 7.7.0 using Brasero (CD Creator didn't seem to offer an iso burner option). With this CD I was able to boot Pogo2003 to a Debian RAM-only configuration but for text-only. I was able to mount my disks (e.g., 'sudo mkdir /SDA1', 'sudo mount /dev/sda1 /SDA1'). The only software included were some the common Linux terminal commands and the editor nano. I doubted that I could do anything with the Ubuntu drivers under Debian, but I did edit /etc/default/grub on sda1 to comment out 'GRUB_HIDDEN_TIMEOUT=0' ('#" inserted in column 1), but I couldn't get 'sudo update-grub' to implement the change. I tried rebooting to Ubuntu, shelling out with ctl-alt-F1, and executing 'sudo update-grub' in the blind, but that apparently didn't work (don't know why). No grub menu on reboot.

Seeing no other remaining options, I simply tried to install Debian, over writing Ubuntu. Again, I got the "bad mirror" message, but Debian offered to install without mirror access. This was successful: reboot resulted in a fully visible text shell. I immediately activated the Grub boot menu, which appeared on reboot as hoped. All of my disks were mounted and I had access to the USB ports by way of manual mounting (e.g., 'sudo mkdir /media/USB1' and 'sudo mount /dev/sdc1 /USB1'). I apparently did have internet access, as pings to known web sites were returned. However, I did not have a GUI. I did have 'aptitude', but the 'sources.list' file was set up only to access the CD, which did not include a GUI.

I had previously downloaded "The Debian Administrator's Handbook -- Debian Wheezy from Discovery to Mastery" by RaphaŽl Hertzog and Roland Mas (http://debian-handbook.info/get/now/). They gave a current recommended 'sources.list', which I moved from Pogo2011 to Pogo2003 via a USB flash drive. When I ran 'aptitude' and updated the packages list, there were thousands more packages to consider installing, including Gnome. So I started the process to install Gnome. The process ran for about 2.5 h and then appeared to crash after downloading something called Dropbox. I let it alone for about 30 min and then tried to kill it without success. Finally, I did a ctl-alt-del reboot and started 'aptitude' again. 'aptitude' indicated it had been interrupted and that 'dpkg --configure -a' should be executed to resume. The install then finished quickly. After reboot, I was presented with a beautiful full-GUI log-on screen. I logged on with Gnome Classic and was off and running again, a "EUREEKA!" moment.

And for a moment there, but just a moment, I felt like a steely-eyed computer geek.
---------------------------------
Just for reference, this machine is described as follows:
Altura Workstation (32 bit)
Athlon-XP 2400+ (2.0 Ghz) 266 Mhz FSB Processor
Asus A7V8X KT-400 Chipset Motherboard
1024 MB PC2700 DDR333 Memory (2 X 512 MB)
(2) Maxtor 120 GB UDMA-133 7200 hard drives
NEC 40X / 10X / 40X IDE CD-RW drive
Gainward GeForce4 Ti-4200 64 MB AGP video adapter
Creative SoundBlaster Live Value
Intel EtherExpress Pro 100+ adapter
82540EM Gigabit Ethernet Controller
Posted in Uncategorized
Views 1959 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration