LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Gnuplot aborts Ubuntu 16.04 LTS upgrade installer

Posted 09-16-2016 at 02:02 PM by flshope

A week ago I decided to proceed with the upgrade from Ubuntu 14.04 LTS to 16.04 LTS. I always dread having to do these upgrades because it always means trouble, and this one was no exception.

As instructed by the release notes

https://wiki.ubuntu.com/XenialXerus/ReleaseNotes

I started from the Update Manager, which offers the LTS upgrade once it has been made available three or four months after the initial release in April. I have made it a practice to keep running handwritten notes of what happens during the upgrade because I never know when I might loose the machine or end up with a blank screen after reboot. This blog entry is reconstructed from those notes.

Early in the upgrade process, after fetching some files, and proceeding to "calculate changes", the upgrader put up a dial box that said "Could not calculate the upgrade", "An unresolvable problem occurred while calculating the upgrade.", "... please report this bug using the 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal (see attachment). When I clicked the 'Close' box, the upgrade process aborted but restored the 'sources.list' to 'trusty' corresponding to the 14.04 installation. Per instructions, I ran

Code:
ubuntu-bug ubuntu-release-upgrader-core
in a terminal, which reported that the bug had already been reported. Firefox was then automatically started and opened to a web page at the URL

https://bugs.launchpad.net/ubuntu/+s...r/+bug/1384946

titled "Trying to upgrade to utopic, cannot compute changes due to gnuplot" and dated 2014. The text indicated that some rogue gnuplot installation not from the Ubuntu repository was somehow interfering with the upgrade process. The original poster of the bug report said that when he uninstalled gnuplot, his upgrade ran successfully. I use gnuplot daily and installed it from the Software Center when I first acquired Ubuntu 11.04. Gnuplot, when first opened in a terminal, was indicating version 4.4. So I opened the Software Center and removed gnuplot, but the upgrade failed as before with the same error dialog box. I ran gnuplot from a terminal and -- surprise -- it still ran and indicated version 4.4. Next, I ran

Code:
apt list --installed|less
which gave the following condensed results (along with output lines for all other installed packages)

gnuplot-nox/now ... 4.4
gnuplot-x11/now ... 4.4

Next, I ran

Code:
sudo aptitude purge gnuplot-nox/now
This worked and gnuplot no longer would execute from a terminal. Note: it is necessary to have closed the upgrader; otherwise the sources.list will remain modified to 'xenial' and will abort the 'aptitude' command.

After this, the 16.04 upgrade proceeded as hoped (without aborting). The file download (at 1 MB/s) took about 30 minutes. Installing the upgrades took about 2-1/4 hours (AMD Athlon(tm) II X3 450 Processor). The reboot into 16.04 was normal. Most of my software choices (including gnome flashback) were installed and working. I did have to install gnuplot (now at version 5.0) and emacs (version 24.5.1) from the Software Center, and they are both working.

I am now tabulating the inevitable anomalies as a result of the upgrade and searching for work-arounds.
Attached Images
File Type: png Screenshot from 2016-09-09 10:03:50.png (34.3 KB, 2 views)
Posted in Uncategorized
Views 1347 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration