LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Difficulty resetting the default browser in Debian/Xfce

Posted 03-21-2020 at 01:48 PM by flshope

This blog entry refers to Debian 10.3 and Xfce 4.12 on a desktop machine.

On a whim, I decided to reset my default browser from Chromium (Version 80.0.3987.132) to Firefox (version 68.6.0esr). Shortly thereafter, I decided to go back to Chromium and reset the default at Xfce menu item

Code:
Applications/Settings/Settings Manager/Preferred Applications/Web Browser
Then I clicked on a link in a daily email in Thunderbird for my local newspaper. The link opened in Firefox (which does not work as well as Chromium for this application). I checked the Xfce Settings Manager again, which still showed Chromium as the default. Then I checked Firefox's Preferences, which displayed a note saying Firefox was the default. I hunted around Firefox to see if there was an option to turn it off as the default, but I couldn't find anything. I did the same fruitless manual search in Thunderbird. Then I deleted the entire cookies and history from Firebox -- no loss because I don't use it much anyway. After that, Firefox no longer listed itself as the default browser. But Thunderbird still opened its links in Firefox, and then Firefox again showed itself as the default browser while the Xfce Settings Manager still showed Chromium as the default.

I did a search in Firefox Help and turned up a link that said to execute

Code:
sudo update-alternatives --set x-www-browser /usr/bin/chromium
I ran that, but Thunderbird still auto-selected Firefox to open links. I tried rebooting the machine, but that didn't change anything either.

After looking at the man page for update-alternatives, I ran

Code:
cat /etc/alternatives/x-www-browser
which listed Chromium as the (apparent) default.

With no progress so far, on a whim I logged out of Xfce and logged into Gnome Flashback and then Gnome Classic. Under both, Chromium was shown as the default and Thunderbird opened its links in Chromium. When I logged back in under Xfce (my usual desktop environment choice), Thunderbird started opening its links in Chromium again.

I guess my problem is fixed, but I don't which, if any, of the previous actions solved the problem -- if it is actually fixed.

This post is not intended as a request for help (not that I'd turn down any suggestions), but just a report of what I think is anomalous behavior.
Posted in Uncategorized
Views 5358 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration