LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

Debian 10 Upgrade on 8-year-old desktop machine is successful but with anomalies

Posted 11-12-2019 at 02:54 PM by flshope
Updated 11-23-2019 at 01:00 PM by flshope (correct arithmetic error)

This post is a summary of two anomalous results from upgrading to Debian 10 on my primary desktop computer Pogo2011. The machine was purchased new from Pogo Linux in 2011 with Ubuntu 11.04 pre-installed. It is now set up for dual booting from either Ubuntu or Debian, each OS booting from a separate hard drive and each with its own Grub installation. Prior to the Debian 10 upgrade, the OS was Debian 9.11. At the end of this post is a machine hardware summary.

I spent considerable time working through the Release Notes to understand the recommended actions. I have seen several posted comments that the Debian upgrade is easy: just run the apt update, apt-get upgrade, and apt full-upgrade. However, the Release Notes say to do much more than that. Basically, I followed the releases notes where the recommendations seemed relevant to my situation, but I will not list those details here. What I will describe are several anomalies that I encountered and what I did about them.

I found the Release Notes somewhat ambiguous about whether to run the update from a terminal within the desktop GUI (Gnome Flashback in my case) or to run it in a virtual console using the screen program. Based on comments by other LQ participants, I decided to go ahead and use a terminal started within Flashback. THIS WAS A MISTAKE (in my case, anyway). Toward the end of the full-upgrade step, the screen suddenly reverted to the wall paper of the greeter but without the log-in prompt -- that is, I lost all access to my terminal screen where the upgrade was running. I tried entering ctl-alt-F1 and logging back in, but this simply reverted to the greeter wall paper. I was able to get back in as my alternate admin user, su to my original user, and access the script file (I used tail typescript). When the typescript file stopped changing, I assumed the upgrade had finished and then did a cold restart.

After reboot, I encountered two anomalies:
1. Flashback no longer displayed the icons in my Desktop folder on the desktop display. I believe this is a known bug based on internet searches. Of course, I could still open the file manager to the Desktop folder and retrieve the functionality of desktop icons. I tried Xfce, which seemed to be working, including displaying the desktop icons. Xfce is now my standard desktop environment.
2. Thunderbird would no longer start but gave a message box indicating that an instance of Thunderbird was already running. Running dmesg gave a screen of messages indicating that apparmor had denied some operations related to Thunderbird. I tried several other desktop environments that were installed, but Thunderbird failed the same way under each. An internet search turned up a fix at the following link:

https://bugs.debian.org/cgi-bin/bugr...cgi?bug=928178

The fix is to disable apparmor for Thunderbird with the command

Code:
sudo aa-disable /etc/apparmor.d/usr.bin.thunderbird
I did have to install apparmor-utils from the repository to enable aa-disable, since apparmor-utils was not installed during the upgrade.

Aside from these two glitches, my Debian 10 upgrade appears to be successful.

========================================================================
Pogo2011 machine description

Pogo Linux Altura M3 Desktop Workstation
AMD Athlon II X3 445 Triple-Core, 3.1 GHz (64 bit)
8GB DDR3 1333 Mhz Non-ECC Unbuffered RAM
Two Seagate Barracuda 500 GB 7200 RPM hard drives
Seagate Barracuda 1 TB HDD SATA
GeForce GT 220 512 MB graphics card
Posted in Uncategorized
Views 1579 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 02:55 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration