LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Blogs > flshope
User Name
Password

Notices


Rate this Entry

15-year-old desktop kept alive with Debian 9 and Xfce (but not GNOME)

Posted 06-29-2018 at 11:25 AM by flshope

I have a 15-year-old Pogo Linux Altura desktop machine using an AMD Athlon(TM) XP 2400+ 2GHz processor. I call it Pogo2003. The machine has 1 GB of RAM and two 120 GB hard disks. Despite its age, the machine shows no indication of hardware deterioration. So it has become a bit of an obsession and hobby of mine to keep it running with a current operating system. It serves as one of two backups to my primary machine (Pogo2011), which is only seven years old.

Until recently, the machine had been running Debian 8.10, but with the recent announcement of end of life for Debian 8, I decided to risk installing Debian 9. The machine has had a series of OS's, from Red Hat 9 to Ubuntu 14.04 when a routine software update rendered it unbootable. I thought the machine was a goner then, but on a whim I tried Debian 7 and it booted just fine after some tweaking.

My OS major upgrades or installs have rarely been textbook smooth. For Debian 9.4, I decided to do a clean install, but my first try was a total failure. I used a current net install CD (no bootable DVD capability) and this went smoothly. For the choice of installed software, I chose the defaults and GNOME, which worked before. On the first boot after the install, the machine crashed after a few lines of splash. Over the next several days, I tried lots of ignorance-based actions to get the machine to boot. I entered the Grub recovery mode and was able to log in as root and look at the disks, but I did not get a network connection and could not download anything. I tried using the installer's rescue mode but I couldn't get a network connection there either. On a whim, I discovered that under the Grub recovery mode, if I typed "NetworkManager", the network activated. I had speculated that the installer chose a display driver that didn't work with my display adapter -- this happened to me previously. So I tried installing the Bumblebee driver, which had worked on a previous installation disaster. It made no difference. The machine still crashed at the some point early in the splash. Finally, after browsing the kern.log file once again, I noticed that GNOME was generating messages indicating segmentation faults. I don't know what that means -- Google says it means software is trying to access memory without authorization -- but I know segfaults are not good. Since it was my choice to install GNOME as part of the Debian 9 install, I decided to do a second clean install without that GNOME choice but with Xfce. Again, the install went smoothly, though much faster -- I guess GNOME includes a lot more stuff. This was my "EUREEKA!" moment: the machine booted all the way to the log-on GUI. I was able to log on and do stuff. GNOME had always worked for me before (though I always used flashback), but I guess it expanded beyond my machine's hardware.

At this point I am almost happy with the machine -- almost. I have had too many full-machine crashes during which I cannot even raise a virtual console (e.g., ctl-alt-F1). I must do a reset-button reboot or a forced power off (ctl-alt-del does nothing). The crashes seem to be associated with maximizing or resizing an application window, though the failure is intermittent. I have not had a crash when I did not resize a window. I didn't see anything in the kern.log that I understood, though the last entries after a crash always seem to come from the Nouveau display driver. Perhaps I should file a bug report.

One thing I did do just today was upgrade the machine's memory to the motherboard capacity of 3 GB. The machine still had its vendor installed 1 GB with two 512 MB modules. To my surprise, I was able to find RAM modules with the motherboard specifications (PC2700 DDR333 184 pin) at

https://www.MacSales.com
(Other World Computing)

I don't know if this has affected my crashing problem, but the 1-GB modules only cost $11 each. If I learn anything else about this, I'll post it as a comment.

Machine:
Pogo Linux Altura (purchased 2003)
CPU: AMD Athlon(TM) XP 2400+ 2GHz (32 bit)
RAM: 3 GB
Current OS: Debian 9.4
Desktop Environment: Xfce4
Disks: 2 120 GB Maxtor IDE
Posted in Uncategorized
Views 764 Comments 12
« Prev     Main     Next »
Total Comments 12

Comments

  1. Old Comment
    I was given a Dell Inspiron 700m yesterday and plan to install Slackware on it. Hopefully I have less problems than what you ran into. It has an Intel pentium m 2.0 Ghz processor and 2 GB of RAM. Not sure yet how large the hard disk is just yet. These specifications should be sufficient for any distribution if configured properly.
    Posted 06-29-2018 at 01:54 PM by mralk3 mralk3 is offline
  2. Old Comment
    Best of luck with your Slackware install, mralk3. If I can't resolve my crashing problem, I might need to find other alternatives. Maybe Slackware is a good choice for older hardware.
    Posted 06-29-2018 at 02:53 PM by flshope flshope is offline
  3. Old Comment
    Thanks!
    Posted 06-29-2018 at 08:17 PM by mralk3 mralk3 is offline
  4. Old Comment
    Well everything works as expected on this 15 year old laptop. I ended up with Slackware 14.2 32 bit. I did not have to jump through any hoops at all. I will be adding a wireless N usb WiFi network card because the internal NIC only supports wireless a/b protocols. Most recent routers only support g and n wireless protocols these days.
    Posted 07-01-2018 at 09:24 PM by mralk3 mralk3 is offline
  5. Old Comment
    Excellent news. I did a quick Google search on "Dell Inspiron 700m" and saw links going back to 2004. Your painless install is certainly a strong recommendation for Slackware. May your wireless network card connect on the first try!
    Posted 07-02-2018 at 08:20 AM by flshope flshope is offline
  6. Old Comment
    Here is a screenshot of the Inspiron 700m.

    https://www.linuxquestions.org/quest...ml#post5876299

    Using a Ralink USB WiFi dongle.
    Posted 07-06-2018 at 10:12 AM by mralk3 mralk3 is offline
  7. Old Comment
    Looks like you are up and running, mralk3. Way to go!
    Posted 07-06-2018 at 11:51 AM by flshope flshope is offline
  8. Old Comment

    Debian 9/Xfce crash resolution (work around)

    Addendum: Debian 9/Xfce crash resolution (work around)

    After installing Debian 9 with Xfce, I quickly discovered that the machine usually had a crash (freeze, lock up, ... whatever) after double clicking the top bar of an application window to maximize the window. It didn't happen every time, but most of the time. The last messages in the previous kern.log after rebooting usually seemed to be coming from the Nouveau graphics driver.

    I doodled with things a while and finally came up with what might be a work around: at the Xfce menu item:

    Code:
    Applications/Settings/Window Manager/Advanced
    I set 'Double click action' to 'Nothing', which had been set to 'Maximize window'. Since doing this a week ago, I have not had a crash.

    Machine Description:
    Pogo Linux Altura (purchased 2003)
    CPU: AMD Athlon(TM) XP 2400+ 2GHz (32 bit)
    Motherboard: ASUSTeK Computer INC. A7V8X
    Display: NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]
    Display driver: X.Org X server -- Nouveau display driver
    RAM: 3 GB
    Current OS: Debian 9.4
    Desktop Environment: Xfce4
    Disks: 2 120-GB Maxtor IDE hard disks
    Posted 07-10-2018 at 12:06 PM by flshope flshope is offline
    Updated 07-10-2018 at 07:50 PM by flshope (Accuracy)
  9. Old Comment
    Crap! I just had another machine crash immediately after going full screen with terminal. So my workaround isn't a workaround.
    Posted 07-12-2018 at 10:29 AM by flshope flshope is offline
  10. Old Comment
    Your issue sounds like a problem with the Nouveau graphics driver. I think you are stuck between a rock and a hard place because your machine is so old. It will be difficult, if not impossible, to use the proprietary Nvidia graphics drivers.

    The hard drive on my Dell Inspiron 700m is showing signs of disk failure. There is a consistent clicking noise while the disk is idle. Everything else works great.
    Posted 07-12-2018 at 12:11 PM by mralk3 mralk3 is offline
  11. Old Comment
    Yes, I am being dragged, kicking and screaming, as it were, to that conclusion.

    I guess it is hard to put a positive spin on new noises from a disk drive. At some point we will just have to let these old guys go to their well-earned reward of infinite sleep.
    Posted 07-12-2018 at 12:33 PM by flshope flshope is offline
  12. Old Comment

    Bumblebee display driver displaces Nouveau -- no crashes since

    To recap, after I upgraded my 15-year-old-desktop machine (Pogo2003) to Debian 9.4 from 8.10, I started having regular crashes, frequently but not always after resizing a window. I was running the Xfce desktop environment. I tried adding LXDE to see if the culprit was the DE. It wasn't -- the crashes continued under LXDE as well as Xfce.

    The latest thing I did was install the Bumblebee graphics display driver from the Debian repository. So far I have not had a crash since the Bumblebee install. Guess I'll give it a month or so before claiming problem solved, but I am optimistic.
    Posted 07-31-2018 at 06:41 PM by flshope flshope is offline
    Updated 08-05-2018 at 06:20 PM by flshope
 

  



All times are GMT -5. The time now is 02:19 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration