LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Blogs > LINUX mostly DEBIAN - hardware and software
User Name
Password

Notices


12 happy years of experience with DEBIAN starting from version 5 Sid until the recent 8.3 Jessie.
Before that done 6 years of system administration including a SCO UNIX Server and a couple of Windows Servers and dozens of workstations. The largest system was nearly 100 PC's, devices etc. at 3 locations with LAN and VPN's, Firewall and Phone via landline and VoIP.

I like to experiment and then share the experience. With sharing I may post silly stuff and get corrected - the way to learn something from anybody.

Have fun, insight and maybe share your knowledge with me.
Rate this Entry

Debian 9 - 64bit on ACER E5-573

Posted 08-14-2016 at 08:00 AM by error_401
Updated 11-05-2017 at 05:58 PM by error_401 (Updated for Debian 9)

This is another update on last years laptop with Debian 8.5 in 64bit with KDE
------------------------------------------------------------------------

As google has stopped support for the 32 bit version of chrome I have updated the known laptop with Debian 8.5. Just did a complete re-install from CD-ROM. Easier than to fumble with the 32bit and try to bring it to 64bit. At the same time we'll see what is working now.


ACER Aspire E15 E5-573-74BW

Nice laptop. Nice large screen, keyboard with num block, touchpad. Intel i7 processor and 8 GB of RAM and a huge 1TB HDD.

PREPARATION TO RE-INSTALL LINUX
------------------------------------------------------------------------
Made a CD-ROM with Debian 9 amd64 (64bit version) including firmware. (328 MB image)
Insert and reboot while pressing F12 to access boot menu - Launch CD-ROM - follow installer.
1 hour later install done via cable based LAN and internet connection.

INSTALLATION OF LINUX
------------------------------------------------------------------------

Once I got that figured I installed Debian 9 from CD-ROM by booting into the normal installer.
Worked like a charm. When at the HDD partitioning I have deleted the largest partition, then installed the system into this partition using an automated setup and all into one partition.

The sources.list includes contrib and non-free and at the same time the installe now uncommets the CD-ROM entry from the setup. (As the CD-ROM is normally later not available this gets rid of the nuisance warnings that the source blabla CD-ROM blabla ist not accessible.)

Then installed my usual set of software. See other blog post about software I normally install.

WHAT IS WORKING - WHAT IS NOT
------------------------------------------------------------------------

Working out of the box:
Well - lets write up what did NOT WORK out of the box and the fixes - it's way shorter:

1. Touchpad works out of the box.
SOLVED

2. WiFi (Previously with Debian 8 this was the only downside - The Aceros driver for that chipset is still not available AUG 2017)
SOLVED - in Debian 9 the driver is available from the firmware set.

3. Webcam - out of the box.

4. Power settings - The general profile options work fine. The finer tunings are partially not supported (HDD spin-down, etc.) I'll have to dig into that but simply have no time for that.
PENDING - I will probably set up the laptop again, this time in UEFI mode. Maybe that brings back some control.

5. Screen - (Used to act up on Debian 8 randomly in so far as that with the power safe features it dims but sometimes cannot be woken again and stays dim. To brighten up the screen again I can use "Fn" + "F6".)
This is SOLVED in Debian 9. Screen works correctly.

WORKAROUNDS for Debian 8.x
------------------------------------------------------------------------
Installing a workaround for the wifi proves difficult at best, as many chipsets which were previously working have undergone letter revisions (e.g. from version D to E) and are not currently supported. That means, if you buy today, you most probably have too recent hardware to work out of the box.

USING A USB WI-FI STICK
=======================================
I leave this information about WiFi USB sticks in here for reference.

I have tried a D-Link DWA-171 but the chipset had revision E1 which is not yet supported.
Then changed to a different D-Link device.

D-LINK DWA-140 rev. D2 which is an USB wireless connector.

The respective information is:

Code:
lsusb
output
Device ID 2001:3c20 D-Link Corp.

Code:
lsusb -v
output:

Bus 001 Device 005: ID 2001:3c20 D-Link Corp.
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x2001 D-Link Corp.
idProduct 0x3c20
bcdDevice 1.01
iManufacturer 1 Ralink
iProduct 2 802.11 n WLAN
iSerial 3 1.0

INSTALLATION INSTRUCTIONS

First make sure that "non-free" is enabled in sources.list.
You will need to edit the file and add non-free to the respective lines.
Look it up on the internet using the following search words: debian sources.list non-free

run
Code:
apt-get update
to include the non-free in the sources

run
Code:
apt-get install firmware-ralink
this will install all ralink firmware in preparation for the usb stick.

Plug in the USB stick. It should be recognized right away and nearly
immediately show up on the network manager as wireless device.

POSSIBLE WORKAROUND
=======================================

Using a testing or unstable could help make all work. As from kernel version 3.24 the specific Atheros driver should be available. This is still not true. The ath10k family driver is still not available in kernel 3.24. AFAIK it is available from kernel 3.26 onwards but Debian 8 ships only with kernel 3.24.

As my girlfriend was happy with the WI-FI STICK I've waited for Debian 9 and the WiFi issue is a thing of the past.
Views 554 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 11:58 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration