Welcome to the most active Linux Forum on the web.
Go Back > Blogs > LINUX mostly DEBIAN - hardware and software
User Name


18 years of DEBIAN starting from version 5 "Sid" until the recent 10 "Buster".
Before that done 6 years of system administration including a SCO UNIX Server and a couple of Windows Servers and dozens of workstations. The largest system was nearly 100 PC's, devices etc. at 3 locations with LAN and VPN's, Firewall and Phone via landline and VoIP.

Have fun, and maybe share your knowledge with me.
Rate this Entry

Debian 8 on ACER Aspire E15 - E5-573

Posted 09-09-2015 at 04:29 AM by error_401
Updated 12-18-2015 at 05:19 PM by error_401 (Update)

A new laptop with Debian 8 with KDE

Just bought the latest from ACER an

ACER Aspire E15 E5-573-74BW

Nice laptop. Nice large screen, keyboard with num block, touchpad. Intel i7 processor and 8 GB of RAM.


It took longest to figure out how to enable booting into the BIOS on the Window 8.1 installation.
Had to work through the windows side bar and settings. Had to try several times to get into the advanced start settings. Finally Win 8 decided to give in and let me change the setting in order to be able to access the BIOS on startup. Used F2 during boot.

First thing to do is disable advanced security and UEFI boot. (I disable this option altogether, well aware of what I'm doing.) This brings the BIOS back to a basic BIOS.

I found out later that the tochpad would work fine in KDE when the advanced is turned to basic in the BIOS. So the next time I would change that option at the same time once I'm in the BIOS.


Once I got that figured I installed Debian 8 from CD-ROM by booting into the normal installer.
Worked like a charm. When at the HDD partitioning I have deleted the largest partition, then installed the system into this partition using an automated setup and all into one partition.

Then changed the sources.list to include contrib and non-free and at the same time uncomenting the CD-ROM entry from the setup. (As the CD-ROM is normally later not available this gets rid of the nuisance warnings that the source blabla CD-ROM blabla ist not accessible.)

Then installed my usual set of software. See other blog post about software I normally install.


Working out of the box:
Well - lets write up what did NOT WORK out of the box and the fixes - it's way shorter:

1. Touchpad (To fix the non working touchpad in KDE (I assume also other GUI) enter the BIOS and place the Touchpad into "BASIC") Then it works like a charm.

2. WiFi (This is the only downside - The Aceros driver for that chipset is not yet available SEP 2015, still no solution DEC 2015)

3. Webcam - Status unknown not yet tested

4. Power settings - The general profile options work fine. The finer tunings are partially not supported (HDD spin-down, etc.) I'll have to dig into that but simply have no time for that.

5. Screen - Acts up randomly in so far as that with the power safe features it dims but sometimes cannot be woken again and stays dim. To brighten up the screen again I can use "Fn" + "F6".


Installing a workaround for the wifi proves difficult at best, as many chipsets which were previously working have undergone letter revisions (e.g. from version D to E) and are not currently supported. That means if you buy today, you most of the time have a too recent hardware to work out of the box.

I have tried a D-Link DWA-171 but the chipset had revision E1 which is not yet supported.
Then changed to a different D-Link device.

D-LINK DWA-140 rev. D2 which is an USB wireless connector.

The respective information is:

Device ID 2001:3c20 D-Link Corp.

lsusb -v

Bus 001 Device 005: ID 2001:3c20 D-Link Corp.
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x2001 D-Link Corp.
idProduct 0x3c20
bcdDevice 1.01
iManufacturer 1 Ralink
iProduct 2 802.11 n WLAN
iSerial 3 1.0


First make sure that "non-free" is enabled in sources.list.
You will need to edit the file and add non-free to the respective lines.
Look it up on the internet using the following search words: debian sources.list non-free

apt-get update
to include the non-free in the sources

apt-get install firmware-ralink
this will install all ralink firmware in preparation for the usb stick.

Plug in the USB stick. It should be recognized right away and nearly
immediately show up on the network manager as wireless device.


Using a testing or unstable could help make all work. As from kernel version 3.24 the specific Atheros driver should be available.

As my girlfriend is happy with the WI-FI STICK I'll wait for the next release of my Debian distro.
Views 9649 Comments 3
« Prev     Main     Next »
Total Comments 3


  1. Old Comment
    I have a similar laptop. It's the Aspire E15 E5-571. Mine has the i5 CPU, 8Gb RAM and 1Tb HD.

    It's a pretty nice unit, but feels a little flimsier than my old ASUS.

    I'm an accountant, so the numeric keypad was a big factor in choosing this one. Price was the other main factor...

    Does Windows 8.1 still boot if you disable UEFI? I've not tried it.

    Did you keep Windows on it? The applications I use for work demand Windows, so, unfortunately, I had to keep it. I'm using rEFInd to enable the ability to dual boot. The unit is pretty powerful, so I might end up running Windows inside of VirtualBox, but then I'd have to buy another licence... something I'm not really keen on.

    My distro of choice is Slackware64. The version I've installed is the current development version, and I did not experience any of the troubles you seem to have had. This might be because it has a very late kernel, which probably has better support for the hardware in this unit than the kernel in Debian 8.

    Wifi worked straight out of the box with NetworkManager. The touchpad also worked straight out of the box. I've not yet tried the Webcam, but will give it a go at the first opportunity.
    Posted 09-18-2015 at 06:04 PM by rkelsen rkelsen is offline
  2. Old Comment
    Actually I hate and have killed it altogether on that machine retaining only the restore partition.

    During install I have simply choosen the large windows partition in which win8 is installed as the target for my linux install. No dual-boot or such. Just kept the ability to restore it to windows.

    I'm running windows in virtualbox and for the license I'm not too sure if it would be stretching it if installing with the OEM wich came with the machine itself. You have a valid license to run on that hardware. Nobody said how it has to be run...
    AFAIK there is no specific limitation that it has to run on the hardware directly but is associated with the computer it came with.

    I'm just now updating the tech section above with the latest findings.

    Posted 10-06-2015 at 06:20 AM by error_401 error_401 is offline
  3. Old Comment
    Thank You for the info! I went straight into BIOS and changed the touchpad setting to BASIC---now everything works on my E5-575 running Mint 19.1.
    Posted 12-29-2018 at 01:03 PM by hayseed hayseed is offline


All times are GMT -5. The time now is 09:13 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration