Welcome to the most active Linux Forum on the web.
Go Back > Blogs > drask
User Name


Rate this Entry


Posted 03-15-2011 at 03:53 PM by drask

Okay, my Ubuntu install has been getting raggedy over time. I've upgraded it a couple of times and that's always iffy, plus our network engineers have been busily tying our shares to both our user and computer active directory entries, which worked for a while under Ubuntu using Likewise-open, but then stopped and I haven't had time to figure out why. So baby with the bathwater style, I decided it was time to jump ship and try Debian. I've always heard good things about that distro even before Ubuntu existed (back then I was a SuSE user).

The installation went well. I tried to do a network install but could never get the installer to load my (proprietary) wifi drivers. It kept asking for iwlwifi-5000-1.ucode and iwlwifi-5000-2.ucode and helpfully suggesting that I could load them off a USB or floppy drive. Since I haven't seen a floppy drive in about five years or so, I tried putting the driver files on a USB drive. I tried putting the whole firmware-nonfree squeeze package on the root of the drive, and also copying the individual files out of the package to the root of the usb drive, and changing the names to literally "iwlwifi-5000-1.ucode" instead of "iwlwifi-5000-1.ucode-5.4.A.11", but it never found them, and didn't provide a tool for browsing. I also hit CTRL-F2 and got a busybox terminal and copied the files to /, /root, and /etc/firmware but no luck. Finally, I just downloaded the first cdrom disk, which it turns out is the only disk you really need to get a fully functioning system installed. That install went much smoother. At the end, I still needed to pull out a crossover cable and set my Ubuntu laptop's ethernet port to "share" to get connected to the internet in order to finally install the firmware-iwlwifi package and get this machine swimming on it's own, since I wasn't sure how to install the firmware-nonfree.tar.gz package I had downloaded earlier (it didn't seem to have any install scripts or instructions included).

I had to add my own repositories. I think because the computer was not connected to the internet during the install, it declined to add any repositories other than the CDROM itself, which was also annoying because every time I did a search or update in aptitude it would demand the CDRom be placed back in the drive, and then the next time I would boot the computer it would come up with the CDRom menu which didn't include an option to boot from the hard drive. Now my /etc/apt/sources.list file contains:

# Main
deb squeeze main contrib non-free
deb-src squeeze main contrib non-free

# Security
deb squeeze/updates main non-free contrib
deb-src squeeze/updates main nonfree contrib

# Official Repository Mirror:
deb squeeze main contrib non-free
deb-src squeeze main contrib non-free
I'm sure I need to add more, but I'm just learning my way around.

Since then, adding programs has been very easy. I got Synaptic up and going and felt a lot more comfortable.

I had a bit of a panic a little while ago. I right-clicked on the Applications menu and selected "Edit Menus" and got the familiar two pane window listing directories on the left and applications on the right, but there was no way to add or edit entries. The checkboxes next to the menu entries were missing, and the buttons for adding, editing and deleting folders and items were gone. Installing the "alacarte" package fixed it. Whew!

Due to the new security restrictions on shares, I had to install both wpasupplicant and likewise-open to authenticate to active directory. With wpasupplicant, I had to create a file called "wired.conf" in /etc/wpasupplicant (I used the instructions at Then modify /etc/network/interfaces to start and stop my connection:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
#NetworkManager#iface eth0 inet dhcp

iface eth0 inet dhcp
pre-up wpa_supplicant -ieth0 -Dwired -c/etc/wpa_supplicant/wired.conf -B
post-down killall -q wpa_supplicant
and then update my /etc/NetworkManager/NetworkManager.conf to allow NetworkManager to manage the connection so I get nice update messages if my connection is lost:

Restarted, and my wired network connection finally came up and dropped me into the correct subnet.

I couldn't find a package for Likewise-open (I'm pretty sure I need a few more repositories) but I downloaded the install script directly from and that worked great. I just plugged in my username, password, and domain controller information, accepted the default "add computer to computers OU" and everything went just very nicely.

Excited, I updated my /etc/fstab and added my windows shares in, and fail.
[ 2581.826750]  CIFS VFS: cifs_mount failed w/return code = -22
[ 2720.401691]  CIFS VFS: cifs_mount failed w/return code = -22
[ 2787.137646]  CIFS VFS: No username specified
Turns out the problem was that I was using my credentials files, but didn't have the cifs_tools package installed. Installed and my smb shares started working. Now that I'm finally up and running, it's time to go home and dream of doing something productive tomorrow.
Posted in Uncategorized
Views 1802 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 08:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration