LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Blogs > donatom
User Name
Password

Notices


Rate this Entry

How I got my microphone to work in Arch Linux and How you can save time and frustration

Posted 10-15-2015 at 05:40 PM by donatom
Updated 10-15-2015 at 06:45 PM by donatom

I am writing this to help any poor soul who like me has spent hours trying to get his microphone to work. I am an Arch Linux user and Arch has excellent support. For instance the following website offers all kinds of help to get sound and recording to work: https://wiki.archlinux.org/index.php...roubleshooting

Another website that I found quite helpful is: http://ubuntuforums.org/showthread.php?t=1703092

And of course there are many other sites that offer help to solve audio problems.

Despite an abundance of help in various forums, I still managed to waste more than a few hours trying to solve this problem.

I guess I started off on the wrong foot by purchasing a set of gaming headphones. I didn't realize when I ordered it on Amazon that it was made for newer laptops, smartphones and tablets; it only had one plug for both audio and recording. I played around with it for several hours, thinking that I could figure out a work-around with the help of Google. To no avail; I eventually realized that I needed an adapter that separated the audio from the microphone.

As soon as I received the adapter I fired up my Linux box (multiboot: Arch, Debian, Fedora). I plugged in the adapter to the two front audio ports. Unfortunately I could not use my mic to record anything – no matter how much I googled and how many attempts I made (many of them repeat attempts). Out of desperation I tried Fedora 23, and after a little tinkering – based on all my readings – the mic functioned perfectly.

I could have just forgotten about using Arch with my headphones – but I wasn't comfortable with capitulation. I started up Arch again and made sure that I had the exact same settings on alsamixer as I had on Fedora. But try as I would, the microphone refused to work.

When I was about ready to give up once and for all, I happened to change “Configuration” on pavucontrol (pulse audio volume control). I have two sound cards, one built in and a CA0196 Soundblaster (SB Audigy SE) which I rarely use. I changed the configuration of the unused sound card to “off”. And as they say, the rest is history (my microphone finally decided to play nice).

So make sure you set up alsamixer correctly (after pressing the function key “F4”) by raising the volume on your mic (in my case the front microphone) and by toggling on “Capture” by navigating to it with the arrow key and then pressing the space key until the word “CAPTURE” appears in red above volume (100<>100). And by checking to make sure that you configure the sound card you are using (using pavucontrol/pulseaudio volume controll) so that it shows “Analog Stereo Duplex”. And don't forget to configure any sound cards not being used to “off”. It might save you hours of frustration.
Posted in Uncategorized
Views 2628 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration