Download your favorite Linux distribution at LQ ISO.
Go Back > Blogs > davetesc
User Name


Rate this Entry

kde apps under XFCE

Posted 03-20-2013 at 04:05 PM by davetesc

Having to resort to using XFCE and LXDE as KDE ( my favourite ) is a bit heavy for my no so new laptop, I still use kaffeine, kate and kwrite, this is normally fine but after installing mint14 XFCE and then the above trio of kde apps I found that kaffeine failed with "Cannot open the SQLite database" and both kate and kwrite would crash when I clicked on the open file button.

Running kaffeine from the cli gave a load of errors relating to permission errors in .kde folder.

Looking at the perm for my .kde folder I found it was owned by root and I had no access to it so I ran the following commands and that cured it.

sudo chown -R myusername .kde
sudo chgrp -R myusername .kde
sudo chmod -R a+rwx .kde

After doing this kaffeine, kate and kwrite seem to be working fine.
As a test I created a new user and the .kde folder had correct permissions so I think this only affects users created before the kde apps were installed.
This hasn't happened in the past running kde apps in XFCE and LXDE but it was nice to be able to fix a glitch quite quickly for myself.
I've tried to post this info online but couldn't find anybody posting a similar problem so am writting it here instead.

Posted in Uncategorized
Views 1126 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 08:05 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration